Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

2nd P3P arrived today and... DJI Go app won't connect. Help!

Discussion in 'Pro/Adv Discussion' started by EsteeNJ, Sep 22, 2015.

  1. EsteeNJ

    Aug 25, 2015
    Likes Received:
    Hi guys and gals-

    My 2nd P3P arrived today but it wont connect to any of the devices via DJI GO app that my previous P3P (v1.4) would connect to.

    DJI GO Android v2.2.0, P3P firmware on Samsung Galaxy Edge S6, Samsung Galaxy Tab A, and HTC One m7.

    I have tried un-installing the app then deleting the DJI folder from the file directory of the device before reinstalling, tried multiple cables, tried messing with the USB settings on the devices, all no good.

    After the remote has been plugged into any of the devices for a few minutes this message pops up:

    A lot of people seem to be having issues like this recenty and one person on the DJI forums suggested it may be a defective board in the RC remote.

    Has anyone with this issue found a fix yet?
  2. n3srj

    Feb 23, 2015
    Likes Received:
    Doesn't work with the ios app either!. Flew a few weeks back software updated ipad 2 will not connect to this POS! After reading all the posts on here about what to try short of using a sledge hammer i've tried them all.. Wish i NEVER got sold my p2 at least it was trouble free.

    DJI should change there name to POS! I'm throughly frustrated over this thing. At least it still flies fine.. Just like those 100 dollar quadcopters..
Similar Threads - 2nd P3P arrived Forum Date
2ND GENERATION SHELL FOR P3P???? Pro/Adv Discussion Oct 10, 2016
Just Received 2nd P3P Pro/Adv Discussion May 29, 2016
2nd P3P - will my Go app records keep them separate? Pro/Adv Discussion Feb 24, 2016
Adding a 2nd camera to my P3P; open to suggestions and advice FPV (First Person View) Sep 23, 2015
2nd crash. Need help Phantom 4 Help Monday at 6:57 PM