Solid red lights

Joined
Oct 12, 2014
Messages
5,115
Reaction score
566
Location
Commerce Twp,MI
Dam that looks like its in manual mode, scary as there is no gps or altitude hold., ive flown like that just once or twice.

By the way can we get a video of the quad outside showing the lights
Just what are you talking about? Red LEDs and manual mode.
 
Joined
Oct 12, 2014
Messages
5,115
Reaction score
566
Location
Commerce Twp,MI
hi Jason

Where those rear LEDs go to a slow flashing green there are six or more satellites locked on and your ready for flight. If you only have a flashing red LEDs after compass cal you may have a damaged GPS antenna. You'll have to open up the shell and unscrew the GPS module as the antenna is on the top side of the board. If it's cracked you have to replace it. There's one solder point on the component side and the antenna is double back taped to the board.

today i took the top of and the i couldnt find the antenne on the board:eek:. I changed the gps that is screwed to the top of the body but that doesnt make any difference,so have search further for a solution.
The GPS antenna Is ceramic and it's on the top of the board next to the plastic shell. If the one you exchanged was not damaged and you're still getting red LEDs after compass calibration is it possible there may metal pipes under the area you trying to calibrate the compass. Are you also outside when calibrating the compass?

I would also suggest that you do an advanced IMU calibration and do not waste your time with either the Check IMU Status or the Basic Calibration.
 
Last edited:
Joined
Oct 31, 2014
Messages
1,963
Reaction score
333
Age
49
Location
Manchester UK
Just what are you talking about? Red LEDs and manual mode.
Jason I’m starting to find you very irritating and very rude, you don’t own this forum but yet you act like you do, I was referencing the video, the quad appears to be in manual mode, and I’ve yet to see a video of the quad starting up and showing what lights, let’s try to be respectful and if you don’t like what I post or ask just ignore it.
 
Joined
Oct 12, 2014
Messages
5,115
Reaction score
566
Location
Commerce Twp,MI
Jason I’m starting to find you very irritating and very rude, you don’t own this forum but yet you act like you do, I was referencing the video, the quad appears to be in manual mode, and I’ve yet to see a video of the quad starting up and showing what lights, let’s try to be respectful and if you don’t like what I post or ask just ignore it.
If you were referring to the video I posted of the yellow/black P2 with the telemetry that wasn't in the manual as it locked down with 9 satellites.
 
Joined
May 28, 2016
Messages
11
Reaction score
0
Age
65
The control circuit on the batteries DOES NOT MAKE GOOD CONTACT.
Gently sand down the edges of the battery end that goes in first until it fits nicely. The red lights will be gone.
 

N017RW

Premium Pilot
Joined
May 2, 2014
Messages
8,825
Reaction score
3,124
Location
Palm Beach Co.- FL
Are you referring to the data port pins?

If so, they are spring loaded and may be stuck in the compressed position.

Also gently clean the tips of the pins and the gold pads on the battery where the pins contact. Be gentle such as with a pencil eraser as they are gold-plated and you don't want to remove the gold.

If the battery fully seats against the drone's battery port opening, sanding the rear will not likely make any difference.
 
Last edited:
  • Like
Reactions: jason
Joined
Dec 2, 2018
Messages
22
Reaction score
2
Age
50
hi guys sorry for the late reply but was kind of busy i hooked up the quad to the program again and what i noticed was that in phantom mode it gave normal fly
normal.jpeg



and in naza-mode it gave gps

gps.jpeg


so if it gets dry today i will take it up for a try.
 

New Threads

Forum statistics

Threads
134,518
Messages
1,391,589
Members
98,064
Latest member
mxdjng