P4P Part/Repair Help Needed

DaShu

Premium Pilot
Joined
May 17, 2020
Messages
7
Reaction score
0
Location
Hudson Valley, New York
Hey All,
Crashed my P4P, think it was attacked by a bird while doing a range extender flight test. It fell from roughly 250 feet, broke 2 of the 4 propeller blades, 1 side of the landing gear clean off the other hanging by wires, bent the gimbal arm and the battery popped apart. After installing a new gimbal arm and landing gear, I ended up with all kinds of sensor issues(left, right, rear, downward)... replaced the gimbal ribbon cable twice (1st time 3rd party cable, 2nd was DJI), replaced the ultrasonic downward sensor assembly, replaced the 2 primary boards under the gimbal housing(from a crashed P4P). Good news is I got all my sensors back and was able to calibrate them, the bad news is I still have no camera. Error message says there is a camera sensor error. Does anyone know exactly which board is the camera sensor or what else I can try? The gimbal acts as it should going through self test on startup and goes through the calibration sequence. The device was not powered when I got to where it was crashed so I dont think the gimbal is smoked.... I have been through the gimbal assembly several times and confident all the cables are seated in their connectors correctly....
 

dronesky

Premium Pilot
Joined
Feb 4, 2017
Messages
654
Reaction score
525
Location
Indiana
Hey All,
Crashed my P4P, think it was attacked by a bird while doing a range extender flight test. It fell from roughly 250 feet, broke 2 of the 4 propeller blades, 1 side of the landing gear clean off the other hanging by wires, bent the gimbal arm and the battery popped apart. After installing a new gimbal arm and landing gear, I ended up with all kinds of sensor issues(left, right, rear, downward)... replaced the gimbal ribbon cable twice (1st time 3rd party cable, 2nd was DJI), replaced the ultrasonic downward sensor assembly, replaced the 2 primary boards under the gimbal housing(from a crashed P4P). Good news is I got all my sensors back and was able to calibrate them, the bad news is I still have no camera. Error message says there is a camera sensor error. Does anyone know exactly which board is the camera sensor or what else I can try? The gimbal acts as it should going through self test on startup and goes through the calibration sequence. The device was not powered when I got to where it was crashed so I dont think the gimbal is smoked.... I have been through the gimbal assembly several times and confident all the cables are seated in their connectors correctly....
Isn’t he in New York or somewhere like that for the summer?
Think someone posted that he was heading to New York not sure if he's left yet
 
  • Like
Reactions: DaShu

Capt KO

Capt KO
Premium Pilot
Joined
Feb 13, 2019
Messages
1,891
Reaction score
1,525
Age
68
Location
IRB, Fl
Good luck. He’s the best. Don’t know if he traveled or not with all that’s happening. Talk of closing our FL borders. Ouch
 

New Threads

Forum statistics

Threads
139,059
Messages
1,435,209
Members
100,996
Latest member
Howlr