ESC Error after obstructed rotor - take a peek at my board?

Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Hey everyone, thanks in advanced for any assistance. I have a p3pro that took a topple from a few feet and had its rotor(s) obstructed for a few seconds before i thought to kill it. it started throwing an esc error immediately after and wouldn't take off. I re-calibrated and it seemed to work fine for a few flights, but now won't take off at all.

I popped the top off today to have a peek and don't see any visible signs of trauma to the areas where I assume the ESCs are. When spinning the rotors by hand, 3 feel pretty smooth, while one of them has a bit of a notched sensation as it spins. I can post some better pics / closer up if this thread gains traction. I have a couple new motors coming in the mail, and hopefully won't need a new board too. but wanted to check with the experts.




Going to sift through the forum now and see what data in the logDat file will help me narrow down what my problem may be.

Thanks!

edit: here's a close up of the board: (not sure if the camera flash makes it too shiny, but let me know if you see anything that's obviously not right)
 
Last edited:
Joined
May 2, 2016
Messages
1,484
Reaction score
384
Age
46
Generally when you get the ESC error, the main board needs replacing. I am guessing the mosfets burn up. Or there is some kind of protection built-in. Maybe try pulling the internal SD card and wiping it.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Is there any sort of diag routine I can run that would confirm this? I'm fine with hunting through config files and logs if I must. I don't mind replacing the board if that's what needs to be done, but seems like there should be a way to definitively know what is fried.
 
Joined
Jan 21, 2017
Messages
1,202
Reaction score
238
Age
53
The ESC is your diagnostic.
To what extent/methid it is determining that probably only DJI engineers would know.
It could be sending no current draw which could be caused by an open mosfet or open motor winding.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
so i wiped my SD card completely and formatted on windows, popped the lid back on the bird, and motors all spun right up. log text of that test below. Going to put some screws back in and give it a real test flight. (although i'm sure it will error out as soon as i get this thing back together :) )

-177.983 : 757 : 0 IST8303[2:0x18]:Init...
-177.978 : 760 : 0 IST8303[2:0x18]:set mode failed
-177.978 : 760 : 0 ist83xx:0 ret:-14
-177.978 : 760 : 0 IST8303[2:0x1e]:Init...
-177.973 : 763 : 0 IST8303[2:0x1e]:set mode failed
-177.973 : 763 : 0 ist83xx:1 ret:-14
-177.463 : 1069 : 0 ms5607:0 ret:0 spi_id:0 init ok
-177.102 : 1286 : 0 [BAT]read barcode data success num:1
-177.102 : 1286 : 0 [BAT]read begin:12211232 end:12345678
-177.102 : 1286 : 0 [BAT]barcode[0]:6171152308289
-177.053 : 1315 : 0 eeprom load 0 0 22 32
-177.018 : 1336 : 0 eeprom load 1 32 28 32
-176.983 : 1357 : 0 eeprom load 2 64 34 40
-176.930 : 1389 : 0 eeprom load 3 104 20 24
-176.893 : 1411 : 0 eeprom load 4 128 132 136
-176.787 : 1475 : 0 eeprom load 5 264 128 136
-176.680 : 1539 : 0 eeprom load 6 400 12 16
-176.643 : 1561 : 0 eeprom load 7 416 40 48
-176.592 : 1592 : 0 eeprom load 8 464 9 16
-176.557 : 1613 : 0 eeprom load 9 480 1 8
-176.520 : 1635 : 0 eeprom load 10 488 6 16
-176.485 : 1656 : 0 eeprom load 11 504 4 8
-176.450 : 1677 : 0 eeprom load 12 512 52 56
-176.397 : 1709 : 0 eeprom load 13 568 8 16
-176.362 : 1730 : 0 eeprom load 14 584 7 16
-176.327 : 1751 : 0 eeprom load 15 600 12 16
-176.273 : 1783 : 0 eeprom load 16 616 38 48
-176.220 : 1815 : 0 eeprom load 17 664 12 16
-176.167 : 1847 : 0 eeprom load 18 680 56 64
-176.113 : 1879 : 0 eeprom load 19 744 32 40
-176.060 : 1911 : 0 eeprom load 20 784 1 8
-176.025 : 1932 : 0 eeprom load 21 792 16 24
-175.972 : 1964 : 0 eeprom load 22 816 16 24
-175.937 : 1985 : 0 eeprom load 23 840 1 8
-175.902 : 2006 : 0 eeprom load 24 848 1 8
-175.867 : 2027 : 0 eeprom load 25 856 10 16
-175.813 : 2059 : 0 eeprom load 26 872 36 40
-175.762 : 2090 : 0 eeprom load 27 912 52 56
-175.690 : 2133 : 0 eeprom load 28 968 44 48
-175.637 : 2165 : 0 eeprom load 29 1016 28 32
-175.583 : 2197 : 0 eeprom load 30 1048 18 24
-175.530 : 2229 : 0 eeprom load 31 1072 16 24
-175.495 : 2250 : 0 eeprom load 32 1096 72 80
-175.423 : 2293 : 0 eeprom load 33 1176 24 32
-175.372 : 2324 : 0 eeprom load 34 1208 64 72
-175.300 : 2367 : 0 eeprom load 35 1280 24 32
-175.265 : 2388 : 0 eeprom load 36 1312 96 104
-175.083 : 2497 : 0 mis cali 55 55 17ab fff0 cnt:0
-175.083 : 2497 : 0 imu status:0
-175.083 : 2497 : 0 [hardfault]:******************check fault info and trace ************
-175.083 : 2497 : 0 [hardfault]:-----fault is null: addr(0x40024000),flag(0x842ed686)-----
-175.083 : 2497 : 0 [hardfault]:-----fault is null: addr(0x400241a0),flag(0x8fba5e73)-----
-175.083 : 2497 : 0 [hardfault]:-----task info is null: addr(0x40024340),flag(0x6be944c5)-----
-175.083 : 2497 : 0 [hardfault]:-----trace info is null: addr(0x400244d0),flag(0x62ead5c3)-----
-175.082 : 2498 : 0 [hardfault]:******************check last trace ******************
-175.082 : 2498 : 0 [hardfault]:-----trace info is null: addr(0x40024790),flag(0xa1494ab2)-----
-175.082 : 2498 : 0 [hardfault]:-----wdg_time_info is null: addr(0x40024a50),flag(0x99d96dac)-----
-175.082 : 2498 : 0 startup:4.60070
-175.082 : 2498 : 0 Board:"wm320v2"
-175.062 : 2510 : 1 airport limit inited[1]
-175.062 : 2510 : 1 compass calibration init!
-175.062 : 2510 : 1 [LED] changed: test led when startup
-175.062 : 2510 : 1 app connect changed:last(255) != current(0)
-175.062 : 2510 : 1 assistant connect changed:last(255) != current(0)
-175.062 : 2510 : 1 [FDI MAGN[1]] event:turn on
-175.060 : 2511 : 1 [FDI GYRO[1]] event:turn on
-175.060 : 2511 : 1 [FDI ACC[1]] event:turn on
-175.060 : 2511 : 1 [FDI BARO[1]] event:turn on
-175.060 : 2511 : 1 [FDI AHRS[1]]:turn on
-175.060 : 2511 : 1 [FDI CTRL] event: turn on
-175.058 : 2512 : 1 temp cali (0.000000,0.000000) 0 fw:4 4
-175.058 : 2512 : 1 temp cali 0 bw:0.000000 0.000000 0.000000 ba:0.000000 0.000000 0.000000
-175.058 : 2512 : 1 app temp cali (52.000000,65.008827) aa fw:6 6
-175.058 : 2512 : 1 app temp cali aa bw:0.000036 -0.000560 0.000322 ba:0.000027 -0.000365 -0.002158
-175.002 : 2546 : 4 [esc_is_stall] status changed: last(0xffffffff) != current(0x00000000)
-175.000 : 2547 : 4 [esc_is_empty] status changed: last(0xffffffff) != current(0x00000000)
-174.882 : 2618 : 10 [FDI GPS[1]] event:turn on
-174.502 : 2846 : 29 [Err] OFDM_TX State:0x00000400
-174.230 : 3009 : 42 ESC0 link up
-174.218 : 3016 : 43 ESC1 link up
-174.207 : 3023 : 43 ESC2 link up
-174.195 : 3030 : 44 ESC3 link up
-174.195 : 3030 : 44 esc alive info = 0xf
-173.942 : 3182 : 57 [Err] OFDM_TX State:0x00000000
-173.230 : 3609 : 92 ESC0 version: Protocol = [V1.0] Hardware = "WM320_ESC_V9"
-173.230 : 3609 : 92 Loader = [V01.00.02.02]
-173.230 : 3609 : 92 Firmware = [V01.11.00.00]
-173.222 : 3614 : 92 ESC1 version: Protocol = [V1.0] Hardware = "WM320_ESC_V9"
-173.222 : 3614 : 92 Loader = [V01.00.02.02]
-173.222 : 3614 : 92 Firmware = [V01.11.00.00]
-173.213 : 3619 : 93 ESC2 version: Protocol = [V1.0] Hardware = "WM320_ESC_V9"
-173.213 : 3619 : 93 Loader = [V01.00.02.02]
-173.213 : 3619 : 93 Firmware = [V01.11.00.00]
-173.205 : 3624 : 93 ESC3 version: Protocol = [V1.0] Hardware = "WM320_ESC_V9"
-173.205 : 3624 : 93 Loader = [V01.00.02.02]
-173.205 : 3624 : 93 Firmware = [V01.11.00.00]
-173.057 : 3713 : 101 [FDI AHRS[1]]:ahrs_init begin
-173.042 : 3722 : 102 [FDI AHRS[1]]:bias fdi turn on
-173.042 : 3722 : 102 [FDI AHRS[1]]:init fdi turn on
-173.042 : 3722 : 102 [FDI AHRS[1]]:wait for sensor check
-172.862 : 3830 : 111 [LED] changed: temperature not ready when startup
-172.862 : 3830 : 111 Battery barcode:6171154219220
-172.842 : 3842 : 112 Battery barcode:6171154219220
-172.822 : 3854 : 113 Battery barcode:6171154219220
-171.982 : 4358 : 155 old.IOC reset intelligence_orientation_enabled
-171.982 : 4358 : 155 [BATTERY]:reset default smart cfg - L1:1 L2:2
-171.982 : 4358 : 155 [smart_battery]this fireware calc gohme speed:7.800000 - land speed:2.500000
-171.982 : 4358 : 155 CTRL reset all by rc mode switch
-171.982 : 4358 : 155 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-171.858 : 4432 : 161 Eeprom write offset:1d0
-171.422 : 4694 : 183 [LED] changed: no atti
-170.582 : 5198 : 225 app connect changed:last(0) != current(1)
-170.520 : 5235 : 228 Battery name :ATL NVT DJ005
-170.520 : 5235 : 228 manufacture Date:2015/10/13
-170.520 : 5235 : 228 Serial number :2241
-170.358 : 5332 : 236 counter: 0 timeout_counter0
-170.358 : 5332 : 236 gps init: nack:0 ack:18 false_flag:0
-169.122 : 6074 : 297 [FDI AHRS[1]]:ahrs_init pass
-169.120 : 6075 : 298 [FDI AHRS[1]]:evaluation fdi turn on
-169.022 : 6134 : 303 [LED] changed: temperature not ready when startup
-167.722 : 6914 : 368 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-167.142 : 7262 : 397 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-166.742 : 7502 : 417 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-133.562 : 27410 : 2076 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-133.262 : 27590 : 2091 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-132.482 : 28058 : 2130 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-131.962 : 28370 : 2156 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-130.982 : 28958 : 2205 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-130.582 : 29198 : 2225 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-129.602 : 29786 : 2274 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-129.182 : 30038 : 2295 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-128.002 : 30746 : 2354 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-127.602 : 30986 : 2374 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-126.822 : 31454 : 2413 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-126.202 : 31826 : 2444 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-125.222 : 32414 : 2493 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-124.822 : 32654 : 2513 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-123.842 : 33242 : 2562 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-123.422 : 33494 : 2583 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-122.242 : 34202 : 2642 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-121.942 : 34382 : 2657 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-120.962 : 34970 : 2706 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-120.442 : 35282 : 2732 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-119.462 : 35870 : 2781 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-119.062 : 36110 : 2801 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-118.082 : 36698 : 2850 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-117.662 : 36950 : 2871 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-116.482 : 37658 : 2930 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-116.182 : 37838 : 2945 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-115.202 : 38426 : 2994 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-114.882 : 38618 : 3010 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-112.522 : 40034 : 3128 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-111.902 : 40406 : 3159 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-109.322 : 41954 : 3288 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-108.922 : 42194 : 3308 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-107.942 : 42782 : 3357 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-107.642 : 42962 : 3372 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-106.462 : 43670 : 3431 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-106.142 : 43862 : 3447 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-104.962 : 44570 : 3506 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-104.662 : 44750 : 3521 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-103.682 : 45338 : 3570 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-103.162 : 45650 : 3596 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-102.082 : 46298 : 3650 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-101.782 : 46478 : 3665 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-100.782 : 47078 : 3715 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-100.382 : 47318 : 3735 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-97.802 : 48866 : 3864 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-97.502 : 49046 : 3879 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-94.922 : 50594 : 4008 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-94.622 : 50774 : 4023 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-93.442 : 51482 : 4082 [Ctrl<1>] REQ_RC_NORMAL ATTI ctrl_atti
-93.122 : 51674 : 4098 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
-92.702 : 51926 : 4119 [LED] changed: normal led
-.042 : 107522 : 8752 [M.Start]REQ_RC_NORMAL
-.042 : 107522 : 8752 [Ctrl<2>] REQ_RC_COMMAND ENGINE_START ctrl_engine_start
-.022 : 107534 : 8753 [IOC.CL ] 106.4 Degree
-.022 : 107534 : 8753 [TO.ALT ] 78.270744
1.200 : 108267 : 8814 [esc_is_empty] status changed: last(0x00000000) != current(0x00000008)
1.978 : 108734 : 8853 [Ctrl<2>] REQ_RC_COMMAND ASST_TAKEOFF_HOLD ctrl_asst_takeoff
4.500 : 110247 : 8979 [esc_is_empty] status changed: last(0x00000008) != current(0x00000000)
5.102 : 110608 : 9009 [esc_is_empty] status changed: last(0x00000000) != current(0x00000003)
10.702 : 113968 : 9289 [esc_is_empty] status changed: last(0x00000003) != current(0x00000000)
26.700 : 123567 : 10089 [esc_is_empty] status changed: last(0x00000000) != current(0x00000003)
37.400 : 129987 : 10624 [esc_is_empty] status changed: last(0x00000003) != current(0x00000000)
38.200 : 130467 : 10664 [esc_is_empty] status changed: last(0x00000000) != current(0x00000003)
41.118 : 132218 : 10810 [M. Stop]REQ_RC_NORMAL
41.118 : 132218 : 10810 Motor Start 1 Total 41.16
41.118 : 132218 : 10810 CTRL reset all by motor stopped
41.118 : 132218 : 10810 [Ctrl<2>] REQ_RC_COMMAND ENGINE_START ctrl_engine_start
 
Joined
Jan 19, 2017
Messages
105
Reaction score
50
Location
Smokey Point, WA - USA
I wonder how many other issues (sensor errors, gimbal errors, etc) could be resolved by formatting the SD card. And since that seems to have fixed it, why is it looking at old logs when deciding whether or not things are working right rather than actually just attempting to initialize things and moving forward?
 
Joined
May 2, 2016
Messages
1,484
Reaction score
384
Age
46
I am glad that my suggestion helped. But, I'm guessing that when you update the firmware, you will get the ESC error again.
 
Joined
May 2, 2016
Messages
1,484
Reaction score
384
Age
46
There are several reports from P3 owners that show that just by updating the firmware caused an ESC error. I guess the new firmware is super sensitive to errors or has tighter limits.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
I wonder how many other issues (sensor errors, gimbal errors, etc) could be resolved by formatting the SD card. And since that seems to have fixed it, why is it looking at old logs when deciding whether or not things are working right rather than actually just attempting to initialize things and moving forward?
are you calling me an "it"?? :) I'm just not confident that the fix will hold. so rather than stumble ahead blindly only to have the same issue crop back up tomorrow; i would rather have some inclination of what may actually be wrong.

After owning for just a week, my impressions with DJI quality control aren't too good. Unprofessional spelling errors throughout the app, randmonly asking me to upgrade my controller to the same firmware version it's already on, etc... don't exactly inspire confidence in my flying buzz saw.

/endrant. going to take this thing out in a bit. will report back.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
no luck. Snapped the shell back together/ replaced all of the screws and brought her outside. ESC error persists... does anyone know if it's common for a hardware related esc error to occur intermittently? wondering if there's a loose connection somewhere.

.000 : 113886 : 9262 [M.Start]REQ_RC_NORMAL FAIL, esc error!
28.120 : 130758 : 10668 [M.Start]REQ_RC_NORMAL FAIL, esc error!
31.180 : 132594 : 10821 [M.Start]REQ_RC_NORMAL FAIL, esc error!
33.240 : 133830 : 10924 [M.Start]REQ_RC_NORMAL FAIL, esc error!
39.780 : 137754 : 11251 [Ctrl<6>] REQ_APP_WM610 ENGINE_START ctrl_engine_start
39.800 : 137766 : 11252 [M.Start]ACT.Takeoff FAIL, esc error!
39.820 : 137778 : 11253 [M.Start]ACT.Takeoff FAIL, esc error!
39.840 : 137790 : 11254 [M.Start]ACT.Takeoff FAIL, esc error!
39.860 : 137802 : 11255 [M.Start]ACT.Takeoff FAIL, esc error!
39.880 : 137814 : 11256 [M.Start]ACT.Takeoff FAIL, esc error!
39.900 : 137826 : 11257 [M.Start]ACT.Takeoff FAIL, esc error!
39.920 : 137838 : 11258 [M.Start]ACT.Takeoff FAIL, esc error!
39.940 : 137850 : 11259 [M.Start]ACT.Takeoff FAIL, esc error!
39.960 : 137862 : 11260 [M.Start]ACT.Takeoff FAIL, esc error!
39.980 : 137874 : 11261 [M.Start]ACT.Takeoff FAIL, esc error!
39.980 : 137874 : 11261 CTRL reset all by auto takeoff start fail
39.980 : 137874 : 11261 try auto takeoff, but start motor fail!
40.000 : 137886 : 11262 [M.Start]ACT.Takeoff FAIL, esc error!
40.000 : 137886 : 11262 [Ctrl<1>] REQ_RC_NORMAL ATTI_HOLD ctrl_gps_atti
42.100 : 139146 : 11367 [M.Start]REQ_RC_NORMAL FAIL, esc error!
45.320 : 141078 : 11528 [M.Start]REQ_RC_NORMAL FAIL, esc error!
 
Joined
May 2, 2016
Messages
1,484
Reaction score
384
Age
46
Nope, you just have a defective board. You can buy new ones for around $200. Or if it's under warranty DJI will fix it at no cost, unless you have already taken it apart. In that case, the warranty is void.
 
  • Like
Reactions: p3s_noob
Joined
Sep 16, 2014
Messages
96
Reaction score
15
Location
Des Moines
I had the same experience after a minor impact except it flew several times before the escape error appeared. DJI looked it over and replaced one motor. It's been fine since.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Nope, you just have a defective board. You can buy new ones for around $200. Or if it's under warranty DJI will fix it at no cost, unless you have already taken it apart. In that case, the warranty is void.
Check the enormous images in the first post of the thread--clearly my drone has been opened. also, i don't think there's a blanket answer of "pay 200 dollars and pass go". There has to be a way for it to somehow spit out which ESC or motor is faulty.

I took my FW down from 1.10 to P3X_FW_V01.07.0060 which didn't solve the ESC problem. I then popped the top, and also detached the GPS module from the lid so I could reattach it without needing the lid to be awkwardly lying on top.

well, using the csc to quickly start and kill the motors is working now...

i guess I'll try putting the lid back on and taking it for a test flight.
 
Joined
Jan 21, 2017
Messages
1,202
Reaction score
238
Age
53
As you might have noticed when you took it apart, there aren't separate ESC boards, they are integrated into the main board.
Being that all 4 report errors at the same time, may be a common element such as power regulation to them.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Put the lid back on, tested. Motors started up. Put the screws in, tested. ESC error....

Note, I have over-tightened any screws and not using any after market screws that may be too long and are digging into a component.

formatted SD card and took each screw out 1 by 1 and tested to no avail. Going to take the lid off again. On the plus side I'm getting good at that.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Put the lid back on, tested. Motors started up. Put the screws in, tested. ESC error....

Note, I have over-tightened any screws and not using any after market screws that may be too long and are digging into a component.

formatted SD card and took each screw out 1 by 1 and tested to no avail. Going to take the lid off again. On the plus side I'm getting good at that.

took all of the screws out and go the thing to work again. Put the screws back in and tested after each screw. finally had the bird on with all screws firing and the motors whirling. decided to reboot the bird and received the ESC error after no physical changes.

anyone want to buy this thing? lol
 
Joined
Jan 21, 2017
Messages
1,202
Reaction score
238
Age
53
Could be bad cable, bad connector or bad connection on the board itself where when you button it up, you apply enough pressure to something and the connection breaks.
Does it work snapping the shell shut but no screws? Only motor screws?
 
Joined
May 2, 2016
Messages
1,484
Reaction score
384
Age
46
Check the enormous images in the first post of the thread--clearly my drone has been opened. also, i don't think there's a blanket answer of "pay 200 dollars and pass go". There has to be a way for it to somehow spit out which ESC or motor is faulty.

I took my FW down from 1.10 to P3X_FW_V01.07.0060 which didn't solve the ESC problem. I then popped the top, and also detached the GPS module from the lid so I could reattach it without needing the lid to be awkwardly lying on top.

well, using the csc to quickly start and kill the motors is working now...

i guess I'll try putting the lid back on and taking it for a test flight.
Well, then I guess you goofed up. Especially if it is still under warranty. Why someone takes apart a $1000 toy and voids the warranty when it's a known issue is baffling to me. Let me know how that works out for you.
Maybe you can be the one to figure out why there are all these ESC errors after the firmware update.

As you might have noticed when you took it apart, there aren't separate ESC boards, they are integrated into the main board.
Being that all 4 report errors at the same time, may be a common element such as power regulation to them.
 
Joined
Mar 10, 2017
Messages
38
Reaction score
3
Age
28
Could be bad cable, bad connector or bad connection on the board itself where when you button it up, you apply enough pressure to something and the connection breaks.
Does it work snapping the shell shut but no screws? Only motor screws?
Just got it to work with just the motor screws, but it started throwing ESC errors immediately following a reboot with no other changes. Maybe the slight pressure of turning it on is jarring something loose, like you said.
 

New Threads

Forum statistics

Threads
136,755
Messages
1,414,074
Members
99,400
Latest member
Robert S.