Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Comp-*** calibration story (w/ happy-ending)

Discussion in 'Pro/Adv Discussion' started by rickeyfitts, Aug 25, 2015.

  1. rickeyfitts

    Jun 13, 2015
    Likes Received:
    Solano County, California
    This morning I discovered the origin of the term Compass;

    COMP-lete + ***

    At least, that's how I felt after spending a couple of hours spinning around in the Compass Dance, then finally realizing my bone-head mistake. I hope this story may help someone else (or at least provides a chuckle or two).

    I recently discovered an amazing place to fly nearby; the Benicia Community Park – 11 successful flights there since receiving my replacement P3A two weeks ago (running v1.3.20 firmware, w/ Galaxy Pro 8.4 running Go v2.0.2). Other than an occasional app-crash, the flights have been flawless. I have not re-calibrated the compass on this new bird even once - the pre-flight panel had always reported the compass is A-OK – even so, I always check the sensor values in my pre-flight checks.

    This morning, when prepping for take-off in the middle of one of the baseball fields, I got the compass calibration warning for the first time. The only metal on my person was the zipper in my trousers (and I'd have stripped those off and tried again, if not for the metal in my artificial knee joint that has more metal than a zipper). Each time calibration failed with a warning that there was severe electromagnetic interference in the area, and the sensor values were 'wack.


    When I finally concluded it was not the surroundings, I started looking at a couple of enhancements I added to the 'bird yesterday; Strong Arm reinforcement plates and new “safety pin-style” drop-pin clips, both from UAE-Bits. (I also rooted the tablet and upgraded to Lollypop 5.1.1 last night, but that seemed unlikely to be the culprit).


    So, I removed the metal drop-pin clips and tried again; no change.
    My Trackimo had been on-board for the 11 previous flights with no problems, but just in case, I removed it and tried again: no change.

    I couldn’t imagine how the Strong Arm plates could be the culprit and was not prepared to remove them in the field to test anyway, so I scratched my head again, packed it up and headed for home.

    While pondering the mystery on the drive home, a little lightbulb went off in my pea-brain -- when I originally mounted the Trackimo with Velcro-like strips, I shortened the cloth ribbon on the Trackimo’s plastic quick-release clip and tied it to the landing gear as a safety-tether. Although secure, it didn’t look very clean.

    Yesterday, when adding the Strong-arm plates and drop-pins, I had the brilliant idea of replacing the cloth ribbon with a cheap key-ring looped around the landing gear, which looked much cleaner. When I removed the Trackimo in the field to re-check the compass, I un-clipped the quick-release on the tether, leaving the key-ring still looped around the landing gear -- which happens to be where the compass sensors live.



    When I got home, I removed that stupid key-ring, and viola, the compass again reports Normal! Since I was now a few miles from the Park, I put the key-ring back on and checked it again, and as-expected, it failed with similar sensor values as I was seeing at the Park.

    In retrospect I should have known that was a bad idea to begin with, or at least it should have registered with me a lot sooner when the compass failures began (but at lest my Physical Therapist would probably approve of the compass dances as good knee-therapy, but only if I did it until it hurt ;o)

    On another note, this experience also reminded me just how easy it might be to point the finger at Dji when the 'smoking gun' to a problem/failure is not that obvious (except to someone with a bit more troubleshooting experience or a higher IQ than 'moi).

    Not to say that Dji is always blameless, but things like improper antenna positioning, running on un-optimized multi-use tablets full of bloatware, lack of basic/proper training/planning, (and of course, stupid ideas like my key-ring 'thang), far outnumber cases where a P3 is truly defective (IMHO).

    Anyway, all's-well-that-ends-well. I feel little less-dumb, and will be at the 'Park again after work if the wind doesn't kick-up too badly.

    Cheers! --rickeyFitts
    #1 rickeyfitts, Aug 25, 2015
    Last edited: Aug 25, 2015
    sktool97, jryser, SENC and 3 others like this.
  2. suck it up

    Apr 25, 2015
    Likes Received:
    Very good post!

    It may help a lot of people here.
  3. envisionabove

    Apr 13, 2015
    Likes Received:
    Tim in San Diego
    Manning up! That's great info and well written.
    Most would come hear and say it was the upgraded app or FIRMWARE.

    Thumbs up from me. ;)
  4. Totof1965

    Aug 15, 2014
    Likes Received:
    Thanks for sharing this info.
  5. pounder35

    Jun 20, 2015
    Likes Received:
    Heart of Dixie and Ft. Walton Beach, FL.

    I got a great laugh reading the story. Thanks for sharing the experience.
Similar Threads - Comp *** calibration Forum Date
transfer files from phone to computer Standard Thursday at 10:30 AM
I a Model GL658A C1 cotroller compatable with a P4 Pro? Phantom 4 Discussion Thursday at 9:43 AM
Need new landing gear.. compatability? Phantom SE Sunday at 10:44 PM
If you set a waypoint and remote loses signal, will it complete mission? General Discussion Sunday at 8:39 AM
A complete beginners FPV kit - Parrot Mambo FPV FPV (First Person View) Jan 13, 2018