Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Aircraft Disconnected/Gimbal Disconnected/Battery Temperature N/A

Discussion in 'Pro/Adv Discussion' started by Paonaim, Jun 10, 2017.

  1. Paonaim

    Joined:
    Jun 10, 2017
    Messages:
    3
    Likes Received:
    0
    Hey guys! I just unbox my new drone, flew it once, charged the battery, was going to fly it again but then it said the following "Aircraft disconnected, Gimbal Disconnected, Battery Temperature N/A" I have no idea what's going on. Help?

    The green dot in the gimbal is on.
     
  2. Richard R

    Joined:
    Jan 27, 2016
    Messages:
    2,399
    Likes Received:
    902
    Location:
    Ohio
    What sequence are you turning on things? I believe that with the Go app, you want to first turn on the aircraft, then the remote and finally the app. Things don't connect properly if you don't do it in the right order. (If I got the sequence wrong, I know someone will correct me!)
     
    Paonaim likes this.
  3. Paonaim

    Joined:
    Jun 10, 2017
    Messages:
    3
    Likes Received:
    0
    Hey! At this point I tried every sequence their is and still nothing.
     
  4. Elbert Hill

    Joined:
    Apr 22, 2017
    Messages:
    61
    Likes Received:
    9
    Er ah..excuse me, just want to help out a little bit as far as startup sequence/ The sequence when starting up is, mobile device/remote controller first, and then the aircraft. I just looked it up in the manual before saying anything to make sure I was correct (and I may add it was rather difficult to find it clearly stated. finally found on page 46 ). It's the way I was taught by a friend and I never did bother to question it until reading this post

    There have been a few times I inadvertently skewed the sequence and things just didn't link together quite as smoothly
     
  5. Richard R

    Joined:
    Jan 27, 2016
    Messages:
    2,399
    Likes Received:
    902
    Location:
    Ohio
    Yep, knew someone would correct me. Thank you. I didn't have access to a manual when I first posted. Just wanted to get the OP thinking about sequence. Sounds like he's been through them with no luck. Wish I had more to offer.
     
  6. Paonaim

    Joined:
    Jun 10, 2017
    Messages:
    3
    Likes Received:
    0
    Thank you! Turns out my DJI came defective. I'm waiting on the return shipping label in order to send it back and get a new one!
     
  7. BigAl07

    BigAl07 Moderator
    Staff Member

    Joined:
    Jan 5, 2015
    Messages:
    5,315
    Likes Received:
    3,789
    Location:
    Western North Carolina
    FWIW I don't follow the suggested sequence and it's always connected within a few seconds. Sometimes the Tx first then aircraft then DJI Go but it's hit or miss with our start ups LOL. Maybe I need to pay more attention to it.

    If I had to guess I'd say at least half the time Aircraft is first, then Tx, then DJI Go Ap.
     
  8. Harryp

    Joined:
    Jun 22, 2017
    Messages:
    1
    Likes Received:
    0
    Hi, I had the same problem, finally you could not solve it, you gave back by guarantee?
     
  9. Newly

    Joined:
    Dec 5, 2015
    Messages:
    139
    Likes Received:
    10
    Location:
    BC
    Aircraft Disconnected, Gimbal disconnected, I am having the same problem after installing new firmware and updating DJI Go and remote controller. The last time I flew (several months back the bird was working fine. Any ideas how to further troubleshoot this problem before I send it in for repairs.
     
Loading...
Similar Threads - Aircraft Disconnected Gimbal Forum Date
Aircraft Disconnected, Aircraft Battery temp n/a, gimbal disconnected Standard Aug 3, 2017
Aircraft Disconnected Standard Jul 8, 2018
Aircraft Disconnected and Crash! Phantom 4 Discussion Jul 7, 2018
Aircraft Disconnected Phantom 4 Pro Help Jun 9, 2018
Aircraft disconnected after crash Standard May 14, 2018