Phantom 4 RC Problem no connection indicator and beeping noise gone

Joined
Oct 14, 2021
Messages
4
Reaction score
0
Age
26
Hello guys ! I have problem with my Phantom 4 remote controller! I bought controller second hand and it was working perfect but yesterday when I turned on the RC amd the aircfaft and when I started the linking process controller started flashing blue as it should and when i oressed the linking button on the aircraft the controller stoped beeping and the indicator witch was blinking blue turned off at all and in the same time it disconnected the phone and all the buttons on the RC stopped to make the beep noise ! I turned the RC off and when i tried to turn it on again the indicators for the battery are there but no indicator for connection and there is no beeping sound for welcome or from any of the buttons and when i turn it off there is the sound for turning off but it is not that laud like normal and it is like bugged!If someone knows what i can do please text me!
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,742
Reaction score
2,287
Age
70
Location
IRB, Fl
Sounds like on/off button is getting old. Try holding the second press longer or in a different location. Had one that only worked if pressed on the bottom corner.
 
Joined
Oct 14, 2021
Messages
4
Reaction score
0
Age
26
Thanks for texting me ! I've tried pressing the button from many positions but it is not working for me!
 
Joined
Mar 9, 2020
Messages
238
Reaction score
82
Age
72
I dont know what is wrong with your controller, sorry. But if you need to replace it, I have an extra 300F (which works with all P4s except V2) available in excellent condition. located in Austin TX
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,742
Reaction score
2,287
Age
70
Location
IRB, Fl
Don't know where you ship DJI but they do repair remotes quite inexpensive. Under 100us most.
 

Recent Posts

Members online

Forum statistics

Threads
142,175
Messages
1,461,191
Members
103,958
Latest member
TLL0003