Phantom 2 Vision Plus, V3, Phone not showing Pictures or Video

Joined
Apr 1, 2015
Messages
18
Reaction score
1
Age
57
Location
Virginia Beach
Hello everyone. I've had this quad since new a couple of years ago, and it's always performed like a champ.
Last time out I shot some great construction video and came in for a battery change. Once changed, my phone video/picture feed wouldn't fire up again. The gimble control works, as does the actually taking a picture/video. Problem is all I see on the screen is the never-ending circular dots. When I pull the SD card and plug it in to my laptop, I can see the stills I took, just cant see anything on the phone while I'm taking them but the circular dots.
Any suggestions. I've re-bound the wifi extender, and reloaded the app to the phone, although I probably didnt need to since the gimble control works from the phone as it should.
Thanks,
John
 
Joined
May 20, 2016
Messages
4
Reaction score
0
Age
49
Hey Pigeon, I have the same problem. Tried all the updates I could find, rebound, different phones, still no video. Everything else works fine. Let me know if you find a remedy! Thanks.

Sent from my XT1254 using PhantomPilots mobile app
 
Joined
Oct 10, 2014
Messages
1,833
Reaction score
290
your wifi unit inside the bird is toast.
need to replace that and you'll be back in business.
problem is that whoever has them they are trying to get $200+ for them which is a rip-off.
 
Joined
Apr 1, 2015
Messages
18
Reaction score
1
Age
57
Location
Virginia Beach
Hello Hunch & King,
Hunch, Is the replacement as easy as soldering in a new module, or possibly as easy as just unplug/replug in the new wifi unit? 200 bucks seems pretty rich, but still alot cheaper that a whole new bird.
Thanks,
John
 

New Threads

Forum statistics

Threads
135,767
Messages
1,404,554
Members
98,846
Latest member
Stan Celestian