Phantom 4 takes pictures but not video

Joined
Apr 16, 2021
Messages
5
Reaction score
0
Age
31
So, I own 3 DJI drones, a Spark, Phantom 3 SE, and Phantom 4.

I acquired this Phantom 4 in great condition during a trade on Craigslist, fully inspected the drone, flew perfectly, crystal clear feed.. flew just as well as my previous drones, maybe even better :p (it is my nicest drone afterall), but when I went home to play with it more I noticed that it never wanted to go into video mode no matter what I did, I haven't really bothered researching it or playing with the settings until now (about a year later) since drones have peaked my interest again and I would like to fly again.


Here's some quick info:
It gives a smooth and clear live feed when flying, every function about the drone works and operates flawlessly other than video function.
When taking pictures, it goes in full resolution to my SD card and caches to my phone in 720p I believe as well, perfect functionality.

however, when I switch to video mode, the feed goes black and after 5-10 sec it swaps back to pictue mode, not really sure why.. everything else works just fine.

Have tried using different phones, reinstalling DJI go, reformatting SD card, turning the resoulution in video mode down (before it swaps back to picture mode), and updating to latest firmware.

Here is a youtube video demonstrating the problem :)
in the video, I show the gimbal functions just fine and provides a clear and live feed until put into video mode.

Problem is shown in this Youtube video
 

Droneted

Premium Pilot
Joined
Nov 23, 2015
Messages
1,995
Reaction score
516
Location
Clermont, Florida
I watched your video. I guess I would start by using DJI Assitant 2 and refresh the firmware. If that fails and it probably will my next guess is the video board in the top of the gimbal.
 
Joined
Apr 16, 2021
Messages
5
Reaction score
0
Age
31
I watched your video. I guess I would start by using DJI Assitant 2 and refresh the firmware. If that fails and it probably will my next guess is the video board in the top of the gimbal.
Thank you for your response, I will try refreshing the firmware, if it still doesn't work, do you know if it's easy to replace the board and about how much they run? I looked it up on ebay but I am not sure if I am looking at the right parts.
 
Joined
Apr 16, 2021
Messages
5
Reaction score
0
Age
31
I see, I'm not sure if it would be worth the hassle of attempting to repair it myself just to get video back (assuming the firmware reflash doesn't work), I do have evidence that this *may* have be crashed, I am not completely sure... the only thing I notice off with it is one of the back blinking lights is a very faint red and doesn't blink green like the other side, like the 2 front reds are completely bright and the back right is completely bright red/green, but the back left is faint red/no green at all, there isn't any cracks though.. I got this drone + 3 batteries + case for a used iphone xr with no money involved, it felt too good to be true lol and turns out the drone does have minor defects.

Do you offer repair services?
and
Do you know if the lights going out on the arms is normal with age, or is it an implication of a crash/water damage (maybe from flying in rain I don't know lol)?


Edit: I have not flown any of my drones in any rain/mist/fog or in clouds ever, so I'm suspecting maybe previous owner did, not sure.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,836
Reaction score
3,894
Location
Western US
I'm curious about the specs of your SD card and if you've tried others.
 
  • Like
Reactions: Capt KO
Joined
Apr 16, 2021
Messages
5
Reaction score
0
Age
31
I'm curious about the specs of your SD card and if you've tried others.
It's just some old 16gb sandisk one that came with my Phantom 3 standard, do you think maybe that could be causing it? It works fine for P3s and Spark but those aren't 4K, I don't have any other SD cards.
 

Droneted

Premium Pilot
Joined
Nov 23, 2015
Messages
1,995
Reaction score
516
Location
Clermont, Florida
I see, I'm not sure if it would be worth the hassle of attempting to repair it myself just to get video back (assuming the firmware reflash doesn't work), I do have evidence that this *may* have be crashed, I am not completely sure... the only thing I notice off with it is one of the back blinking lights is a very faint red and doesn't blink green like the other side, like the 2 front reds are completely bright and the back right is completely bright red/green, but the back left is faint red/no green at all, there isn't any cracks though.. I got this drone + 3 batteries + case for a used iphone xr with no money involved, it felt too good to be true lol and turns out the drone does have minor defects.

Do you offer repair services?
and
Do you know if the lights going out on the arms is normal with age, or is it an implication of a crash/water damage (maybe from flying in rain I don't know lol)?


Edit: I have not flown any of my drones in any rain/mist/fog or in clouds ever, so I'm suspecting maybe previous owner did, not sure.
Yes I do. I do mostly gimbals/cameras. I am curious about the back light that should be green. I don’t charge if it is not worth repairing. I am in central Florida. Email me
[email protected]
 
  • Like
Reactions: dronesky
Joined
Apr 16, 2021
Messages
5
Reaction score
0
Age
31
Yes I do. I do mostly gimbals/cameras. I am curious about the back light that should be green. I don’t charge if it is not worth repairing. I am in central Florida. Email me
[email protected]
Dropped you an email :)

Can provide a video to show you exactly what the light is doing if you'd like.
 
Joined
Jul 13, 2016
Messages
146
Reaction score
84
Age
68
What is that strong wireless interference message that keeps appearing?
 

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,785
Reaction score
8,784
do you think maybe that could be causing it?
It's the simplest thing to check.
And if you look at the screen shutter button when you switch to video, it's showing an SD card icon with a red diagonal line across it.
That's a pretty good clue that the camera doesn't think the card is good enough.

You could also try changing the video resolution down to a lower resolution which would be much less demanding and demonstrate that the camera is OK.
 
Joined
Sep 10, 2017
Messages
106
Reaction score
93
Age
65
Location
Devon, UK
I suspect that the SD card may not be fast enough to record the 80Mbs 4K video stream. First thing to try is change the SD card. Use a card with the U3 standard (the 3 is shown inside the U). This may be a simple fix for the problem.

All the best, Martin
 
  • Like
Reactions: Capt KO

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,836
Reaction score
3,894
Location
Western US
I'm curious about the specs of your SD card and if you've tried others.
It's just some old 16gb sandisk one that came with my Phantom 3 standard, do you think maybe that could be causing it? It works fine for P3s and Spark but those aren't 4K, I don't have any other SD cards.
Yes, I do think it’s possible that this could be causing your issue which is why I mentioned it. It’s at least a very fast troubleshooting step before moving on to the other possibilities.
 
Last edited:
Joined
Jul 19, 2020
Messages
7
Reaction score
5
Age
61
So, I own 3 DJI drones, a Spark, Phantom 3 SE, and Phantom 4.

I acquired this Phantom 4 in great condition during a trade on Craigslist, fully inspected the drone, flew perfectly, crystal clear feed.. flew just as well as my previous drones, maybe even better :p (it is my nicest drone afterall), but when I went home to play with it more I noticed that it never wanted to go into video mode no matter what I did, I haven't really bothered researching it or playing with the settings until now (about a year later) since drones have peaked my interest again and I would like to fly again.


Here's some quick info:
It gives a smooth and clear live feed when flying, every function about the drone works and operates flawlessly other than video function.
When taking pictures, it goes in full resolution to my SD card and caches to my phone in 720p I believe as well, perfect functionality.

however, when I switch to video mode, the feed goes black and after 5-10 sec it swaps back to pictue mode, not really sure why.. everything else works just fine.

Have tried using different phones, reinstalling DJI go, reformatting SD card, turning the resoulution in video mode down (before it swaps back to picture mode), and updating to latest firmware.

Here is a youtube video demonstrating the problem :)
in the video, I show the gimbal functions just fine and provides a clear and live feed until put into video mode.

Problem is shown in this Youtube video
I had the same problem with my phantom 3 it was the camera ribbon cable replace that everything was fine
 

New Threads

Forum statistics

Threads
140,614
Messages
1,449,376
Members
102,416
Latest member
K.J.