Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

No Camera Status indicator light & "Gimbal Disconnected"

Discussion in 'Pro/Adv Discussion' started by Seeley27, Jan 21, 2017.

  1. Seeley27

    Joined:
    Jan 21, 2017
    Messages:
    5
    Likes Received:
    0
    Hey Guys,

    Received drone around Christmas time, updated controller and firmware. Everything was good and ready to fly, but it was too cold out so Ithe drone sat, or was safely stored (in house since Christmas till now) camera worked great, recorded video and took pictures until today)

    Now no camera status indicator light at all. No Image from camera, and tablet says "gimbal disconnected".
    When I try to format SD tablet says "no SD card"

    Drone flys great today - everything updated remote green and camera light was green after update.

    I can control gimbal fin with remote so I know its getting signal, and I can fly drone perfectly fine.
    I have tried unplugging and re-connecting cable btwn controller and Ipad, (as many have suggested in other threads), no cigar.

    Any Ideas on how to get my camera back?

    Thank In advance,

    -Mike
     
  2. Seeley27

    Joined:
    Jan 21, 2017
    Messages:
    5
    Likes Received:
    0
    Additional info:
    Phantom 3 Pro
    no crash or hard landings
    App version 3.1.2
    Aircraft version 1.10.90
    Remote Controller version 1.8.0

    have tried multiple SD cards
    Deleted and reinstalled app.

    Please help, Running our of options

    -Mike
     
  3. Seeley27

    Joined:
    Jan 21, 2017
    Messages:
    5
    Likes Received:
    0
    DJI replied and had me calibrate IMU and gimbal, and reset camera still with no success.

    No Camera Status Light
    Still "gimbal disconnected"
    still reads "no SD card" when trying to format card in the drone.

    Anything guys? Anyone else have this issue?

    All Firmware is updated (See Image Below)
    [​IMG]
    [​IMG][​IMG]
    [​IMG]
    IMU Calibrated
    Gimbal Calibrated
    Still no Image on display
    Still says "Gimbal disconnected"
    Still no Camera Status Light
    Tablet using:
    Apple ME277LL/A 8-inch iPad Mini 2 with Retina Display


    Please help,

    I have only flown this drone once, it is brand new.

    -Mike
     
  4. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    1,728
    Likes Received:
    252
    Location:
    Manchester UK
    Couple of things, have you tried another cable, or an android device to rule out the app. Is there any loose cables around the gimbal.


    Sent from my iPhone using PhantomPilots
     
  5. Seeley27

    Joined:
    Jan 21, 2017
    Messages:
    5
    Likes Received:
    0
    Thanks for Reply!

    Yes, I have tried different USB connections btwn controller and tablet
    Tablet is apple iPad mini 2 w/ retna

    I did not remove gimbal but connections I checked appeared tight - (The gimbal also responds to controller and moves fine on start up and motion tracking/stabilization)
     
  6. javierespada

    Joined:
    Jan 27, 2017
    Messages:
    1
    Likes Received:
    1
    I had the same issue with mine when I first got it... it would move when the quad was powered but in the app I was getting the error and no picture, it was the cable that connects to the body, not the thin ribbon on the gimbal, the one with 5 white cables, removed, re-connected and all is good after that.
     
    MedicFL1 likes this.
  7. Seeley27

    Joined:
    Jan 21, 2017
    Messages:
    5
    Likes Received:
    0
    Hey guys, anyone else? Nothing seemS to power up on status indicator/ sad card reader
     
  8. DanMan32

    Joined:
    Jan 21, 2017
    Messages:
    1,202
    Likes Received:
    240
    I would disconnect and reconnect both white ribbon cables going to the Gimbal. The other end of one of the cables connects to the VPS module so check/reseat that too.

    Sent from my HTC 10 using PhantomPilots mobile app
     
  9. DanMan32

    Joined:
    Jan 21, 2017
    Messages:
    1,202
    Likes Received:
    240
  10. muleferg

    Joined:
    Feb 23, 2017
    Messages:
    1
    Likes Received:
    0
    Fixed my issue by replacing the usb cable to the I Phone after back dating to the last update.
     
Loading...
Similar Threads - Camera Status indicator Forum Date
Camera Status Indicator blinking red 3 times does mean what? Phantom 4 Help Jan 12, 2018
Camera Status LED Indicator Phantom 4 Pro Help May 2, 2017
No light in camera status indicator Pro/Adv Discussion Nov 15, 2016
Camera yaw (pan?) axis rubbing, but gimbal status "normal" Standard Jul 12, 2017
Professional Camera requires Upgrade. (Overall Status) Phantom 3 Help May 7, 2016