app shows gimbal pointing straight up when gimbal is stabalized


Deleted member 56578

their is a problem I am having right now that will show itself on the cell app as an extreme red in either yaw or pitch(mine is pitch and stays at the top even when the camera aligns up) to one side or the other and not being able to be moved via the app, however it will still stabilize straight forward and record video and stay stabilized. I have tried reinstalling the app, different cell phones, rebinding, re leveling the motors and the pot, I have checked all cables and even replaced the gimbal cable.

I am not sure if the shaft or a pot causes the above problem, but I have been looking for the reason it happens. Anyone ever come across this?

Deleted member 56578

Fixed it. When I looked at the firmware, it seems that their is a 1 time initial startup calibration when new firmware is installed.

This shows 1 of 2 things:

A: when installing new firmware, keep the device level! don't touch it if it has a gimbal on it that is slaved into the unit.

B: If you used a gimbal saver, new pieces or simply straightened out the arms from a crash, you will need to reset the gimbal via disassemble of the top plastic shell and do a "Hard Reset" on the phantom. after this was done, it solved my issue.

here a video on how to do it.

New Threads

Forum statistics

Latest member