Ribbon cable disconnected in remote

Joined
May 11, 2017
Messages
4
Reaction score
11
Location
San Diego, California
Purchased used P4 yesterday. Got it home to hear something rattling in remote control. I was concerned it might be something metallic, possible shorting out something expensive so bit the bullet and took the back off the remote.
I removed the (non-threatening - of course!) black nylon plastic debris causing rattle, but see the black ribbon cable connecting the comms board (located under separate cover on rear of remote) to the main board is disconnected - not good. See attached image for view inside the remote.
My question: Does anyone know of a technique to refitting the very short ribbon cable back in to its tiny, board flush connector?
 

Attachments

  • Ribbon-problem.jpg
    Ribbon-problem.jpg
    1.8 MB · Views: 531
Joined
Mar 10, 2016
Messages
80
Reaction score
24
Age
53
Location
Port Arthur
Remove the video downlink cover from the rear of the remote first! It's much easier to reconnect there on the back. Then insert the cable into the motherboard being sure to secure the latch tab before closing. Now you are able to close the remote. Next insert your cable back into the USB/video link and you should be ok. Please post it this works for you...
 
Joined
May 11, 2017
Messages
4
Reaction score
11
Location
San Diego, California
Remove the video downlink cover from the rear of the remote first! It's much easier to reconnect there on the back. Then insert the cable into the motherboard being sure to secure the latch tab before closing. Now you are able to close the remote. Next insert your cable back into the USB/video link and you should be ok. Please post it this works for you...

Thank you. I ended up paying a local iPhone store to do the repair ($25), but still cannot see anything on my phone screen, though remore control of drone seems fine. Just no camera connection.
 

Members online

Forum statistics

Threads
142,358
Messages
1,461,846
Members
104,162
Latest member
Boufou