Woes of doing the HDMI controller upgrade...

Mar 14, 2017
Reaction score
Well, considering I have just gone through this special kind of hell and there is a LOT of misinformation and assumptions out there, I figured I would post about my trials and successes to give a glimmer of hope and a path to follow to those that are wanting to make this upgrade.

First off I ended up acquiring a set of DJI Goggles. They work great, and they work properly with the P4P via USB. I have tested the goggles via HDMI and a Xbox360 for a few hours and they work great for that application as well.

My hope in getting the goggles was to allow someone else to use them to experience "first hand flight". That someone was my mother and the kids. My wife has no interest as wearing the goggles makes her feel ill.

So I figure if I get the HDMI board for the controller I can have them experience flight without any distractions (ie, HUD info) and with me in full control of the bird. Using USB not only has all the flight info, but there is no easy way to share it (yeah, I figured out a way via a Miracast device and my android tablet, but again it was less than ideal and used WiFi to get it going, which means I could end up having issues mid-flight that would be a distraction), so HDMI was the means to my ends.

I got the board in along with a mini-HDMI to Micro-HDMI cable. The package seemed to be unused and in "factory new" condition.

First off I checked everything out and found out my controller was v1.04.00.00, but, since in my research I know you need to update the firmware to get it working properly I didn't worry too much.

I installed the module, got it all put back together. I started out with the C1/C2/Record/Camera action button combination on startup of the controller to reset it. I thought it worked since the "HD" tab of DJI Go 4 showed the HDMI options. I was able to turn on and off the HUD information, but that was it, no video display. I started getting weird command errors in DJI Go 4, so I resigned myself to updating the firmware.

Next step took a bit of research to figure out that doing a long-press on the three vertical bars in the upper right corner of the launch screen opens up the firmware update utility for the remote controller. Well, on my ancient version of DJI Go 4 (v4.0.7) it didn't show anything for the controller and no revisions of firmware. So, I switched to my Galaxy S9+ phone with the latest version of DJI Go 4. It complained that my aircraft firmware was out of sync with peripherals used, and wanted to refresh the firmware, which was v1.03.0509. Since it stated the same firmware I had installed I let it refresh it. It did not update any maps (even though it asked to and I declined) and it showed a new firmware available (v1.5.xx.xx), but that was it when it was done.

So I held the three bars on the upper right, it showed the controller firmware as v1.04.00.00 and the downgrade menu showed all three revisions of the firmware available, including the latest v1.04.01.00 (yes, I know there is a firmware in the wild, but not available via download from DJI through DJI Go 4). I choose and let it update the remote controller.

It starts counting fairly quickly, gets to 92%, stalls, the area next to "Downgrade" shows "(Unable to load)" or somesuch (sorry I didn't get a screenshot), but the controller goes from a blue light and constant beeping to a light green light briefly, then it goes back blue and the count resumes and it goes to 100% and tells me to reset the controller that the update is complete.

I think great, that was easy, reset everything, hook it all back up and restart the controller. Now the HDMI output is only valid for 2 seconds and then goes blank for 4 seconds and keeps cycling. At the same time the HDMI goes out it also disconnects the USB from the tablet. I try on the goggles and on the 65" Vizio TV in the family room. Same thing.

So I rip everything apart numerous times to try to reseat things. I try starting up the controller with the big ribbon cable disconnected from the USB board to reset the USB (as suggested in a post somewhere), then turn it off and put it all back together, no luck. I redid everything a half dozen times to no avail (including another firmware update of the same rev), again, no dice.

At this point I am dejected, figuring I got a defective module, so I pull it out and install the stock USB only module back.

That is when it hits me. Maybe you need to do multiple successive flashes to get it to the new firmware, and then to get it load the HDMI module. So I did some experiments with flashing firmware both with the USB only module and the HDMI module and got it to work. I noticed that the speed at which the percentages changed doing flashing was different when going from module to module and with that I came up with this as the "fool-proof" method if installing the HDMI module with success:

Pre-requisites: Do not have the aircraft powered on while doing this until you need to verify the modules installation and function. Have a fully charged remote controller and cellphone/tablet with the latest DJI Go 4 app installed. Have all the tools necessary to install the module (mini-torx screwdriver, plastic spudger, philips screwdriver, tweezers if you can't handle the ribbon cables with your fingertips).

1) Start up the controller with the USB-only Module still in it. Connect to it via the latest DJI Go 4 app. Choose the Phantom 4 Pro device if it does not switch to it automatically. Press and hold the upper right three vertical lines until the Remote Controller firmware Downgrade utility shows. Select the firmware you want to load (I used v1.04.01.00), it will then download. Choose to start the update and it will load to the controller. During this process ignore anything that shows next to the "Downgrade" label for the drop-down menu. Once it is complete turn off the controller and go back to the device selection screen.

2) Unplug the controller from the cellphone/tablet, turn it on and after it comes up, wait 5 seconds and then turn it off. Flip it over and open up the back cover with the mini-torx screwdriver. Use the spudger to flip up the black tabs that lock the ribbon cables in place (there will be three the flip up from the opposite side of where the cables push into the connectors). Lift the board up and pull all three connectors off.

3) Install the new HDMI board and cover. Install the right side small ribbon cable first. Press down the black lock tab when it is installed far enough (the white line on the cable will be at the connector). Repeat with the left side connector and then the bottom connector (I found that order allows for the easiest and most secure installation of those cable). Install the board into the controller and reuse the 3 screws you took out to remove the USB-only board. Next make sure the copper-internal panel is firmly snapped completely to the white back cover (which is also the HDMI module, as if this is not done it will make a not-so-secure connection to the USB board). Install the HDMI module/cover to the controller by sliding the front edge over the USB port first and then snapping the back of it down. Then use the 4 mini-torx screws to affix the HDMI module/cover to the controller.

4) Now start up the controller. Once it comes up plug it into the cable that is attached to the cellphone/tablet running the latest DJI Go 4. Once it is detected, again press and hold the 3 vertical bars on the upper right until the controller firmware downgrade utility displays. Again choose the same firmware you chose before. Start the upgrade. You will notice it going at a different speed than before. Again ignore anything that pops up in blue next to the "Downgrade" labelling. Let it complete. Once it is done, shut off the controller and exit out of the controller firmware screen and back to the device selection screen. Start up the controller once more. Once it is detected, again go into the firmware downgrade utility by pressing and holding the three vertical bars on the upper right. Once there, do the same firmware upgrade you did just before with the same revision as before. Again, let it upgrade completely while ignoring anything next to the blue "Downgrade" labeling. Once it is done you can choose to delete the firmware downloaded if you want, and then turn off the controller. Go back to the device selection menu.

5) Get the aircraft, start it up. Connect your controller via HDMI to the display of your choice (DJI Goggles, TV, monitor, etc), start up the controller. Once up go into "Go Fly". Once there hit the three dots in the upper right corner, go to the "HD" menu and make sure you can see the options for HDMI output (selections for 50hz/60hz, selection for simultaneous HDMI and tablet display and the selection for flight information on the HDMI output). In my case it has always been set for 60hz and HDMI output along with flight information were all selected at initial startup, but yours may react differently.

At this point you should have HDMI output and whatever options you select.

I would imagine if the HDMI output were to abruptly stop displaying and changing options in the "HD" menu won't fix it, I would start by redoing the remote controller firmware flashing once more. Since everything with DJI seems to be software configurations, and based on my own experience with firmware acting strange "out of the blue" (such as it saying that there was a misconfiguration that needed the firmware to be reloaded), I would imagine that it is not unheard of for a setting to get "stuck" in the configuration loaded on the controller and a fresh flash would be the way to get it back to normal. (side-note: you may try the C1/C2/Record/Camera option hold while starting the controller to reset it as well, since I have read in numerous places that it has worked to get a HDMI module displaying again, but I *KNOW* for fact that loading the firmware on the controller redoes EVERYTHING back to where it needs to be to make it work)

I also have no doubt that electronics go bad at times and a module can most certainly go out on you. That is why I am also recommending to NOT change the HDMI connection while the controller is up and running if you can. That means if you plan to use HDMI, have it plugged in BEFORE you start up the controller. Like-wise make sure you only unplug the HDMI cable once the controller is shut down. Again, only a suggestion, but considering the funkiness I have seen first-hand with how the HDMI module freaks out at times, it is obvious that it is not as robust of a setup as one would hope it would be in regards to plugging and and unplugging HDMI display devices.

Hopefully this helps someone. If anyone wants me to reformat it into bullet-point/more detailed and annotated numerical steps, I can do that as well. Just ask.
Glad it worked out. And more glad mine was a simple drop in. ? persistence paid off in your case.
  • Like
Reactions: Jim Canada
Yeah, I was ready to send the interface upgrade board back, but I figured I would go "full meticulous" starting all over and it worked out just fine.
  • Like
Reactions: Capt KO
C1/C2/Record/Camera a
So I have a job tomorrow so im not going to do the reupdate on the RC tonight. Here's my symptoms:
plug all up, boot P4P system, turn on cinimizer goggles (tried the dji RE goggles too), the FPV display will flash on without the camera, only heads up display, then fuzz out and goggles say no input or not recognized. Then rinse and repeat in a cycle. The cam display on the ipad pro also goes black. I did have this working fine for a long time. This will be the 2nd time its happened within a year.
Ive reseated the HDMI mod 2x.
Tried different HDMI cables.

I had this problem last summer and did something to fix it... I found the solution online. No I didnt log that solution... and no my memory sucks! (i usually do log solutions)(sometimes im dim... :)

Ill def try this one though.

Any other ideas I could try first would be super appreciated!

Thank you all for posting all of this.... !!!!
brad p
So i bought a new in box part 54 and when I go to install it will not connect to any phone tablet whatever i connect it too. Funny thing is once I take out the HDMI card and just run it off the USB card that came with it will connect. I bought it so I could use it in conjunction with the DJI Goggles and while i still can use the googles using USB I cannot use the Goggles Via the HDMI port. Since I cannot connect I cant download any updates on firmware. Possible that the HDMI Card is bad?
Sorry if this has already been discussed.
My hdmi module only worked on a newer gl3ooc. Install on other unit led to black screen with some graphics on hdmi with camera still on usb. If you have nothing you may need to update firmware first and then change module. Be careful with cable coming out of controller, tiny tiny connector will break easily.
I have no way to update anything since with the HDMI module installed it will not connect to any Phone Tablet or PC it just doesnt connect even if I run the app. I take out the HDMI card and leave the USB card in from the module it will connect. Shows I have the most current update available and no other newer update available.

Members online

Forum statistics

Latest member