Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Remote keeps connecting and disconnecting (every 5 seconds) to drone after gimbal replacement

Discussion in 'Standard' started by kiwirider, Dec 21, 2017.

  1. kiwirider

    Joined:
    Apr 13, 2017
    Messages:
    4
    Likes Received:
    0
    Hi All,

    I've come across a problem with a standard when I removed the the camera (only the camera and arms, not the base that houses the wifi module etc.).

    Before removing the camera I as able to fly the drone and had connection to the DJI App throughout flight.

    I as also able to fly the drone without the gimbal base (no DJIGo App though) without an issue.

    However, after taking the camera off the gimbal base, the drone boots up fine and the controller light goes from red to green (indicating that binding to the drone is successful). The DJIGO App connects to my phone fine BUT after about 5-10 seconds the App loses signal AND the green light on the controller goes back to red. 5-10 seconds later, it binds again and the App connects briefly before disconnecting again. This goes on and on etc.

    I have taken the cover plate off the gimbal base to reveal the main gimbal PCB. There are two small LEDs. I notice that while the drone is connected the first LED slowly blinks bright green (see green circle below), and just before it disconnects it flashes dim green once, and then the second red (see red circle below) LED flashes bright red (slowly). This connect/disconnect cycly repeats every 5-10 seconds while the drone is on. 20171221_203155.jpg

    The last comment I have is now when I take the board off the remote doesn't bind at all (but it was working before I took the camera off).

    I know taking the camera off is not the issue itself (I have done it once before and it was fine), The only thing I think it could have something to do with one of the 3 wires attaching the gimbal to the drone? These were bumped while I took the camera off (although they didn't come off) however I have taken these of and reconnected and have also tried rebinding and various other easy fixes. I'm hoping someone has either discovered this issue before or has enough knowledge about these drones to know what the LED blinks mean in this scenario.

    Any help is appreciated
     
  2. Buffalohunter

    Joined:
    Dec 28, 2017
    Messages:
    10
    Likes Received:
    2
    I would try making a call or e-mail Fixacrash. They are highly rated on yelp reviews. Open 7 days a week. Leave a message if know on answers.

    [email protected]


    415-715-4821
     
  3. grgguy

    Joined:
    Feb 16, 2018
    Messages:
    1
    Likes Received:
    0
    Did you ever solve this issue. My Phantom 3 Standard is doing this exact thing. Like you I've tried all the obvious fixxes to no avail.
     
  4. Jimmers

    Joined:
    Dec 1, 2016
    Messages:
    119
    Likes Received:
    23
    Sounds maybe like a loose wifi wire that goes to the board that sits just above the camera. If that’s not it try to refresh the RC firmware and then relink the RC to AC.
     
    kiwirider likes this.
  5. donk

    Joined:
    Sep 5, 2017
    Messages:
    11
    Likes Received:
    5
    This may be too simplistic...but I was having similar problems with my standard...I realized the Bluetooth on my iPhone was turned on. I turned it off and everything was fine...apparently it was causing interference
     
  6. kiwirider

    Joined:
    Apr 13, 2017
    Messages:
    4
    Likes Received:
    0
    @grgguy it was due to dodgy cable connections between the gimbal and drone (haven't been able to narrow it down to the two signal cables of or the main gimbal cable - although @Jimmers suggests it is on of the two wifi cables?). I managed to repair the two wifi cable connectors (with a lot of care) and it all worked fine for a month or so (although the gimbal occasionally wouldn't work until it was bumped). Last time it was transported in the car when I turned it on the problem came back so my cable repair was not as strong as I'd hoped. My next option is to completely replace the cables between the drone and gimbal and see if that works, but haven't been able to find a set. Very annoying!
     
  7. Brother Dave

    Joined:
    Dec 28, 2017
    Messages:
    150
    Likes Received:
    52
    If you are talking about the gray wire and the black wire that go to the 2.4g antennas inside the drone, it’s much easier to just replace the antennas than to try and repair the wires, at least for me. I found them on eBay for $24 for both. Free shipping, too. I think I saw the ribbon wire, too.
     
  8. saucypuppets

    Joined:
    Jul 1, 2018
    Messages:
    1
    Likes Received:
    0
    I've got this exact issue after a hard crash which broke my roll arm in half and tore the gimbal flex cable. I see the red LED on the exterior of the board flash red, then the remote loses connection with my P3SE (remote LED changes from green to red and DJI Go says "disconnected"). I'm currently wondering if the disconnect/reconnect issue is caused by my gimbal being partially severed and the main board (the one shown in the original post) being unable to talk to the sub-board on the roll arm. Am I to understand that people don't have the disconnect/reconnect issue while the gimbal flex cable is disconnected?

    Noticed something else to add: The gimble board makes a beeping sound which stops when the red light comes on, then restarts after the controller regains a connection. The beeping sound is the same one which occurs prior to the gimble stabilizing prior to flight. No one else mentioned the beeping sound related to this issue, thought I'd share.
     

    Attached Files:

    #8 saucypuppets, Jul 1, 2018
    Last edited: Jul 1, 2018
  9. alia5

    Joined:
    Jul 4, 2018
    Messages:
    1
    Likes Received:
    0
    I had the same issue with just the gimbal board itself connected to the bird (no flex cable). Connect/Disconnect every few seconds, and the beeps stop briefly when the light turns red.

    Replaced the ribbon cable with a genuine DJI one last night, and everything is fully functional again.
     
    #9 alia5, Jul 4, 2018
    Last edited: Jul 11, 2018
  10. Yugs

    Joined:
    Feb 17, 2018
    Messages:
    3
    Likes Received:
    3
    Thanks for this info., I crashed my P3 SE and severed the flex cable. The quad then was able to take off, but would then intermittently disconnect from the controller and continue flying autonomously in the direction last commanded before disconnection (scary to say the least!). Reading threads about P3 Standards flying ok without the camera, I thought I may have damaged something internally. Replaced the flex cable and gimbal roll assembly and it now works perfectly!
    I think as saucypuppets mentioned there is a critical communication that needs to occur between the main board and the sub board, in order for sustained connection with the controller.
    Anyone out there with a Phantom 3 SE with a slightly damaged gimbal cable or gimbal assembly, my advice is replace those components; as a mid air failure could easily result in a flyaway situation.
     
  11. Porktree

    Joined:
    Jan 17, 2017
    Messages:
    22
    Likes Received:
    8
    I had to replace the gimbal mount plate - after doing that I can only get about 220 feet of range - I tried a different RC with the same results. Is there something in the camera/gimbal that also affects the 5.8ghz radio? I had assumed that the AC's connection with the Remote was controlled by the main board and the antenna there. I'm going to pull the camera/gimbal off again and check all the connections. Any additional info would be welcome.
     
  12. Icemancy

    Joined:
    Aug 16, 2018
    Messages:
    4
    Likes Received:
    0
    Hi anybody found a solution to the Problem, do I need to change gimbal Mainboard?, Green light on gimbal mainboard flashing slow then red and starts from begin.
    Thabks
     
  13. Icemancy

    Joined:
    Aug 16, 2018
    Messages:
    4
    Likes Received:
    0
    Hi I have the same problem, did your order new gimbal mainboard to fix the disconnection problems?- I want to fly drone without camera but still have telemetry. Thanms


    QUOTE="kiwirider, post: 1302850, member: 91409"]Hi All,

    I've come across a problem with a standard when I removed the the camera (only the camera and arms, nkot the base that houses the wifi module etc.).

    Before removing the camera I as able to fly the drone and had connection to the DJI App throughout flight.

    I as also able to fly the drone without the gimbal base (no DJIGo App though) without an issue.

    However, after taking the camera off the gimbal base, the drone boots up fine and the controller light goes from red to green (indicating that binding to the drone is successful). The DJIGO App connects to my phone fine BUT after about 5-10 seconds the App loses signal AND the green light on the controller goes back to red. 5-10 seconds later, it binds again and the App connects briefly before disconnecting again. This goes on and on etc.

    I have taken the cover plate off the gimbal base to reveal the main gimbal PCB. There are two small LEDs. I notice that while the drone is connected the first LED slowly blinks bright green (see green circle below), and just before it disconnects it flashes dim green once, and then the second red (see red circle below) LED flashes bright red (slowly). This connect/disconnect cycly repeats every 5-10 seconds while the drone is on. View attachment 92386

    The last comment I have is now when I take the board off the remote doesn't bind at all (but it was working before I took the camera off).

    I know taking the camera off is not the issue itself (I have done it once before and it was fine), The only thing I think it could have something to do with one of the 3 wires attaching the gimbal to the drone? These were bumped while I took the camera off (although they didn't come off) however I have taken these of and reconnected and have also tried rebinding and various other easy fixes. I'm hoping someone has either discovered this issue before or has enough knowledge about these drones to know what the LED blinks mean in this scenario.

    Any help is appreciated[/QUOTE]
     
  14. Icemancy

    Joined:
    Aug 16, 2018
    Messages:
    4
    Likes Received:
    0
    Friend I have connected a new ribbon cable from gimbal to camera- I didn't connect the motors of gimbal. ItIt ee my previous flex was defective. From what I understand now you need to have it connected on camera and gimval to access app and have connection
     
Loading...
Similar Threads - Remote keeps connecting Forum Date
Remote Control keeps unlinking Phantom 2 Discussion Nov 5, 2014
Remote Pro/Adv Discussion Sep 15, 2018
Standard P3s intermittent remote connection Phantom 3 Help Sep 15, 2018
Remotely controlled nozzle or clamp to drop little water from drone General Discussion Sep 14, 2018
$1350 - DJI Phantom 4 Pro Bundle. Includes aircraft, 3 flight batteries, and DJI remote controller. Classifieds Sep 14, 2018