Standard Multiple Flight Mode switch doesn't show at all

Joined
Oct 23, 2016
Messages
2
Reaction score
0
Age
31
Dear All,

I recently purchased a Phantom 3 Standard and I was looking forward to test the intelligent flight modes such as the follow me and waypoint flight. But no matter how many guides I read or videos I watch I always find myself stuck on the same point: when I open the advanced options on the DJI GO app, there simply isn't a multiple flight mode switch.

I have recently upgraded the firmware and everything, but I can't figure it out.

I have tried with a Samsung s7 and with a samsung s5, without results.

Maybe you should know that this drone was bought in Italy, and that from watching the videos, my controller seems to be slightly different from what i see around. Instead of having the switches on the trigger position they are at the top right and top left corners of the remote, and instead of having a standard usb port (also nearby the trigger position) it has a micro USB in the front part of the RC (that is, facing the person holding it).

Any help would be greatly appreciated, I bought this phantom to use it for work applications, and without the intelligent flight modes i will have no use for it.

Thank you all,

Beikeni
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,794
Reaction score
10,142
Location
Harrisburg, PA (US)
Try this:
  • Take off
  • Move the S1 switch to the bottom position
  • Press the flight mode icon on the left side of DJI GO
DJI-GO-IOC-Icon-P3.png
 
Joined
Oct 23, 2016
Messages
7
Reaction score
0
Age
33
Hi all. I also just got a P3S and found this forum a wealth of knowledge so far. This is my first post and I'm having the same problem as OP in that the "Multiple Flight Modes" toggle isn't even there. I really want to play with the follow me function when on my quad bike around my property but I'm at a loss.

Sent from my Pixel XL using Tapatalk
 
Joined
Jan 13, 2015
Messages
1,582
Reaction score
328
Location
Girard. ohio
Hi all. I also just got a P3S and found this forum a wealth of knowledge so far. This is my first post and I'm having the same problem as OP in that the "Multiple Flight Modes" toggle isn't even there. I really want to play with the follow me function when on my quad bike around my property but I'm at a loss.

Sent from my Pixel XL using Tapatalk
do your self a small favor
take some time to learn a bit about this prior to starting that stuff.
lots of features and hidden things buried in that app to dig up and learn what they mean, what they do, and how to undo when needed.....

while it is all easy for the most part a bit of time and experience with simple stuff ends up better for new flyers.

good luck and have fun flying!
 
Joined
Oct 23, 2016
Messages
7
Reaction score
0
Age
33
do your self a small favor
take some time to learn a bit about this prior to starting that stuff.
lots of features and hidden things buried in that app to dig up and learn what they mean, what they do, and how to undo when needed.....

while it is all easy for the most part a bit of time and experience with simple stuff ends up better for new flyers.

good luck and have fun flying!
I appreciate the sentiment, but it doesn't help me or OP work out if our products or apps are playing up. Experience aside the function isn't there.

Sent from my Pixel XL using Tapatalk
 
Joined
Aug 6, 2016
Messages
2,745
Reaction score
1,386
Age
60
Location
Western Australia
Hi all. I also just got a P3S and found this forum a wealth of knowledge so far. This is my first post and I'm having the same problem as OP in that the "Multiple Flight Modes" toggle isn't even there. I really want to play with the follow me function when on my quad bike around my property but I'm at a loss.

Sent from my Pixel XL using Tapatalk
Hi there, assuming that you have a similar controller configuration to the OP and incidentally myself, the advice from msinger ^ is spot on (as always). Flick the S1 on the right of the controller to the bottom and on your screen you will see the MFM option as shown in the screen shot above. Tap on that and all will be revealed. I used mine tonight and it works fine. And again as msinger pointed out, make sure the drone is up in the air before you start playing with it, can end badly otherwise.
 
Joined
Jan 13, 2015
Messages
1,582
Reaction score
328
Location
Girard. ohio
I appreciate the sentiment, but it doesn't help me or OP work out if our products or apps are playing up. Experience aside the function isn't there.

Sent from my Pixel XL using Tapatalk
hint
once you learn a bit more you will know why it is not there.
it is there when and IF it should be, it all depends upon what you set or don't set in various menus

The GO app is large and complex and you need to have the quad powered on for some
even need to be in flight for others.

good luck and have fun flying

Google
 
Last edited:
Joined
Oct 23, 2016
Messages
2
Reaction score
0
Age
31
Hi All,

a special thanks to msinger for providing a solution, even tho it didnt seem to work for me.
Here are some screenshots from my latest attempt, I tried to do as told but without results, also the GO app seems to be different, anyway, take a look, maybe its something really obvious that im not seeing.

The flight mode always seems to be P-GPS and no matter how much switch flipping i engage into, it won't change.


Screenshot_20161023-131438.png
Screenshot_20161023-131451.png
Screenshot_20161023-131457.png
Screenshot_20161023-131500.png
Screenshot_20161023-133613.png
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,794
Reaction score
10,142
Location
Harrisburg, PA (US)
Did you try installing the current version of DJI GO?
 
Joined
Jun 14, 2016
Messages
1,746
Reaction score
793
Age
60
My "Multiple Flight Modes" switch is under the BASIC settings, not the advanced settings. On the screenshot you provided, click the left-facing arrow next to "Advanced Settings" (at the top of your screen) and it should take you to "Main Controller Settings". In smaller gray letters underneath that it should say "Basic Settings". The first thing on the list should be "Multiple Flight Modes". If you don't see it, scroll up all the way to the top. For the setting to "stick", you have to be connected to the bird. Edit: I see that in your 3rd and 4th screenshots, you're in basic mode. Are you scrolled ALL the way up? My version is 3.0.1
 
Last edited:
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
24
I'm also having the same problem with a P3S... the Multiple Flight Modes just isn't there. We are scrolled all the way to the top for Basic Settings and Advanced Settings. I can't find this option anywhere. Here's another thread with more people and DJI suggesting it is an issue:

No intelligent flight modes?

My version is 3.0.0 which looks to be the latest Android version on the Play Store... I'm afraid at how long it will take them to fix it though, unless there is something special we have to do to get it to show.
 
Joined
Oct 23, 2016
Messages
7
Reaction score
0
Age
33
I gave up and bought Litchi. Game changer.

Sent from my Pixel XL using Tapatalk
 
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
24
Haha yeah I was thinking of doing that. Guess I was going to get Litchi at some point anyways
 
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
61
Can we bump this thread? I am also having the same issues and want to keep up with this one.
 
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
24
Did you update your DJI Go app? The most recent update (3.0.1) fixed this for me.
 
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
61
I have not updated since I installed it a week ago. I will see if I can. Thank you
 
Joined
Oct 24, 2016
Messages
3
Reaction score
0
Age
61
OK the version I originally downloaded was 3.0.0. I just uninstalled it and reinstalled to 3.0.1. Problem solved, at least for what I see on the screen now. I am not going to fly today because we have 30mph wind. Hopefully I can fly tomorrow. Thank you all for this post.
 

New Threads

Forum statistics

Threads
134,954
Messages
1,396,193
Members
98,345
Latest member
Gerard55