Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motors won't start - three red flashes then unresponsive.

Discussion in 'Phantom 2 Help' started by strbhnfhr, Oct 18, 2014.

  1. strbhnfhr

    strbhnfhr Guest

    Hi all.

    Any and all help is appreciated. Bought my Phantom 2 with HD-3D a week ago and have not crashed or modified it in any way. It's flown just fine each night and I updated to the latest firmware three days ago. The only other change I made was to restrict the max height to 400 feet.

    Tonight, after flying a short while my Phantom would not rearm/restart and instead the rear led's flashed red three times. I eventually got it restarted, but then a short while later in flight it became unresponsive to any commands and would not RTH in failsafe mode either for what felt like an absolute eternity. Has anyone else run into this and if so, what are the remedies?

    The series of events were:
    1) Began flying in an open soccer field with a full battery. Scouted the site for any obvious radio towers, high tension lines, or other sources of interference. None noted, and no buildings were nearby.
    2) Calibrated the compass and went though entire preflight checklist including controller S1 and S2 in up position, six satellites, normal LEDs on startup, etc.
    3) First 6 min of flight were normal....then I decided to practice a landing which was soft and uneventful. Some kids came to play soccer so I powered down the motors and changed the home position location by about 50 ft.
    4) Went through preflight checklist again and everything appeared normal except for when I tried to start the motors. This time I received three quick red flashes to rear LED and motors would not spool up.
    5) Turned off power to craft and removed battery. Also removed controller batteries. Then attempted restart sequence and compass calibration which all seemed fine and I ended up with green lights. Same result though when I tried starting the motors (would not arm; got three red flashes) so I repeated the battery removal/recalibraion process three more times and also changed position of the Phantom back to my original location.
    6) Fourth attempt the Phantom motors started and all appeared fine. After I relaunched, the flight controls appeared normal and I got about another 5 minutes of good flying in.
    7) When the Phantom signaled a low battery it was about 100 feet away and close to the ground. I began to ascend for the return and reached ~40 feet where the craft suddenly stopped responding to my inputs. I noticed it very slowly creeping upwards on its own.
    8) After 30 sec of no response and watching it climb on it's own I turned off the controller and waited. The Phantom flashed yellow a few seconds later but did not really do anything else for another minute or so at which point I was getting very nervous and wondering how long till the battery completely died.
    9) Suddenly the Phantom started to ascend quickly on its own , then returned to the starting position above us. It then began to descend and I started to feel better. On the descent it became stuck again and just hovered (about 50 feet above us).
    10) I turned on the controller, flipped S1 and was able to regain control of the craft and bring it in for a quick landing and power down.
    11) Post-flight checklist showed a very low battery but otherwise everything looked fine and intact.

    Thoughts on why I would initially get three red LED lights and then experience unresponsiveness at ~50 feet? At this point, I'm a little nervous about putting it back into the air until I figure out what is going on.

    Many thanks!
  2. strbhnfhr

    strbhnfhr Guest

    Re: Motors won't start - three red flashes then unresponsive


    After getting home and fully charging the battery, I tried powering up the Phantom and have the same situation. It initializes and eventually blinks green lights. When I try to spool up the rotors, I get three red led flashes. Am not going to try to launch until I solve this problem and appreciate any advice!


    Sep 5, 2013
    Likes Received:
    N 44.895 W 93.354 Minnesota
    Re: Motors won't start - three red flashes then unresponsive

    First thing I would do is an advanced IMU calibration as per Tools page in asst software. On another note - it's not neccessary to pull batteries from transmitter between flights.
  4. strbhnfhr

    strbhnfhr Guest

    Re: Motors won't start - three red flashes then unresponsive

    Thanks. That seems to have resolved it. As soon as I tried the basic calibration the device indicated that it was indeed required. Appreciated
Similar Threads - Motors won't start Forum Date
Motors won't start (Battery too cold warning?) Pro/Adv Discussion Dec 2, 2017
Motors on P3 Standard won't start and need repair addresses for Southern California Standard Nov 18, 2017
Need help upgrading P3A!!! The drone motors won't start after upgrade Pro/Adv Discussion Aug 12, 2017
Phantom 4 motors won't fully start Phantom 4 Help Jul 20, 2017
Standard Motors won't start up Phantom 3 Help Feb 27, 2017