HDMI module troubles

Joined
Oct 24, 2018
Messages
42
Reaction score
14
Location
West Virginia
I have a question. My HDMI module on the controller for my P4 Pro has stoped working. Everything is fine until I plug in the other end of the HDMI cable to a monitor or TV. It then disconnects the aircraft. I have tried different cables and different monitors, no difference. When I disconnect the cable from the monitor, the controller reconnects to the aircraft in a few seconds. Any thoughts?
 
Yep, checked all the settings in Go4, settings were to simultaneously display; even changed the other settings between 2.4 and5.8, 50 to 60, etc with no change
 
I have a question. My HDMI module on the controller for my P4 Pro has stoped working. Everything is fine until I plug in the other end of the HDMI cable to a monitor or TV. It then disconnects the aircraft. I have tried different cables and different monitors, no difference. When I disconnect the cable from the monitor, the controller reconnects to the aircraft in a few seconds. Any thoughts?

remove the module and check that the ribbon cables are fully seated in the sockets
 
Read the attached instructions and follow them precisely. There is a lot of information in it.
 

Attachments

  • Safari - Sep 8, 2020 at 11:07 AM.pdf
    1.4 MB · Views: 299
Read the attached instructions and follow them precisely. There is a lot of information in it.
Hi, did reflashing fix ur hdmi problem? I have the same thing now and am looking for solutions. It was working. And then it didn’t. HDMI mod about 4 yrs old. Never and issue with it until now. Thx
 

Recent Posts

Members online

Forum statistics

Threads
143,021
Messages
1,467,029
Members
104,897
Latest member
TKDroon