Professional gimble crazy no camera

Joined
Jun 6, 2016
Messages
14
Reaction score
0
Age
52
Location
East Texas
When I turn the aircraft on my gimble just rolls bobbles and shakes harder than I have ever seen it do. Also I have no video at all says not connected but seems everything else works fine. ?maybe a tape loose or wire? I dont know what info someone may need but I am certainly willing to get it to you.
thank you
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,081
Reaction score
10,334
Location
Harrisburg, PA (US)
Did you crash? If not, can you think of anything that might have changed since it last worked?
 
Joined
Jun 6, 2016
Messages
14
Reaction score
0
Age
52
Location
East Texas
I had a hard landing yes. Wind caught me and it bounced a few times and then flipped over and stayed there. I did have a crash say a month ago but no adverse effects noted. well none so far.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,081
Reaction score
10,334
Location
Harrisburg, PA (US)
Check that this screw is tight:

P3-Gimbal-Grub-Screw.jpg


If that does not resolve the issue, then try this:

 
Joined
Jun 6, 2016
Messages
14
Reaction score
0
Age
52
Location
East Texas
Both were fine.The ribbon however has come untaped all along the gimble is it safe to check the connections and maybe put a dot iof glue every here and there?
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,081
Reaction score
10,334
Location
Harrisburg, PA (US)
Can you post some closeup photos?
 

New Threads

Forum statistics

Threads
136,480
Messages
1,411,446
Members
99,257
Latest member
draculaus