No video feed... Worked fine last time. Can still move camera with controller but in-app controls are disabled. P3A now detected as P3P

Joined
Jan 14, 2016
Messages
9
Reaction score
5
Age
41
I searched Google and read other threads but none match my issue.

No video feed, just black. I can control the camera tilt using the controller, but the controls in the app are grayed out. Can't take pics/video with controller/app.

Everything in the app reports ready to fly, latest firmware, etc.
Odd thing is now the app insists I have a P3P instead of P3A

If I open the Editor, and click Import from SD card it says "Camera firmware not supported".
In the Camera view it says I have 0 MB remaining on the SD card. It's almost empty. Different SD card, same issue.
I've never noticed if these two things were correct when it was working though as I never use the Editor.

I did have to update my controller firmware today when I opened the app. I'm not sure, but I think the video was not working already.
I updated the app today.

The phantom itself definitely has the latest firmware version.

I tried clearing the app's data/cache.

Lights on the phantom are normal, no light on on the camera.

I'm using an Nvidia Shield btw

My guess is the update killed it. I don't know why I ever bother updating the app or connecting it to the internet so it can force me to update things...

Any suggestions?
 
Last edited:
  • Like
Reactions: Hewa
I searched Google and read other threads but none match my issue.

No video feed, just black. I can control the camera tilt using the controller, but the controls in the app are grayed out. Can't take pics/video with controller/app.

Everything in the app reports ready to fly, latest firmware, etc.
Odd thing is now the app insists I have a P3P instead of P3A

If I open the Editor, and click Import from SD card it says "Camera firmware not supported".
In the Camera view it says I have 0 MB remaining on the SD card. It's almost empty. Different SD card, same issue.
I've never noticed if these two things were correct when it was working though as I never use the Editor.

I did have to update my controller firmware today when I opened the app. I'm not sure, but I think the video was not working already.
I updated the app today.

The phantom itself definitely has the latest firmware version.

I tried clearing the app's data/cache.

Lights on the phantom are normal, no light on on the camera.

My guess is the update killed it. I don't know why I ever bother updating the app or connecting it to the internet so it can force me to update things...

Any suggestions?
Updates and firmware are optional unless craft gets locked or bad mismatch of firmware,,I got locked craft while back,does format of sd card help,,I would go back to start an delete and reinstalled app and see what happens
 
Last time I flew it required an update before it'd let me do anything, so out at my site I had to make my phone a hotspot and update firmware. Huge pain.

There's a thread on the official forum about this same issue it seems (including detecting as P3P all of a sudden etc). But no solution yet. Oddly the staff said to try holding C1+C2+settigns button to supposedly start the contoller and force a new install of the firmware, but that does nothing for me. Can't even find mention of that on Google.

Tried reinstalling the app. Also the second SD card I tried is brand new and newly formatted.
 
Last time I flew it required an update before it'd let me do anything, so out at my site I had to make my phone a hotspot and update firmware. Huge pain.

There's a thread on the official forum about this same issue it seems (including detecting as P3P all of a sudden etc). But no solution yet. Oddly the staff said to try holding C1+C2+settigns button to supposedly start the contoller and force a new install of the firmware, but that does nothing for me. Can't even find mention of that on Google.

Tried reinstalling the app. Also the second SD card I tried is brand new and newly formatted.
Your close on the c1 and c2 ,but forgot the gimble wheel and cam settings dial at same time,,the dials work as button when pressed in
Screenshot_20190428-105601.jpg
 
hmm, c1+c2+record+camera settings button (pushing in the wheel) does nothing / does nothing if I hold those while turning it on. ditto for using gimble wheel instead of record per your suggestion (do you mean just moving the wheel as far as it'll go? that wheel doesn't push in)

I googled this and found another post on the official forum that helped. You press c1 + shutter button + power button. Blue LED comes on. Press those again and the white lights flash. Then plug in your tablet and you'll be able to do the firmware again. I guess they keep changing the procedures...

So it went through the upgrade, listing current version and upgrade version both as 1.9.2.

Bad news is, still no video feed.
 
Installed the apk from Nov 2018 and it still doens't work. Still detects as a P3P also
 
I searched Google and read other threads but none match my issue.

No video feed, just black. I can control the camera tilt using the controller, but the controls in the app are grayed out. Can't take pics/video with controller/app.

Everything in the app reports ready to fly, latest firmware, etc.
Odd thing is now the app insists I have a P3P instead of P3A

If I open the Editor, and click Import from SD card it says "Camera firmware not supported".
In the Camera view it says I have 0 MB remaining on the SD card. It's almost empty. Different SD card, same issue.
I've never noticed if these two things were correct when it was working though as I never use the Editor.

I did have to update my controller firmware today when I opened the app. I'm not sure, but I think the video was not working already.
I updated the app today.

The phantom itself definitely has the latest firmware version.

I tried clearing the app's data/cache.

Lights on the phantom are normal, no light on on the camera.

I'm using an Nvidia Shield btw

My guess is the update killed it. I don't know why I ever bother updating the app or connecting it to the internet so it can force me to update things...

Any suggestions?
I had same problem few months ago when I got my P3A. Did update and after that no video feed but could control everything and take off. Replaced USB board but that didn't help. Bought new controller off ebay and it has worked fine ever since. I tried different phones, tablets and and cords. Rebound RC and AC multiple times.
 
hmm, c1+c2+record+camera settings button (pushing in the wheel) does nothing / does nothing if I hold those while turning it on. ditto for using gimble wheel instead of record per your suggestion (do you mean just moving the wheel as far as it'll go? that wheel doesn't push in)

I googled this and found another post on the official forum that helped. You press c1 + shutter button + power button. Blue LED comes on. Press those again and the white lights flash. Then plug in your tablet and you'll be able to do the firmware again. I guess they keep changing the procedures...

So it went through the upgrade, listing current version and upgrade version both as 1.9.2.

Bad news is, still no video feed.
Yip can second that,,dji needs to rewrite the manual cause not only new faults around these the odd different light patterns to,,this shows they can make good drones but don't fully understand themselves how it works,,,one fix certainly not for all drones I have learnt that over time,,sorry to give you incorrect process,, brain not 100% no more,did not think while writing ,,send dji a email asking what they recomended to fix,,,,that why so much guessing going on cause they won't know either,,they probably ask you to send drone in
 
I found out you can also downgrade the firmware. I tried that but it just fails halfway. It will update back to the latest version though. Same problems still exist. I guess I'll email them and see about repairs. I found another thread on the official forum about the same problem -- they had to send it in and they said the camera needed replaced. Almost $300 fix, yet they did it for free, out of warranty. Hmm
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
143,197
Messages
1,468,415
Members
105,110
Latest member
One-Eye