Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Which Firmware are you guys using?

Discussion in 'General Discussion' started by Harleydude, Feb 13, 2018.

  1. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    Hey doods;

    Just got my P4P. Before I take her for a test spin, I want to know your firmware experiences, both good and bad. I especially wish to know about any post-update crashes or issues.

    Here's what I'm running:

    App: v4.1.22

    Aircraft: v01.01.0203

    Remote: v01.03.00.00

    Precise Fly Safe database: v01.00.01.07

    Basic Fly Safe database: v01.00.01.05

    Disclaimer: I know there's a "Firmware-specific" forum, but I felt because this was a general question that I would post it in the General section.

    Thanx for any help or insight you can give.

    D
     
  2. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    Hey Dude,

    If there's a way to get 1.3.509 firmware in the drone that's what I recommend. It's priceless IMO. With that you can still modify the flight parameters and gain added freedoms. After this May 2017 vintage firmware, the next version DJI closed the back door to do this hack.
     
    CANEKiTA likes this.
  3. Timinator

    Joined:
    Feb 3, 2018
    Messages:
    218
    Likes Received:
    110
    Location:
    TORONTO, Ontario, CANADA
    I picked up my P4P+ two weeks ago and I think it was old stock because it was at version 4.0.0 for the app and the aircraft was 01.02.0304. No plans to update it unless there is some killer "must have" feature.

    John, just wondering what the huge differences are between my FW and the 1.3.509 FW you reference. Off the top of your head, what do you see as the benefits/
     
    Harleydude likes this.
  4. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    I searched the Internet to no avail. Do you have any Earthly idea where to acquire this FW version?

    Funny, I noticed in your sig you run the same Go 4 app version I do. I believe that was the last version before they started requiring random logins to the mother ship, which is why I chose it.
     
    #4 Harleydude, Feb 14, 2018
    Last edited: Feb 14, 2018
  5. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    Yes, that is correct, the last one before re-registering with DJI all the time.

    I think I have 1.3.509 firmware and the Dumldor app to load it, but I've never had to use it. So I cannot speak to the process to install it. This was acquired through GitHub, but it wasn't easy to find. Let me look at it tonight and I'll arrange for you to copy it. Maybe you can figure it out.
     
  6. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    I would REALLY appreciate it. I just need the file, which I assume is a .bin file. I'll figure out how to load it. Thanx!!!
     
  7. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    If you don't mind me asking, why did you stop at 1.3.509? Did you find bugs and/or issues with subsequent updates?

    Also...what is your Remote Control's firmware?

    Thanx!!
     
  8. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    The RC firmware is noted in my signature.

    DJI closed the door to hack the flight parameters after 1.3.509. Those additional freedoms are priceless IMO. I got rid of the wind warnings, I got rid of the REV REV when starting the motors, I reduced the idle speed to 50% normal, along with ability to change other important flight limitations that I won't get into here. Without these freedoms I couldn't have recorded this video.
     
    #8 John Locke, Feb 14, 2018
    Last edited: Feb 14, 2018
    ianzone, Brent10, Erised and 6 others like this.
  9. Timinator

    Joined:
    Feb 3, 2018
    Messages:
    218
    Likes Received:
    110
    Location:
    TORONTO, Ontario, CANADA
    That is just gorgeous, John!
     
  10. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    Awesome video! Comic Sans, eh? A man after my own heart...LOL... I see what you mean regarding "additional freedoms." I'm presently @ FW:

    Aircraft: v01.01.0203
    Remote: v01.03.00.00

    So 1.3.509 would be an upgrade for me. And v1.4 would be an upgrade for my remote, as well.

    I made a couple videos on how to hack the Inspire 1 for longer video range, which requires legacy FW. And I run legacy FW and software on my Mavic. Both run like champs. Zero issues. I look forward to getting my P4P set up like yours. I'm going to peruse the (always incomplete) DJI Release notes to see what they say. I hope you can find that .bin file for me. Fingers crossed.
     
  11. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    I just PM'd you a link. Let me know if you're successful.

    What I don't have is the RC firmware to match 1.3.509 craft firmware. That may be a problem
     
  12. bsartist

    Joined:
    Dec 29, 2016
    Messages:
    803
    Likes Received:
    396
    Location:
    Adirondacks, NY, USA
    I have a brand new P4P with the latest firmware - whatever that is. I’d be interested in this downgrade if possible.

    I’m totally unfamiliar with loading firmware on the P4P. On my P3S I just put the bin file on the SD card and it loaded it. Although after a particular version downgrades were no longer possible.
     
  13. Dronefriend

    Joined:
    Mar 20, 2016
    Messages:
    383
    Likes Received:
    143
    Also on 509 here. Have only adjusted maximum vertical velocity but doubt it does much difference IRL. But if I ever want to add more, I can :)

    Dji.retroroms.info
     
    Harleydude likes this.
  14. Hunter Hoffman

    Joined:
    Jul 26, 2015
    Messages:
    8
    Likes Received:
    0
    Help I can’t find a listing for the phantom 3 advanced firm ware update, advanced is not listed at the DJI site
     
  15. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    It's my understanding that the latest RC firmware plays nicely with FW 1.3.509.
     
  16. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    That's good to know. Who has done that, do you recall? I have questions.
     
  17. Harleydude

    Joined:
    Feb 3, 2018
    Messages:
    134
    Likes Received:
    86
    Location:
    Albuquerque, New Mexico
    It looks like you're running the latest FW on your controller (at least as of 30 days ago). I don't know if there's a new, new version, as I haven't checked. I read in one of the forums. I've been through a half dozen forums trying to figure out how to install my custom FW version to my P4P. Still working on that one....
     
  18. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    Oh yeah, you're right. I was thinking Go4 app. I know they had several iterations come out after I froze mine in May last year. The HDMI port I installed doesn't work, so I'm curious why. I wouldn't think that would be affected by Go4, but it might be. I'm wondering if anyone else who installed the HDMI port on a GL300F controller got it to work OK.
     
  19. Bakersfield Quad

    Joined:
    Jul 14, 2017
    Messages:
    973
    Likes Received:
    297
    I put one on mine a month ago. I had to update it, with Assitant 2 as well as the controller and I believe the AC.
    Works fine.
     
  20. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    5,819
    Likes Received:
    2,572
    Location:
    Yorba Linda, CA
    What version did you update to, and what did you update? The GL300F RC for P4P?

    I wouldn't think the craft firmware would affect the RC HDMI operation. There' s no way I'm moving off of 1.3.509 to find out. The freedoms I get with 1.3.509 are way more important than goggles with the HDMI port.
     
    Timinator likes this.
Loading...
Similar Threads - Firmware guys using Forum Date
What firmware are you guys using? Firmware May 1, 2014
Hey guys, please school me on firmware! Pro/Adv Discussion Dec 17, 2016
Firmware can't upgrade RC from 1.6 to 1.9.3 Phantom 4 Help Sunday at 7:47 AM
Sport mode speed restricted by firmware.. Phantom 4 Pro Discussion Saturday at 6:30 PM
Problem DJI Assistant 2 and P4 Pro V 2.0 will not show firmware Phantom 4 Pro Discussion Wednesday at 7:24 PM