Waypoints: drone slows to a 2-3 second halt when it reaches each each waypoint (the continues onward)

Joined
Oct 29, 2018
Messages
130
Reaction score
88
Age
53
This is bizarre. I've done around 200+ Litchi Waypoint missions over the years. On my Phantom 3 Standard and DJI Spark, suddenly, in any new missions I've created in the last month... the drone will stop dead when it reaches each waypoint. It stops for 2-3 seconds (like a stutter) then it continues onward until it reaches the next waypoint, where it will stop again for 2-3 seconds. It has to be a setting, but I've tried looking at all the normal stuff like setting the default gimbal pitch mode to "Focus POI" or "Interpolate", the path mode to "straight lines" or "curved turns", the heading mode to "custom" or "auto". Basically, I've just tried changing anythign I can think of in the Mission Settings to get it to stop this. I notice the behavior (the stuttering at each way point) when I download the video and view it on my computer.

Any ideas?

Also...and this is only on my Phantom 3 Std: The photo interval doesn't work right anymore. I have it set to capture a photo every 2 seconds. It takes the photo once and then stops. I have the "Take Photo" as an action on every waypoint - that doesn't fix it. One picture....and that's all it will take for the entire mission. Anyone see this before?

Thank you for reading. (Billie Nelson, you ever struggle with these two?)
 
Last edited:
  • Like
Reactions: Billie Nelson
Joined
Sep 10, 2017
Messages
128
Reaction score
114
Age
66
Location
Devon, UK
Hi, I have had those unexpected pauses myself. But I can't remember the fix - probably tried all the settings then eventually uninstalled Litchi and then reinstalled.
All the best, Martin
 
Joined
Mar 9, 2020
Messages
224
Reaction score
71
Age
71
Do you have the camera set for Raw+jpg? that could be the cause, as it's too much data to process every two seconds. Or if you are using too slow of an SD card?
 
Joined
Oct 29, 2018
Messages
130
Reaction score
88
Age
53
Interesting on both replies. The "too slow" sd card...it certainly could be that. I will give it look as I'm about to head out to fly. Thanks!
 
Joined
Aug 17, 2020
Messages
284
Reaction score
165
Age
37
This is bizarre. I've done around 200+ Litchi Waypoint missions over the years. On my Phantom 3 Standard and DJI Spark, suddenly, in any new missions I've created in the last month... the drone will stop dead when it reaches each waypoint. It stops for 2-3 seconds (like a stutter) then it continues onward until it reaches the next waypoint, where it will stop again for 2-3 seconds. It has to be a setting, but I've tried looking at all the normal stuff like setting the default gimbal pitch mode to "Focus POI" or "Interpolate", the path mode to "straight lines" or "curved turns", the heading mode to "custom" or "auto". Basically, I've just tried changing anythign I can think of in the Mission Settings to get it to stop this. I notice the behavior (the stuttering at each way point) when I download the video and view it on my computer.

Any ideas?

Also...and this is only on my Phantom 3 Std: The photo interval doesn't work right anymore. I have it set to capture a photo every 2 seconds. It takes the photo once and then stops. I have the "Take Photo" as an action on every waypoint - that doesn't fix it. One picture....and that's all it will take for the entire mission. Anyone see this before?

Thank you for reading. (Billie Nelson, you ever struggle with these two?)

Very recently about a month ago I too experienced a very odd hesitance mid-flight during a 20-minute duration Litchi autoflight mission. I was flying my Mavic Pro1, and then for the first time ever, I watched the airspeed drop to zero uncommanded. On a hunch that there was a strong headwind holding the drone stationary at 200 feet AGL, I lowered the altitude down to 150 feet, but it still took considerable throttle application to force the Mavic Pro back into forward motion towards the landing site. Then it stopped again, twice in a row.

That was a nail-biting moment for sure, and I'm still unsure as to what could have caused that abrupt slow down thrice in a row. I was too busy watching the camera view to check the map view, but now that you also mention this abnormal pause behavior as coinciding with Litchi waypoints, my suspicion is that just maybe, Litchi flight plans are on very rare occasion subject to this anomaly, only to revert back to normalcy by the time subsequent flights are launched.

Flying the exact same Litchi flight plan at the identical altitude at which the Mavic Pro hit the brakes in rapid succession a couple of days earlier, my old workhorse Phantom 3 Standard flew smoothly with no speed aberrations to report. This behavior is a head-scratcher for sure, and thus far I have encountered it just that once over the course of more than 2,000 miles of fully autonomous Litchi flights logged. Maybe an old hand will stop by this topic at some point and share an insight to unravel this mystery.
 
Last edited:
Joined
Aug 11, 2017
Messages
284
Reaction score
137
Age
65
I had the exact same thing except mine was literally a delay of *minutes*.
I was genuinely concerned I'd lost my drone and headed towards its location then it lurched forward again.
It eventually made it back.
Ran that mission twice more ensuring the batteries were absolutely full.
Never did find the cause.
I deleted that mission and haven't had it since.
I'm betting mine was a corrupt mission waypoint file.
 
  • Like
Reactions: Dallas Drone Guy
Joined
Jan 23, 2016
Messages
300
Reaction score
88
Age
62
Object avoidance sensors & position of the sun relative to the AC is most likely the cause of these issues. (Learned by experience).
The P3 does not have these sensors, so does not show that behaviour.
Just turn off object avoidance when you fly the same mission repeatedly.
 
Last edited:
Joined
Aug 11, 2017
Messages
284
Reaction score
137
Age
65
Object avoidance sensors & position of the sun relative to the AC is most likely the cause of these issues. (Learned by experience).
The P3 does not have these sensors, so does not show that behaviour.
Just turn off object avoidance when you fly the same mission repeatedly.
That was also my first thought however it was
a - away from the sun
b - repeatable over several hours.

I'm well aware of this "trap" as I had a Mavic force land once on a Litchi mission because it couldn't proceed.
 
  • Like
Reactions: Billie Nelson
Joined
Mar 8, 2022
Messages
11
Reaction score
4
Age
50
OK This happen to me recently and i also was confused after going back i noticed some how the speed was changed to 2.1km instead of what all the others were set at which was cruising speed that i had set to 20kmph so it suddenly slowed down to that speed so i redid mission and made sure before i saved that i went through every waypoint and made sure it was set to cruising did that saved it went back out and worked flawlessly.
 
Joined
Jul 17, 2017
Messages
24
Reaction score
1
Age
54
Has there been any more updates on this? I, too and having issues with P4P and Litchi. glitchy. even very simple mission as a test. fly to WP1, take pic of POI, fly to WP2, take pic of POI.

Bird sometimes takes pic, sometimes not, sometimes at POI, most not. Added pasues, doesnt react like you waould think. - pause, take pic, pause, resume flight. sometimes pauses, sometimes not. Sometimes pic no pause. Sometimes pause no pic.

and RTH never works at end. it just tries to land.

Confused. any ideas?
 
Joined
Jul 17, 2017
Messages
24
Reaction score
1
Age
54
Has there been any more updates on this? I, too and having issues with P4P and Litchi. glitchy. even very simple mission as a test. fly to WP1, take pic of POI, fly to WP2, take pic of POI.

Bird sometimes takes pic, sometimes not, sometimes at POI, most not. Added pasues, doesnt react like you waould think. - pause, take pic, pause, resume flight. sometimes pauses, sometimes not. Sometimes pic no pause. Sometimes pause no pic.

and RTH never works at end. it just tries to land.

Confused. any ideas?
I have noticed that while the drone is sitting idling, while I am waiting in pre-flight with everything on, I will be just sitting there monitoring the status and the location of the drone on the litchi map is drifting up to 12 or 15 feet away from the original home point. this, while 10, 11 or even 12 sats locked in. then it will drift back a bit. this will go on for a while and never really stabilize. hmmmm.
 
Joined
Jan 23, 2016
Messages
300
Reaction score
88
Age
62
I have noticed that while the drone is sitting idling, while I am waiting in pre-flight with everything on, I will be just sitting there monitoring the status and the location of the drone on the litchi map is drifting up to 12 or 15 feet away from the original home point. this, while 10, 11 or even 12 sats locked in. then it will drift back a bit. this will go on for a while and never really stabilize. hmmmm.
Are you sure it's the aircraft symbol and not the Blue Dot (controller location).
 
Joined
Jan 23, 2016
Messages
300
Reaction score
88
Age
62
I have noticed that while the drone is sitting idling, while I am waiting in pre-flight with everything on, I will be just sitting there monitoring the status and the location of the drone on the litchi map is drifting up to 12 or 15 feet away from the original home point. this, while 10, 11 or even 12 sats locked in. then it will drift back a bit. this will go on for a while and never really stabilize. hmmmm.
"Bird sometimes takes pic, sometimes not,"
Turn OFF AFC (Autofocus Continuous)

"and RTH never works at end. it just tries to land."
Aircraft automatically descends and lands if RTH is triggered when the aircraft flies within a 65 feet (20 meters) radius of the Home Point.
 
Last edited:
Joined
Jul 17, 2017
Messages
24
Reaction score
1
Age
54
"Bird sometimes takes pic, sometimes not,"
Turn OFF AFC (Autofocus Contineous)

"and RTH never works at end. it just tries to land."
Aircraft automatically descends and lands if RTH is triggered when the aircraft flies within a 65 feet (20 meters) radius of the Home Point.
Oh. How did I not know that after all these years!?!??,?,,!? I prolly just forgot. Well, one less thing.
 

New Threads

Members online

Forum statistics

Threads
141,858
Messages
1,458,753
Members
103,644
Latest member
Jennielaw137