Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Update to 1.6.80 caused problems with Nvidia Shield K1 Disconnects

Discussion in 'Firmware' started by Ron Fodor, May 18, 2016.

  1. Ron Fodor

    May 6, 2016
    Likes Received:
    Yesterday I updated FW to 1.6.80 and my Nvidia Shield K1 tablet is losing connection and the screen goes to black & white. It will reconnect after a while but it soon disconnects again. Needless to say I have not tried it in the air like this. The tablet is setting next to the RC and the P3 Standard is right next to the RC. The odd thing is that my LG G3 phone connects and stays connected just as it always has..... no problem with it. Any suggestions - especially from Nvidia tablet users with P3S and 1.6.80. My DJI Go App is at 2.8.0 and the Nvidia is running Android 6.0.1.
  2. Aldo962

    Feb 14, 2016
    Likes Received:
    IMHO is Android 6.0.1 that causes all these problems. I have the same tablet and experienced these disconnects long before this firmware. What I did is downgraded my Nvidia Sheld K1 to android 5.1.1 and stuck with it. I've then experienced problems while connecting to wi-fi (any wi-fi) on Android startup so I have to force the connection, but then no problems. When my phantom 3 standards disconnects is because i'm too far away, I got more than a km in partial disturbed area with lots of High Voltage pylons nearby, and this with the argtek mod but in CE mode. Now I have a DBS Itelite MOD that I have still to verify as I crashed my Phantom the 2nd day I had it. Now I fixed it, and will try soon. This evening I tried myself the firmware update as soon as the bird finally warmed up correctly
    after the long repair, and it failed. I will retry it tomorrow as now here is 2 o'clock in the night and the bird is doing loud beeps. We'll see.
  3. Farris

    May 20, 2016
    Likes Received:
    Last night, I updated my P3 standard to the latest firmware, which is 1.6.80. After successfully downloaded the package from DJI, I tried to update the new FW into my RC and aircraft. Unfortunately, the updating process is 'hanged' at 5% progress. After that, switched off the RC and aircraft, and turned them ON again. Then, there was no wifi SSID from my Phantom appear in the list of wifi signal available for me to connect it using my phone. Already re-installed the DJI GO apps at mt Samsung Note 4 mobile device. But the same problem still happening. Unable to detect wifi signal from my P3S thus unable me to connect to both my RC and the aircraft.

    Anyone facing the same issue like mine?

    Hope I could get some help here.

    Thanks guys :)
Similar Threads - Update caused problems Forum Date
iPhone update caused camera problems! General Discussion Mar 16, 2014
Firmware update caused drone crash Firmware Nov 11, 2014
Newest software update caused crash on Home lock? Phantom 2 Discussion Sep 20, 2014
Any news on fixing firmware after last update? Phantom 4 Discussion Yesterday at 7:51 PM
P3P issues after firmware update Pro/Adv Discussion Yesterday at 2:49 PM