P4 Firmware Phantom 4 RC Controller failed to upgrade and now won't connect to aircraft

Jun 12, 2016
Reaction score
Northern UK

So I bought a new battery for my old P4 and the DJI App said I needed to update the No Fly Zones, which I did. All was going well except today I got a red warning triangle in the app and it said I need to update the RC controller. I did this and it downloaded the new code, only to get to the end and come up with failed.

Now my phone connects to the controller (says it's connected) but I can't get the controller to connect to the P4 and the version of the controller looks really old. I have downloaded the latest version of DJI Assistant 2 and there was a slightly newer version for the P4 which I have installed, but I still can't get the controller to connect.

I suspect that the RC controller doesn't have basic firmware in it, or has reverted to a really old version, DJI Go 4 says Remote Controller 1.4.30+, that is as far as I can get.

I thought DJI Assistant 2 wou;ld download new firmware in to the controller, but this doesn't work either.

Anyone know how I can recover my Remote Controller?
OK after going through all of the menus several times, I have finally found where to re-install the firmware. I must have tried several times and never found this screen where you get opportunity to download a new firmware version.

I finally found it by click on the blank banner at the top in the middle, between Disconnected and the Status icons, pressing anywhere else didn't get me in to the menu option for download. It was more by chance I found it.

It then showed the red triangle again and gave me the option of downloading the latest firmware, v1.9.3.

This actually worked and got my P4 working again, sadly it is now dark so I can't test it.

I assume that when the new firmware download failed, the Remote Controller went back to some type of default firmware, possibly when it was supplied?
This is the screen

Click the grey bar just to the right of where it says disconnected to get 'Aircraft Status'. Clicking on the icons or DJI logo takes you elsewhere.
  • Like
Reactions: Droneted
I have Phantom 4 Pro Vs. 2 and GL 300L: The only item that communicates is the gimbral moves up and down from my controller. NO picture, NO Fly, NO Red flags to respond to update. Just NO communication. Last time I used it was with my S8 Galaxy Samsung Android phone. I have been on this forum since 2019 but for some reason it has kicked me off and I am starting over.
Hola prendo al conectar el control al teléfono se prende luz purpura y no puedo conectar al dron ,como poder instalar con bin usb.o resetear los de los botones no me sirve


  • 20230310_145704.jpg
    1.8 MB · Views: 65

Recent Posts

Members online

Forum statistics

Latest member