Replaced yaw arm and Ribbon cable but camera is not working. Phantom 4 advanced

Joined
Dec 18, 2019
Messages
5
Reaction score
1
Age
51
Crashed my drone and replaced the yaw arm and flat ribbon. The drone will fly, gimbal goes up and down on its own during start up but you can’t see anything from my screen. I have a camera sensor error and a calibrate error. I connected it to the DJI Assistant 2 and was successful in calibrating it but it would not successfully update the software. Any suggestions from here? The ribbon cable was not an OEM part so I thought maybe it was that. I rechecked all the connections. I would hate to go through replacing the ribbon cable and find out it was something else. One thing troubling is although I was told this cable would work with the advanced model, there is a small leg connector that is not being used. There is no place to connect it to. Any help would be appreciated!
 
Joined
Jan 17, 2019
Messages
149
Reaction score
55
Location
Kentucky
Just went through this with a P4P. Made a couple posts about it on this site. I also read that ribbon with the extra extension may work on the pro & advance but was skeptical. Did take some searching and did find the correct OEM cable for the pro / advance on eBay. Here’s one of the posts I made, maybe search my name for the others.

 
  • Like
Reactions: Ahade
Joined
Dec 18, 2019
Messages
5
Reaction score
1
Age
51
Thanks. I am hoping I could find away to at least verify somehow that it is not another problem before purchasing another ribbon cable and go through the whole replacement process again.
 
Joined
Jan 17, 2019
Messages
149
Reaction score
55
Location
Kentucky
Above my pay grade.. My guess is your going to have to gamble between the cost of a new ribbon vs what it may cost to send it off to DJI or a shop that has the equipment to properly diagnose and repair. Best of luck on getting it figured out.
 
  • Like
Reactions: Ahade
Joined
Jul 17, 2014
Messages
148
Reaction score
79
Age
74
Location
Watkins Glen, New York
DO THIS!!
 
  • Like
Reactions: Ahade
Joined
Oct 29, 2018
Messages
78
Reaction score
34
Age
69
Thanks. I am hoping I could find away to at least verify somehow that it is not another problem before purchasing another ribbon cable and go through the whole replacement process again.
Well I am sorry to hear you are having camera trouble! Now here is my story and I hope it helps you. I have a P3S,I bought it crashed to have something to do(LOL) I did all repairs and had most success,but then I got to the camera,now I know you have a P4P,but the gimbal problems are about the same. I replaced all the motors on the gimbal,the wifi board and the two boards on the gimbal ! I was not going to be beat!!! Now I am no technician,but I did learn a lot,I tried the aftermarket ribbons,I tried the oem ribbon,nothing I did worked and finally 14months later I broke down and sent it to DJI ,I about one month(+or-) a few days I got mu P3S back like new. Cost to me was $320.00 after I had spent all I had spent! Now you can take this for what its worth,maybe you are better at electronics that I am,but I wish you all the luck in the world.
 
  • Like
Reactions: Hounddog
Joined
Jun 2, 2014
Messages
225
Reaction score
60
Age
75
Thanks. I am hoping I could find away to at least verify somehow that it is not another problem before purchasing another ribbon cable and go through the whole replacement process again.


I have used many different aftermarket P4P ribbon cables and many of them still have the extra little extension that the P4Std. required. I just cut them off for the P4Pro. Keep in mind that the P4 ribbon cables are the same, ACCEPT for the end that goes in the camera module. One, of course, is a connector with the gold contacts, while the P4P has the snap in connector.
 

New Threads

Forum statistics

Threads
140,273
Messages
1,446,069
Members
102,035
Latest member
brayanokorner