Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 1 pilot goes to Standard-3 and questions...

Discussion in 'Standard/4k Discussion' started by Afterburner, Aug 25, 2016.

  1. Afterburner

    Joined:
    Aug 25, 2016
    Messages:
    4
    Likes Received:
    0
    Location:
    Shingle Springs
    Hi - I'm new to this site and I have had my trusty Phantom 1 for some years and decided to take the plunge into the Phantom 3 Standard and found out rather quickly that there was some sort of issue going on with the firmware.

    So, I picked up my Standard recently and finally got time to open the box and start testing everything out. First thing the Go app does is try to get me to 1.6.8 and I'm resisting this based on all of the horror stories I've heard so far.

    So the question is this: What, if anything, has DJI done to fix this and why are they still offering the same firmware that obviously is causing issues for everyone? I've heard that calling DJI support is a case study in useless so I'm taking that under advisement for the future as well.

    Finally, I'm getting set to take my first hop with the Standard. Any sage advice to a Phantom 1 pilot who is a bit rusty?

    Appreciate any comments and thanks ahead of time.

    Jon
     
  2. Goldsaum82

    Joined:
    Jul 15, 2016
    Messages:
    245
    Likes Received:
    104
    I'm hoping DJI releases a new (and better) firmware that resolves these issues. It sounds like range problems have been the biggest complaint.
     
  3. Afterburner

    Joined:
    Aug 25, 2016
    Messages:
    4
    Likes Received:
    0
    Location:
    Shingle Springs
    The posts I saw range back to May of this year - I checked the DJI site and no-joy on any discussion of the issue on the Standard's product page...

    I'm not going to upgrade, that is for sure. I just wish I could turn off that bloody upgrade nag to stop them from pestering me about it at every turn... lol.
     
  4. toegema

    Joined:
    Mar 10, 2016
    Messages:
    256
    Likes Received:
    55
    I have FW 1.6.80 and have no issues what so ever. Range is better than advertised (in "Wi-fi clean" environment) and with the FCC mod even better..
    I know some are having issues, but if EVERYONE had issues with this one DJI would have released a new FW long time ago.
    I have no reason to want to downgrade.
    But this is just my experience.




    Sent from my iPhone using PhantomPilots mobile app
     
  5. Bob Langlois

    Joined:
    Apr 10, 2016
    Messages:
    14
    Likes Received:
    6
    1.6.8 works fine on my P3S. I had to install it twice, but it works great.
     
  6. WayneMHK

    Joined:
    May 19, 2016
    Messages:
    96
    Likes Received:
    30
    Location:
    Manhattan, KS USA
    Seconded. And I have 2 of them. If I bought another, I wouldn't hesitate to upgrade.
     
Loading...
Similar Threads - Phantom pilot goes Forum Date
Joining the PhantomPilots forum with a P4S! Introductions Aug 13, 2017
New Pilot - FatShark Goggles hookup to Phantom 4 Pro Plus Phantom 4 Pro Help Jul 24, 2017
Any phantom pilots in the Oshkosh, WI area? Pro/Adv Discussion Jul 21, 2017
The True Knights of the Phantom Pilots Forum . General Discussion Jul 15, 2017
Phantom 3 pilot here from monon Indiana just saying hi and this is amazing Introductions Jul 13, 2017