P4 Firmware update will not install after receiving back form DJI North repair after water crash!

Apr 21, 2016
Reaction score
Not sure not what to do. Just received my P4 back from IFLIGHT TECHNOLOGY CO. This was from a water dunk in Lake Havasu about a month ago. Though DJI would cover but said that if flown over water it would not be covered. Cost $227 to get it fixed. But Now..... after turning on it had warnings and also wanted firmware update. This is what the DJI Go displayed.

Would get RC Signal Lost also two Warnings:

Warning: To takeoff in non-P modes, toggle Flight Mode Switch to another mode and then toggle it back.

Warning: Aircraft Firmware Inconsistent. Download update from DJI Go homepage.

I have the latest DJI Assistant 2 and also I deleted and install the latest DJI Go App.

I tried installing the firmware first from the DJI Assistant 2. There were 3 updates available. I was able to down load the firmware but it displayed; failed to install. I tried 3 times. Then I tried to update from the DJI Go app. After starting the app It displayed download available. I was able to down load the firmware and then it said to connect to phantom at this point nothing then happened. When I connected the P4 I did get the sound that it connected and wanted me to acknowledge access. I then deleted the DJI Go app again and re-installed it. But no luck it did the same thing.

So at this point not sure what to do. Have spent so many hours on this and can not fly. Thinking that something was not done right at the DJI North American repair site in Carson Ca. Hate to have to send back and wait another 2 weeks. We are going on a vacation after the 4th.

Hopefully maybe someone has a fix.....

Recent Posts

Members online

No members online now.

Forum statistics

Latest member