P3S Repaired after 2 crashes, new problems

Joined
Sep 9, 2016
Messages
3
Reaction score
0
Age
68
P3S. First crash broke the grey video cable. I was still able to fly, and the video worked sometimes.

Second crash much more severe, broke the roll motor in half and of course the ribbon cable. If I pushed the motor back together, the drone would still fly using the transmitter, but of course, no video nor avionics came back to the phone.

I replaced the video antenna, and the roll motor and roll arm and ribbon cable. I now get video on the display, and some avionics display items.

When I try to launch the motors (on the workbench), it throws an error "Battery signal error", and the motors will not start. I have checked that the battery is fully inserted, and it definitely is.

Second error is that the every half second or so, the camera shifts up and back down a couple of degrees. Video too large to attach, posted on youtube -

Any help is greately appreciated.
 
Joined
Sep 9, 2016
Messages
3
Reaction score
0
Age
68
If anybody is following this thread, I repaired the first problem of "battery signal error" when I tried to spin up the motors. Not surprisingly, it was self-inflicted. When I reassembled the drone, I did not correctly position the battery connectors. In doing so, I broke off a small post at the bottom that it uses for positioning, as well as the screw-ear.

Fortunately, I was able to crazy-glue both back on. I let it set up for a few hours, then reassembled it all, and it works! I took it out flying yesterday and today, and all seems right with that.

Now I just have to solve the gimbal jitters problem ...
 
Phantom Drones from EALLRC.com

New Threads

Forum statistics

Threads
136,752
Messages
1,414,066
Members
99,400
Latest member
Robert S.