Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Tags:
  1. jmv

    jmv

    Joined:
    Oct 11, 2016
    Messages:
    16
    Likes Received:
    2
    Hi,

    I am trying to get photos at given waypoints but the Phantom is not taking any photos.
    My actions are:
    1-Stop Recording (works)
    2-Take Photo (does not work)
    3-Start Recording (works)

    Any ideas what could be wrong ?

    Thanks
     
  2. FlashBuddy

    Joined:
    May 17, 2016
    Messages:
    439
    Likes Received:
    144
    Location:
    Fort Collins, CO
    When you discuss taking photos at waypoint, you must also make note of "curve". Well?

    NoCo Drones
     
  3. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    6,523
    Likes Received:
    2,149
    Location:
    San Francisco, CA
    Actions are disabled if you select curved paths as curved paths never reach waypoints.


    Sent from my iPhone using PhantomPilots
     
  4. jmv

    jmv

    Joined:
    Oct 11, 2016
    Messages:
    16
    Likes Received:
    2
    I am not using curved paths :(
    I was aware of this.

    Actually ALL actions in curved paths are ignored.
    Actions 1 and 3 worked (but not 2 : Take Photo ) which confirms curved paths are off .

    Any more hints ?

    Sent from my iPhone using PhantomPilots
     
    #4 jmv, Oct 15, 2016
    Last edited: Oct 15, 2016
  5. lmayes69

    Joined:
    Jul 5, 2016
    Messages:
    109
    Likes Received:
    18
    Location:
    Chester, Virgnia, USA
    do you have autorecord on? i think that messes this up. I tried with starting recording as a way point action i was able to stop it and then wait 2 seconds and then take picture. but i think you are are already recording it doesn't work
     
  6. John Locke

    Joined:
    Jun 26, 2015
    Messages:
    4,407
    Likes Received:
    1,793
    Location:
    Yorba Linda, CA
    I've had this same problem, no curved waypoints, but it won't take a photo for some reason. I'm curious what we're doing wrong. If auto record is causing this, that's a flaw that needs reported.
     
  7. lmayes69

    Joined:
    Jul 5, 2016
    Messages:
    109
    Likes Received:
    18
    Location:
    Chester, Virgnia, USA
    on the website it says upload_2016-11-1_14-39-36.png try adding some wait time in there so that the camera can dump the recording the take photo, wait then start recording
     
  8. jmv

    jmv

    Joined:
    Oct 11, 2016
    Messages:
    16
    Likes Received:
    2
    I am not sure if autorecord was on.
    I am away on vacation and do not currently have access to my P4.
    Once I am home I will check and let you know.
     
  9. chazzm

    Joined:
    Sep 26, 2016
    Messages:
    163
    Likes Received:
    28
    I just noticed Litchi had an update today, a lot of problems were addressd! not sure if this could help you or not!??
     
  10. lmayes69

    Joined:
    Jul 5, 2016
    Messages:
    109
    Likes Received:
    18
    Location:
    Chester, Virgnia, USA
    @chazzm which version is it up to now? I am a beta tester but im on version 3.8 last updated on 10/18
     
  11. chazzm

    Joined:
    Sep 26, 2016
    Messages:
    163
    Likes Received:
    28
    It's on 1.13.1 right now,,,,


    Sent from my iPad using PhantomPilots
     
  12. lmayes69

    Joined:
    Jul 5, 2016
    Messages:
    109
    Likes Received:
    18
    Location:
    Chester, Virgnia, USA
    oh IOS user, I'm an android guy
     
  13. chazzm

    Joined:
    Sep 26, 2016
    Messages:
    163
    Likes Received:
    28
    Ahhh I see, I've used both but I have better results with IOS personally


    Sent from my iPad using PhantomPilots
     
  14. ehspro

    Joined:
    Nov 17, 2016
    Messages:
    28
    Likes Received:
    5
    I'm having the same results. Ive ensure that I'm not set for curves, added actions to stop recording, wait 3s, take photo, wait 3s, start recording and move on. I know for sure I was set for "Auto Recording" so perhaps that the issue. I'll run same mission and report back if the photos take correctly.
     
  15. ftttu

    Joined:
    Apr 12, 2016
    Messages:
    616
    Likes Received:
    209
    I was going to fly a mission today with no curved waypoint so I could take images. Nothing unusual about that other than I only flown curved waypoints because I only cared about video, and on this particular first flight, I was going over 4 miles out. Due to the distance, I set it to wait 1.5 seconds to limit battery drain while it is wasting precious battery, but this thread shows I need to wait longer from stopping video, taking an image and starting video again. So, I should turn off auto record start recording myself and set it to wait 3 seconds? Do we have a confirmation consensus?

    I was about to send Day Star on his way but a breeze started up. I'm hoping to update my mission with the above information, but confirmation would be helpful since this is such a long flight.
     
  16. ehspro

    Joined:
    Nov 17, 2016
    Messages:
    28
    Likes Received:
    5
    I'm going to fly a mission later today with the only change being that I don't use auto-start recording to see if that makes a difference


    Sent from my iPhone using PhantomPilots
     
Loading...
Similar Threads - Litchi Actions working Forum Date
Litchi - No Actions on Curved Missions Standard/4k Discussion Apr 9, 2017
Litchi waypoint actions out of range Control (Go, Litchi, etc..) Mar 27, 2017
Cruising speed of Litchi mission finish-actions? Control (Go, Litchi, etc..) Dec 29, 2016
need help with Litchi actions after mission Standard/4k Discussion Aug 18, 2016
Litchi App on iPhone, Cannot Delete Actions Phantom 4 Help Aug 17, 2016