Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Faulty Live Feed / system error

Discussion in 'Phantom 2 Vision + Help' started by katielong, Jul 28, 2016.

  1. katielong

    Jul 28, 2016
    Likes Received:
    Please help, this is a nightmare!

    The live feed won't work, its just shows a black screen with a loading icon.
    I'm using:
    iPhone 6SE App v1.0.6 (I tried to downgrade to 1.0.56 but this failed)
    firmware 3.14

    I've checked all the wires are plugged in correctly, I've tried rebinding the wifi range extender,I've tried downgrading the iPhone app to v1.0.56 but got as far as having the version in itunes but not been able to get it onto the iphone permanently.

    Everything works fine, I haven't crashed it ever and I can still take photos/videos, just no live stream!

    Before today, I'd open it up and there'd be a red light in the app with a 'system error' dialog. This has gone for now but i feel like it could come back. Also, the gimbal adjuster on the remote control doesn't work but the gimbal still works and can be controlled through the app.

    I'm thinking maybe the wifi range extender is 'fried' according to other feeds?? Hopefully I'm wrong! I've spent the past 6 hours trying to fix this, please help!!