black screen

  1. Brent10

    P2V+ Black Screen: DJI to Offer P2 Care Plan for certain Phantom 2 users

    Looks like those of us with the P2V+ black screen problem may qualify for repair/replacement. However, I have already opened up my wifi module and left evidence of soldering when I re-flashed the NAND chip (which fixed it for three days). So mine may not qualify for the Care Plan given that it...
  2. Envirodiver

    FPV problems on P4P

    I have been having major break up, freezes, total green screen, black screen and general break up on my P4P. It has been returned to service 4 times, replaced twice and I even go a new iOs. The service manager in California says they ran it for over an hour on all different devices and find no...
  3. A

    Cant update FW RC and AC bound with RED light?

    Hey guys, New here just got a used P3S from offerup, He said it just needed a FW update so i was like ok cool. Took charged everything up turned on the App and the Remote Control LED shows red and the Phantom Battery shows red but the link shows green and the App says Remote Controll signal...
  4. S

    Solving the black screen FPV (no-live-feed) issue - co-operation needed

    Hey everyone, I think this is time for us to solve the issue called no live feed. Also known as: no live stream black screen FPV telemetry ok but no picture phantom connection broken Possible cause (assumption) 1 haven't used the P2 for a while - when turned on, screen is black, last time it...
  5. W

    Black Screen Issue Few Seconds after tuned on

    Hello guys im having this issue since 2 days ago, i turn on the phantom 4 Rc first then the bird, everything comes up few seconds after is on screen goes black stops showing gps signal and and Drone signal which shows drone icon next to gps says N/A, then few seconds later just says...
  6. K

    Faulty Live Feed / system error

    Please help, this is a nightmare! The live feed won't work, its just shows a black screen with a loading icon. I'm using: iPhone 6SE App v1.0.6 (I tried to downgrade to 1.0.56 but this failed) firmware 3.14 I've checked all the wires are plugged in correctly, I've tried rebinding the wifi...