Copper dust underneath p4p props?

Joined
Dec 25, 2017
Messages
19
Reaction score
3
Age
50
I've noticed dust on the props where they attach to the motors...it must be copper from the motors all of which turn freely and none getting hot after flight.
Has anyone else seen this before? Could it be a sign of problems?
I've attached pic😉
 

Attachments

  • 20191113_152706.jpg
    20191113_152706.jpg
    3.2 MB · Views: 123

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,821
Reaction score
3,878
Location
Western US
Has anyone else seen this before?
I do recall it was thought to be rust from flying near the coast or other waters. I’m not certain if that has been confirmed over time, but since @Meta4 identified it back then I tend to put a lot of faith in it.

Here is one example:
 
Last edited:
  • Like
Reactions: ianzone
Joined
Dec 25, 2017
Messages
19
Reaction score
3
Age
50
Thanks @Oso and @Ruben Fred for the replies...I do live near the coast and fly near or over water quite often but I don't think its rust??

Thanks Oso for the link, I will keep an eye on it and keep you updated if it gets worse or clears up...
 
  • Like
Reactions: ianzone

ianzone

**P4**
Joined
May 22, 2016
Messages
6,889
Reaction score
4,646
Age
51
Location
NZ
I fly by water and in the rain,not sure about actual rust like on cars but more of a residue coming off the spring hardening, me has had discolouring in past and not look pretty but you get that on some,,the spring sets are cheap so if unhappy just replace,,if wipe spring with tissue you might see same colour on tissue
 
Joined
Dec 25, 2017
Messages
19
Reaction score
3
Age
50
I fly by water and in the rain,not sure about actual rust like on cars but more of a residue coming off the spring hardening, me has had discolouring in past and not look pretty but you get that on some,,the spring sets are cheap so if unhappy just replace,,if wipe spring with tissue you might see same colour on tissue
Thanks ianzone, will wipe springs and change them to see if that helps...
 
  • Like
Reactions: ianzone

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,741
Reaction score
8,740
I've noticed dust on the props where they attach to the motors...it must be copper from the motors all of which turn freely and none getting hot after flight.
It must be copper ??
The copper windings in your motors are not subjected to any wear.
There's nothing that rubs on them.
If it's copper, you would have serious issues, but it's not copper.
 
  • Like
Reactions: ianzone and T Dogg

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,376
Reaction score
2,001
Age
69
Location
IRB, Fl
It looks like pollen or oak dust. If so, It will wash off but it does stain. Use a stain remover like rust away, it will disappear. Luckily it is seasonal. If it’s copper, the rustaway will not remove it. Use a magnet to find out if it is rust.
 
Joined
Dec 25, 2017
Messages
19
Reaction score
3
Age
50
It looks like pollen or oak dust. If so, It will wash off but it does stain. Use a stain remover like rust away, it will disappear. Luckily it is seasonal. If it’s copper, the rustaway will not remove it. Use a magnet to find out if it is rust.
Thanks for the info @Capt KO
Will try that out...
 
  • Like
Reactions: Capt KO

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,741
Reaction score
8,740
It looks like pollen or oak dust. If so, It will wash off but it does stain. Use a stain remover like rust away, it will disappear. Luckily it is seasonal. If it’s copper, the rustaway will not remove it. Use a magnet to find out if it is rust.
It's just rust and there's not enough that you could tell with a magnet.
It comes from the spring on the motor post and there should be some around the prop mounts too.
i-BfVX97K-L.jpg

It's a only very minor cosmetic issue.
 
Joined
Dec 25, 2017
Messages
19
Reaction score
3
Age
50
It's just rust and there's not enough that you could tell with a magnet.
It comes from the spring on the motor post and there should be some around the prop mounts too.
i-BfVX97K-L.jpg

It's a only very minor cosmetic issue.
Thanks @Meta4
 

New Threads

Members online

Forum statistics

Threads
140,499
Messages
1,448,232
Members
102,289
Latest member
DanTucker