Ultrasonic sensor error

Joined
Nov 2, 2019
Messages
10
Reaction score
4
Age
81
Upon occasion I get the "Ultrasonic sensor error land immediately" while flying above 50 feet over land. All lights turn red indicating a critical error, I have made sure the sensors are clean and have nothing attached to the aircraft. The Phantom continues to fly normally. Any insight will be greatly appreciated.
 
Joined
Sep 19, 2016
Messages
1,047
Reaction score
432
Upon occasion I get the "Ultrasonic sensor error land immediately" while flying above 50 feet over land. All lights turn red indicating a critical error, I have made sure the sensors are clean and have nothing attached to the aircraft. The Phantom continues to fly normally. Any insight will be greatly appreciated.
I did a search on the error wording on your behalf (search engine here is magnifying glass, top right of the page). Have a look at the 2nd and 3rd results below yours and follow posted links as well. Summarising, it is believed that it's possibly just a glitch, maybe related to firmware versions.


As far as I can see, no one has subsequently reported crashing after getting such an error message, so that must be good news... :)
 
Joined
Nov 2, 2019
Messages
10
Reaction score
4
Age
81
I did a search on the error wording on your behalf (search engine here is magnifying glass, top right of the page). Have a look at the 2nd and 3rd results below yours and follow posted links as well. Summarising, it is believed that it's possibly just a glitch, maybe related to firmware versions.


As far as I can see, no one has subsequently reported crashing after getting such an error message, so that must be good news... :)
Thank you very much. I think I have the latest firmware, but I'll check to be sure.
 
  • Like
Reactions: Steve7777

New Threads

Members online

Forum statistics

Threads
140,511
Messages
1,448,397
Members
102,306
Latest member
ixf4414