Professional Three Errors That Prevent Me From Flying

Joined
Jul 6, 2015
Messages
7
Reaction score
0
Age
29
Hi there! My first night out with my Phantom 3 Professional was touchy. I took her out of her box, turned her on, and then realized I needed to update her firmware to v1.2.6. The next day: an IMU error. So I recalibrated her IMU—and she flew great, man, did she FLY.

Ten flights later, a road trip, and today, I receive an "RC Requires Upgrade" error, accompanied by "Deserializer Disconnected" and the loathsome "IMU Error".

Except this time, the option to calibrate IMU is greyed out in the Pilot App, and the camera no longer feeds video to the iPhone (No Signal).

I've fiddled with the SD card, tried re-updating the firmware (the resulting read me .txt says the firmware is already installed), updated iOS, and I even tried flying her (yes, she still flys). But no video feed, and no recording capability.

One curious thought I have goes back to that first IMU error. Before I knew how to calibrate the IMU, the Phantom's gimbal was limp until I stuck my fingers into her serial ports—at the top of the gimbal. Suddenly, her gimbal sprung to life. However, this didn't solve the IMU error, so I later calibrated it.

Any thoughts on what might wrong with Audrey? :)
 
Joined
Aug 24, 2014
Messages
1,558
Reaction score
415
Location
Orlando
Hey there... I am not trying to be a jerk - but when you say you say you tried re-updating the firmware what exactly did you do? walk us through it step by step. My fear is that you never really upgraded the RC and the txt message is referring to the Phantom.
 
Joined
Jul 6, 2015
Messages
7
Reaction score
0
Age
29
Hey there... I am not trying to be a jerk - but when you say you say you tried re-updating the firmware what exactly did you do? walk us through it step by step. My fear is that you never really upgraded the RC and the txt message is referring to the Phantom.

Thanks for your reply. Well, I've pasted the results from today's attempt (I used the SD card with the RC plugged into the Phantom — earlier I attempted the update with a thumb drive straight to the RC).

If you're right, that would be great. Just one note: the Phantom and RC worked for 10 flights after the firmware update—then suddenly stopped working.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Upgrading ...
Result: Success.

========== 2015.06.21 00:49:19 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2015.07.05 11:10:21 =====================
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:14 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.

========== 2014.01.01 00:00:17 remo-con disconnect======
Packet: P3X_FW_V01.02.0006.bin
Result: Abort.
The firmware on the SD card is identical to or older than the current firmware on the aircraft.
 
Joined
Aug 8, 2014
Messages
389
Reaction score
81
This is very similar to what happened to mine when I updated to 1.2.6. One flight after, worked fine. Next day, same spot. All of those errors plus a compass error, wouldn't let me calibrate. I did the same firmware steps you did. Camera eventually would do its dance, and then go limp with video feed still going. After all the troubleshooting... It was determined the new firmware fried my bird. Got a replacement, via amazon, and then kept it at 1.1.9 and no problems since, much better.

Sent from my SM-G920V using Tapatalk
 

FRM

Joined
Jul 4, 2015
Messages
9
Reaction score
1
The gimbal connector might strip wire might be lose. Look around and you'll find it. Push it in


Hi there! My first night out with my Phantom 3 Professional was touchy. I took her out of her box, turned her on, and then realized I needed to update her firmware to v1.2.6. The next day: an IMU error. So I recalibrated her IMU—and she flew great, man, did she FLY.

Ten flights later, a road trip, and today, I receive an "RC Requires Upgrade" error, accompanied by "Deserializer Disconnected" and the loathsome "IMU Error".

Except this time, the option to calibrate IMU is greyed out in the Pilot App, and the camera no longer feeds video to the iPhone (No Signal).

I've fiddled with the SD card, tried re-updating the firmware (the resulting read me .txt says the firmware is already installed), updated iOS, and I even tried flying her (yes, she still flys). But no video feed, and no recording capability.

One curious thought I have goes back to that first IMU error. Before I knew how to calibrate the IMU, the Phantom's gimbal was limp until I stuck my fingers into her serial ports—at the top of the gimbal. Suddenly, her gimbal sprung to life. However, this didn't solve the IMU error, so I later calibrated it.

Any thoughts on what might wrong with Audrey? :)
 

FRM

Joined
Jul 4, 2015
Messages
9
Reaction score
1
How long did you have it before your return


This is very similar to what happened to mine when I updated to 1.2.6. One flight after, worked fine. Next day, same spot. All of those errors plus a compass error, wouldn't let me calibrate. I did the same firmware steps you did. Camera eventually would do its dance, and then go limp with video feed still going. After all the troubleshooting... It was determined the new firmware fried my bird. Got a replacement, via amazon, and then kept it at 1.1.9 and no problems since, much better.

Sent from my SM-G920V using Tapatalk
 
Joined
Aug 8, 2014
Messages
389
Reaction score
81
How long did you have it before your return
~2 weeks. I had it documented with them maybe 12 days into it, and told them I would work with DJI and the dealer to attempt to fix it first.. but it didn't work and I returned it maybe 5 days laters
 
Joined
Jul 6, 2015
Messages
7
Reaction score
0
Age
29
The gimbal is working fine but I pushed on the wires anyways. No improvement with the Video feed. Today, I called DJI and they said they will fixit, they believe it is some kind of hardware error.

I've just sent the bird away and bought another one in the meantime. Wish me luck with the new drone.

The gimbal connector might strip wire might be lose. Look around and you'll find it. Push it in
 
Joined
Jul 6, 2015
Messages
7
Reaction score
0
Age
29
Are you using iOS to fly your bird? I remember the DJI pilot app made me do a mandatory updated to 1.2.6 before I could fly. I don't want to update my replacement drone, if possible.

This is very similar to what happened to mine when I updated to 1.2.6. One flight after, worked fine. Next day, same spot. All of those errors plus a compass error, wouldn't let me calibrate. I did the same firmware steps you did. Camera eventually would do its dance, and then go limp with video feed still going. After all the troubleshooting... It was determined the new firmware fried my bird. Got a replacement, via amazon, and then kept it at 1.1.9 and no problems since, much better.

Sent from my SM-G920V using Tapatalk
 

New Threads

Forum statistics

Threads
140,595
Messages
1,449,142
Members
102,397
Latest member
vignognas