Advanced RC unit not updating to 1.2.8 from 1.1.5

Joined
Jul 11, 2015
Messages
2
Reaction score
2
Age
40
Currently setting up a new Phantom 3 advanced.
Updating to firmware 1.2.8

The Drone updates fine.
The RC does not update. The current RC version is 1.1.5.
The DJI online technical support is telling me that the 1.2.8 firmware does not update the RC and that the RC running 1.1.5 is fine. It sounds like they are just trying to push this issue aside. Is the 1.1.5 version correct and updated?

Tried multiple card readers, multiple usb sticks, the gimbal method with no result.
 
Joined
Jul 11, 2015
Messages
2
Reaction score
2
Age
40
After being on the phone with DJI text support for 4+ hours:
They had me try:
3 different USB sticks
3 different SD readers, with 3 different SD cards
2 USB cords to connect to the gimbal.
2 different firmware versions on both the RC and the drone.

He finally admitted that they don't know what was wrong.
Note*: 1.1.5 is not the most current RC firmware version. I had to do a pretty deep google search to confirm this. Text support was trying to get me accept the situation since the RC unit is supposedly warrantied for 1 year and the next firmware might fix it. This is an investment and I won't deal with "might".

I am attempting to return the whole package back to the vendor. It was purchased on Amazon via a 3rd party reseller. So far the only company I can depend on lately is Amazon.

Seriously disappointed.
 
Joined
Jun 27, 2014
Messages
142
Reaction score
71
So far the only company I can depend on lately is Amazon.
thumbs up! :)

If nothing else, this whole firmware debacle has taught me that ALL of my future DJI purchases WILL be made through my Amazon Prime account.

Amazon Prime and Visa Platinum have done more to address my problems than DJI or my original vendor. In fact, my "factory authorized" vendor wouldn't even return my calls until I started routing the calls through Visa's dispute resolution department. Sorry it had to be that way...no slam, just fact.
 
Joined
Jul 25, 2015
Messages
16
Reaction score
1
Age
57
I am having the same problem described above and have tried all the mentioned combinations. I have prepped a few dozen Phantom 3's both Advanced and Professional. I have just started having this problem within the last week. When updating the radio on the advanced, it would not update at all but indicated on status that RC required to be updated. On an IOS device the message did not come up. I let it go as forums suggested. Now the problem has surfaced on a Professional version for the first time. I don't have an IOS device to confirm. This is with update to 1.2.6 on pro and 1.2.8 on advanced. Info screen says version is 1.1.5.

Has anyone found an explanation and solution to this problem? Is anyone else experiencing it on the Professional version.
 
Joined
May 16, 2014
Messages
3,530
Reaction score
625
Location
Sydney Australia
Insert the battery that was updated with the phantom.

I think the pilot app reports the lowest firmware on the batt/rc/phantom.
 
Joined
Jul 26, 2015
Messages
41
Reaction score
3
Age
60
I'm having this exact problem. It's really buggy. The Phantom 3 went through the updating process fine, but the radio isn't updating at all. No blue light, etc. The "DJI Pilot" app says the firmware is 1.1.5 and that I should update it. .

I have also tried several times in several different ways to no avail.

What is really weird is on some occasions when I look, it says it has the 1.2.8 version on it. but I may check again in a few minutes and it says it's 1.1.5

I guess my question is, can I fly it like this? Do I try and return it? Will the next frimware update fix this problem?
 
Joined
Dec 21, 2014
Messages
468
Reaction score
94
Location
Northern NJ
After being on the phone with DJI text support for 4+ hours:
They had me try:
3 different USB sticks
3 different SD readers, with 3 different SD cards
2 USB cords to connect to the gimbal.
2 different firmware versions on both the RC and the drone.

He finally admitted that they don't know what was wrong.
Note*: 1.1.5 is not the most current RC firmware version. I had to do a pretty deep google search to confirm this. Text support was trying to get me accept the situation since the RC unit is supposedly warrantied for 1 year and the next firmware might fix it. This is an investment and I won't deal with "might".

I am attempting to return the whole package back to the vendor. It was purchased on Amazon via a 3rd party reseller. So far the only company I can depend on lately is Amazon.

Seriously disappointed.
Really sorry to hear this. I can also recommend B&H for impeccable customer service and an all around great shopping experience. I use them instead of Amazon in these kinds of purchases as there is no tax and I get the item in 1 day free shipping (I'm in NJ, they're in NY). They are also an authorized DJI dealer so they can fix issues in their shops without necessitating a return to China.
 
Joined
Jun 3, 2014
Messages
471
Reaction score
123
Well, I too just received my p3A and after reviewing a few posts about this topic here and elsewhere am very reluctant to upgrade to the newest firmware v.1.2.8 as well. What else can be done to resolve this issue other than WAIT for a new and still to be considered a "Not so sure" update to the firmware??
 
Joined
Jul 27, 2015
Messages
19
Reaction score
3
Age
54
I also had the same problem. Somewhere I read a post that said that 1.2.8 does not include the controller update? Been through 6 fights so far with no issues including any video lag on Tab s 8.4. I did also see the update recorded under "about" in the Pilot app but later it reverted back. Maybe it was the battery, so I will have to check next time I use each battery.
 
Joined
May 10, 2015
Messages
3,622
Reaction score
870
Age
76
Location
San Antonio, TX
There were instructions at one time to be sure and leave the firmware update bin file on the sd card and cycle each battery with the been file to update the battery-- so that may be the issue. I have five batteries and they were all run the first time with the bin file on the sd card. However, I am still on 1.1.9 and have not upgraded yet. Don't fix it if it's not broken, so I am still waiting for the right firmware.
 
Joined
Jul 26, 2015
Messages
41
Reaction score
3
Age
60
Is there a way to roll back the update to 1.1.9 from 1.2.8?

I keep having to reboot my Galaxy Note 10.1. It keeps freezing on me.
 
Joined
Jul 25, 2015
Messages
16
Reaction score
1
Age
57
I have now opened 12 boxes, 10 Professional and 2 Advanced and they are ALL experiencing the same problem. Always kept the original battery that was updated with the machine, in the machine. I have no problem if the update is for the machine only, but why is it reporting the RC as requiring the update then? It is very difficult to give someone their $2K machine and say, ' oh, just ignore the status warning.... ' This really is not very acceptable situation and wish DJI would step in and clarify the situation or provide an update. Personally, it looks like this might be a radio issue as the radio does not seem to recognize the bootstrap or .bin file at all, it does not even appear to try. If this is the case, then even if they release a new firmware version, what will make it kick in any better than this release version? Since all other combinations create the txt file and report 'firmware as being same or older than current firmware on device', then why not in this case?
 
Joined
Jul 27, 2015
Messages
19
Reaction score
3
Age
54
Is there a way to roll back the update to 1.1.9 from 1.2.8?]

Not sure how the phantom reads the file but has anyone tried to rename the older files and see if it will load? For example take 1.1.9 > right click > rename > P3S_FW_V01.02.00081. I have seen this done on other things that would not take older files.
 
  • Like
Reactions: Bigfoot_Hunter
Joined
Jul 22, 2015
Messages
164
Reaction score
65
Location
San Diego
I have now opened 12 boxes, 10 Professional and 2 Advanced and they are ALL experiencing the same problem. Always kept the original battery that was updated with the machine, in the machine. I have no problem if the update is for the machine only, but why is it reporting the RC as requiring the update then? It is very difficult to give someone their $2K machine and say, ' oh, just ignore the status warning.... ' This really is not very acceptable situation and wish DJI would step in and clarify the situation or provide an update. Personally, it looks like this might be a radio issue as the radio does not seem to recognize the bootstrap or .bin file at all, it does not even appear to try. If this is the case, then even if they release a new firmware version, what will make it kick in any better than this release version? Since all other combinations create the txt file and report 'firmware as being same or older than current firmware on device', then why not in this case?
You're a vendor? And going in and updating firmwares on phantoms before delivery to customers?
 
Joined
Jul 9, 2014
Messages
57
Reaction score
3
P3A arrived on Monday, same problem with firmware - drone update OK, TX no luck
 
Joined
Jul 26, 2015
Messages
41
Reaction score
3
Age
60
Any word if they are fixing this problem or should I unload it on craig's list and go with another more reliable quad?
 
Joined
Jul 9, 2014
Messages
57
Reaction score
3
as per other forums and threads - if TX model is newer 300B version (sticker on bottom side) then firmware upgrade will not happen until newer fw is released, should be safe to fly anyway
 
Joined
Jul 29, 2015
Messages
84
Reaction score
24
Age
44
dronebandit, could you please post link for other forums and threads that mention the newer 300B?

This is the first mention I have found about this. My controller happens to be of that flavor.

I received my new Phantom 3 Professional yesterday and after easily updating firmware on Drone to 1.26 and figured after as smoothly as that went, the RC would be a breeze, however not the case. I tried multiple USB drives, Mini SD cards, SD readers and trying to update from having RC attached to Gimbal with no luck. RC will not update and I am super bummed.

Trying to figure out as much info as possible while toying with the idea of just returning the phantom. I was so excited to get this, have not even gotten to fly it once and I have an RC that refuses to update.

These updates could stand to be streamlined a bit for sure.
 
  • Like
Reactions: Meklinite
Joined
Jul 29, 2015
Messages
146
Reaction score
42
Age
78
Hi Guys:
-
Here’s the scoop …
-
1.) Brand new, NEVER flown, new Phantom 3 Pro purchased from authorized dealer B&H in New York.
2.) Set everything up and got a “firmware update required”.
3.) I really hesitated to do that because everything up to that point was 4x4.
4.) Pulled the micro SD card and went to your site for the new update.
5.) Followed the on-line video instructions to the letter.
6.) Downloaded the bin file. Put it on the card. Put card back into the aircraft.
7.) Load went fine. All the proper beep-beep sounds. Process ended correctly.
8.) Put the card back into the computer.
9.) Got the success message. Cool.
-
Now the FUBAR begins…
10.) Took the card out. Put card into USB / SD adapter and put into the RC control as instructed.
11.) RC load did not go as it should have. Wrong color LED. Wrong beeps.
WTF ??? ****! Screen says, “Firmware update required” but then says “Safe to Fly” !!! ???
-
Looks like I have joined this "club" : ^ (
 
  • Like
Reactions: Meklinite
Joined
May 10, 2015
Messages
3,622
Reaction score
870
Age
76
Location
San Antonio, TX
Hi Guys:
-
Here’s the scoop …
-
1.) Brand new, NEVER flown, new Phantom 3 Pro purchased from authorized dealer B&H in New York.
2.) Set everything up and got a “firmware update required”.
3.) I really hesitated to do that because everything up to that point was 4x4.
4.) Pulled the micro SD card and went to your site for the new update.
5.) Followed the on-line video instructions to the letter.
6.) Downloaded the bin file. Put it on the card. Put card back into the aircraft.
7.) Load went fine. All the proper beep-beep sounds. Process ended correctly.
8.) Put the card back into the computer.
9.) Got the success message. Cool.
-
Now the FUBAR begins…
10.) Took the card out. Put card into USB / SD adapter and put into the RC control as instructed.
11.) RC load did not go as it should have. Wrong color LED. Wrong beeps.
WTF ??? ****! Screen says, “Firmware update required” but then says “Safe to Fly” !!! ???
-
Looks like I have joined this "club" : ^ (
It is probably safe to fly-- there are numerous posts on this forum with the exact results and the firmware on the craft updated, but the controller did not--
Most of these guys are flying, some with issues and some not.
Put it in the air close in and fly it for a few flights. Make sure you understand the fail safe mode and what it does and the flight modes and what they do.
 
  • Like
Reactions: Meklinite

New Threads

Forum statistics

Threads
135,413
Messages
1,401,109
Members
98,635
Latest member
Hovrtek