Problem connecting samsung tab S2 to either one of × my P3P

Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
42
I just bought the samsung galaxy tab S2 to be used with my P3P and was able to download the DJI go app and the litichi app onto the tablet but when I go to connect my drone, neither app will connect to my drone. Is there a setting that I'm overlooking that needs to be changed on my tablet? If there is anyone that could help me out I would greatly appreciate it!
 
Joined
Jul 1, 2016
Messages
252
Reaction score
65
Age
81
First I would try with just one app installed, preferably DJI Go. There have been reports of problems using tab S2 running Android 6 when Litchi & Go are both installed. I have that problem with mine but haven't looked into a solution yet. It works good with just Go installed.
 

Dronason

Premium Pilot
Joined
Aug 9, 2015
Messages
562
Reaction score
99
Location
Switzerland
Yes, try only with the GO app first.
Same here with mine. It comes with android 6 version, before with 5, there was no issue like that.
Check in the settings / applications / default if there is something that would use the USB connection and removed it.
With your RC on, the quad powered, the tablet powered (the app is not running), then connect the USB or disconnect and reconnect it. It should ask what application to use or launch GO app directly (if it is set as the default application). You can also check in the status bar of the tablet if there is an icon "Connected to a USB accessory", on mine it is set to "Charging".
Many report that their USB cable were faulty, so good to try another one.
To use Litchi after using GO app, I have always to clear application default setting for the GO app, connect USB, then it ask what default app to use, select Litchi and then Litchi become the DEFAULT app. To use GO app now it is the same story to clear default etc... So I give up using Litchi on the Tab S2, I use just GO app and Litchi on another tablet.
This seems not to be android 6 related but more Tab S2 related. Some others with android 6 reported correct operation.
 
Joined
Jul 1, 2016
Messages
252
Reaction score
65
Age
81
Maybe the problem is with Samsung's version of Android 6. Mine worked with no problems on 5. Don't know if I'm bold enough to try unlocking it and installing Google's clean Android 6.
 
Joined
Jul 11, 2016
Messages
11
Reaction score
2
Age
51
My Samsung S2 works fine (Android 6), but it's with a Phantom Standard, not Pro. I have both Litchi and Go installed, but only one is running at a given time (the other, I always force-close).

For a P3S, I don't have any USB cable to connect.
 

Dronason

Premium Pilot
Joined
Aug 9, 2015
Messages
562
Reaction score
99
Location
Switzerland
Good point. The problem lies in the USB connectivity.
That's what they call "USB accessory".
Today I used the app from Pix4D with this tablet. With Litchi, I had to change the setting for the default app that handle this type of "USB accessory" each time I want to use either Litchi or GO. With Pix4D I was surprise that it detect the issue and propose to remove GO as the default app and then it takes the USB for him. Nice is that they propose in that app to do this either one-time or by default (what was in the dialog of android 5 on this tablet). Then this app didn't become the default. If you quit the app, then you get the choice of the app dialog when you connect the USB.
I don't have seen the same possibility with Litchi and for sure not with GO app.
 
Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
42
I've tried everything you guys recommend it and I'm still having the same problem what I've noticed is there is something going on with the USB accessory because it keeps going to the MTP transferring but what I noticed when it does work it should be on charging mode but even when I change it to charging mode it still doesn't work I'm so frustrated with this my question is should I just go out and buy an iPad Air 2 I really don't like Apple products but I'm not going to deal with this problem when I'm on a job site and it's my understanding that Apple products some more compatible with DJI
 

Dronason

Premium Pilot
Joined
Aug 9, 2015
Messages
562
Reaction score
99
Location
Switzerland
Did you tried another USB cable ? Better not a spiral one, I had one with the TAB S2 and it it didn't make contact well.
 

Dronason

Premium Pilot
Joined
Aug 9, 2015
Messages
562
Reaction score
99
Location
Switzerland
2 votes for a USB cable check :)
 
Joined
Dec 27, 2015
Messages
80
Reaction score
11
Age
74
I've tried everything you guys recommend it and I'm still having the same problem what I've noticed is there is something going on with the USB accessory because it keeps going to the MTP transferring but what I noticed when it does work it should be on charging mode but even when I change it to charging mode it still doesn't work I'm so frustrated with this my question is should I just go out and buy an iPad Air 2 I really don't like Apple products but I'm not going to deal with this problem when I'm on a job site and it's my understanding that Apple products some more compatible with DJI
My Samsung Tab S2 tablet works perfectly with the Phantom 3 Pro, I have Android version 6.0.1
 
Joined
Jun 16, 2016
Messages
325
Reaction score
71
I just bought the samsung galaxy tab S2 to be used with my P3P and was able to download the DJI go app and the litichi app onto the tablet but when I go to connect my drone, neither app will connect to my drone. Is there a setting that I'm overlooking that needs to be changed on my tablet? If there is anyone that could help me out I would greatly appreciate it!

Which model of the S2 are you using?

Have a look at this post from another forum, note the first post and how the op got the T-713 to work.
 
Joined
Feb 14, 2016
Messages
223
Reaction score
78
Location
Dallas, TX
I have the Tab S2 9.7 with 813 model too. I had the same issue and solve this by changing the USB configuration to RNDIS.

From a Home screen, navigate Apps icon > Settings. If Developer Options is unavailable, navigate: Apps > Settings > About device then tap Build number 7 times. Ensure the Developer options switch (located in the upper-right) is turned on . Tap USB debugging to turn on or off .

In developer mode, in USB configuration select RNDIS. The default is MTP so you will need to change it to RNDIS everytime you connect your USB cable to the S2.
 
  • Like
Reactions: Jree80
Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
42
I have the Tab S2 9.7 with 813 model too. I had the same issue and solve this by changing the USB configuration to RNDIS.

From a Home screen, navigate Apps icon > Settings. If Developer Options is unavailable, navigate: Apps > Settings > About device then tap Build number 7 times. Ensure the Developer options switch (located in the upper-right) is turned on . Tap USB debugging to turn on or off .

In developer mode, in USB configuration select RNDIS. The default is MTP so you will need to change it to RNDIS everytime you connect your USB cable to the S2.
Awesome bro it worked the first time but then when I tried to duplicate it it's not connecting right away again. My question is should I set that all up before I turn my drone and remote control on or should I have my drone and my remote control on with the USB plugged in and then go in and change the USB settings
 
Joined
Jul 17, 2016
Messages
35
Reaction score
2
Age
42
Awesome bro it worked the first time but then when I tried to duplicate it it's not connecting right away again. My question is should I set that all up before I turn my drone and remote control on or should I have my drone and my remote control on with the USB plugged in and then go in and change the USB settings
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,961
Messages
1,459,585
Members
103,744
Latest member
Miatakoss