Phantom 4 "Twitching" when using Active Track

Joined
Dec 14, 2016
Messages
2
Reaction score
0
Age
46
First time poster here!

I haven't really used Active Track much on my Phantom 4 but I tried it today. It acted a little strange, seeming to "twitch" when it began following me. Here's a link to a youtube video of this.

It does it some at 19 secs, but even more so at 40 secs.


Is this normal? I have only flown this P4 maybe a dozen times since I bought it in November.

As a side note, this is the first time I've flown it since a crash using DroneDeploy. It was 331 ft up over a swampy area and simply just tumbled to the ground with no good explanation. In fact, the only thing I can think of is a bird strike.

It crashed and was partially submerged in swamp water but I dried it out and it seemed ok until today with the Active Track peculiarity. If you're curious about the crash I've posted on DJI and DroneDeploy forums. DJI of course wants me to send the unit in for analysis but instead I linked them to the flight log that I downloaded using Assistant 2. But I have not received their response yet.

DJI Forum Link:

Phantom 4 falls from sky using DroneDeploy

DroneDeploy link:

Phantom 4 Tumbles to ground while mapping w/ DD, log files?

I greatly appreciate any help anyone can give me!

Could the sensors be damaged?

-Ray
 
Joined
Dec 15, 2016
Messages
1
Reaction score
0
Age
27
Hi, Im completely new to all of this, had my first drone turn up on Monday, and have been trying out the features as well and I've noticed the same thing with active track, look at the end of my video its just the same, and the only thing I can think of is that the camera is doing its best to keep the object in the middle of the frame that it looses its smoothness.


 
Joined
Dec 14, 2016
Messages
2
Reaction score
0
Age
46
Hello again,

Just tried Active Track again a little while ago and no problems at all! Everything was smooth.
The only thing I did differently was to calibrate the compass before taking off. So, hoping everything is ok.
 
Joined
Jan 27, 2017
Messages
669
Reaction score
281
Age
75
Location
NH
My P4P did this in the earlier releases of the software. I think the enhanced braking function was hyper active. This might have been associated with earlier efforts at tuning the response to obstacle avoidance. New releases have toned down the braking response in Active Track Mode ... at least as far as I can observe.
 

New Threads

Forum statistics

Threads
134,561
Messages
1,392,106
Members
98,093
Latest member
calebpp