Phantom 4 - gimbal shut down on mid-air

Joined
Nov 19, 2016
Messages
24
Reaction score
18
HI everyone. During today's flight I've unexpected situation. After few minutes of flight, in mid-air the gimbal suddenly was shut down, the same as if the drone was turn off completely. There was absolutely no error indication on screen. The rest (model steering, video link etc.) worked perfectly as usual. But camera movement was unoperable. It was "limp", yet still provided image.
After landing I've turn off the drone and then turn on again. Gimbal returned to normal operation. I've moved it around and shook a little bit by hand, and everything was absolutely OK. I repeated off and on cycles few times and one time problem occurred again. So I did " Gimbal Auto Calibration" on the app. After that I flew for about 40 minutes and everything was fine, I'm not sure if the gimbal calibration solve the problem, or it was just coincidence.
I'm fist owner of the drone, I flew it only about three hours. I've operated it whit extreme care (always catch by hand to avoid unnecessary stress by user error), so I'm sure that there was no physical damage to the drone and camera. Previously I've used Android app, today I switched to iPad Air2. I'm not saying that it is related, I'm only want to mention all the facts.

Please help because I'm really freaking out.
 
Last edited:

Mark The Droner

Premium Pilot
Joined
Aug 26, 2015
Messages
5,316
Reaction score
1,741
There's not much you can do so there's no point in worrying about it. But it does sound like the calibration fixed it. If not, we shall see.

Welcome to the site!
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
Thank you for replay. I put a quick update. To be sure, I have decided to reset the P4 and my iPad to factory default and setup all setting from scratch. After that I've put the drone on desks and watch what's happen (radio and drone ON, engines not arm). After a few minutes of operation without any problems, when I barely touched the Phantom to pick it up the gimbal has stopped working again :(
I wrote about this to DJI support, I am waiting for their response. If anyone has any idea what this could be please help.
I added a video of the first incident (24MB)
https://dl.dropboxusercontent.com/s/n31wvl7t52fgl9a/gimbal.mp4
 
Last edited:
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
Hi,

Something similar happened to me yesterday. 2/3 min in whilst panning right the gimbal went limp but controls remained ok. Flew it back and restarted and it calibrated back level as per normal start up sequence.

I then changed batteries and the problem did not return.

Checked my flight logs and it does show a battery error. Also looked at my video and the camera did its side to side start up wobble/calibration during this error but instead of stopping at the midpoint its as if it stopped to the leaning to the right. So looks like the gimbal re-booted mid flight..

Have u checked ur logs on the app?

Oh btw connected to myhealthydrone and shows no major faults
 
  • Like
Reactions: Riker
Joined
Nov 19, 2016
Messages
24
Reaction score
18
Thank you very much for response RedDragon. It starts to make sense. All my gimbal failures have occurred at the same battery (twice in the field and once at home). Unfortunately I do not have records of that flight. All data has been lost when I reset my iPad :(. I have two additional batteries, and today's flights passed without any problems - just like yesterday at the end. It seems that the problem affects only one battery as in your case. I was a little scary to fly again on that battery... I would like to hear the opinion of the DJI.
 
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
Also, are you doing a compass calibration before flying this was suggested to me as it may effect the gimbal.

Yes would be intetesting to get DJI's reason. I have also sent a query in to them.

I was not sure if it had any link to the recent firware upgrade..
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
Yes, I do calibration every time. Also I'm trying to fly "by the rules" as good as I can.
I still wait for DJI response, let you know when they write to me.
When new firmware will be released I'm sure that apps will inform users.
 
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
Thank you very much for response RedDragon. It starts to make sense. All my gimbal failures have occurred at the same battery (twice in the field and once at home). Unfortunately I do not have records of that flight. All data has been lost when I reset my iPad :(. I have two additional batteries, and today's flights passed without any problems - just like yesterday at the end. It seems that the problem affects only one battery as in your case. I was a little scary to fly again on that battery... I would like to hear the opinion of the DJI.
Any news back from DJi?

They are suggesting that i send my phantom back
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
I received a similar answer. In response I pointed out to this topic. At the moment, we can assume that the problem makes the battery, not a drone itself. On Sunday I flew at all three batteries without any problem. Tomorrow I plan further tests.
 
  • Like
Reactions: RedDragon
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
Can you keep me posted how you get on. I will wait their further reply tomorrow
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
Thanks. Will be easier to me if the problem was more frequent... or did not show up anymore.
 
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
Ye I know what you mean. Dji support online chat did suggest doing a factory reset aswell and re installing the firmware on the battery and craft. I have done this but will probably end up sending mine back if they reccommend that. Just not worth the risk of loosing it.
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
You're right, safety first. If it happens to me again on another battery I'll do the same thing. I hope however that it is the fault of the one particular battery. We will see.
 
Joined
Nov 19, 2016
Messages
24
Reaction score
18
So I have just come back from the field and everything works fine. All three batteries operate without any problems. I don't know what to think about it.
 
Joined
Nov 20, 2016
Messages
16
Reaction score
2
Age
41
It may be just a glitch but I am sending mine back. Just cant risk loosing it or it crashing.
 

New Threads

Forum statistics

Threads
139,541
Messages
1,439,556
Members
101,335
Latest member
kc2pk