Phantom 3 Standard Gimbal not working App keeps disconnecting 8seconds

Joined
Mar 6, 2019
Messages
112
Reaction score
19
Age
27
Hello, just bought used pHantom 3 for parts Remote light goes from red to green every 7-8seconds and app keep disconnecting new flex cable didn't fix the problem any suggestions also can anyone confirm phantom 3 telemetry is working without camera and just the gimbal board ?? because i can't find the reason, camera gets hot but doesn't work when i reset settings gimbal barely moves but does not hold position.
 
Joined
Jun 23, 2019
Messages
4
Reaction score
0
Age
43
I have same issue for my P3S...however when I plug the drone to the PC the camera comes on and I can view it
 
Joined
Mar 6, 2019
Messages
112
Reaction score
19
Age
27
Having same issue even after I replaced gimbal board twice
Seems like two boards were broken on my camera, gimbal main board, and one inside the camera housing. I even bought gimbal main board for 3$ and it was dead. Gimbal main boards are really fragile on phantom 3 series :( maybe you could try testing others things like relinking
 
Joined
Oct 17, 2019
Messages
2
Reaction score
0
Age
46
Seems like two boards were broken on my camera, gimbal main board, and one inside the camera housing. I even bought gimbal main board for 3$ and it was dead. Gimbal main boards are really fragile on phantom 3 series :( maybe you could try testing others things like relinking
I think if my wife hears the drone bleeping anymore it may go on its first flight (Out the window into the dustbin)
 

New Threads

Forum statistics

Threads
140,612
Messages
1,449,328
Members
102,415
Latest member
jeryslo