P3 Firmware Phantom 3 Advanced Update Problem

Apr 30, 2023
Reaction score
Hi All, thanks for letting me join. I need some help to get set up with a Phantom 3 Advanced. I have a decent background in electronics, although more on the hardware side, and I do field service for a job so I’ll try to be as detailed as possible.
My dad received a new Phantom 3 Advanced (with GL300A) as a gift back in 2015, and since then it has sat in storage until last week he gave it to me as I would like to get into drones.
First thing I did was try to charge the battery and control, the controller charged, but the battery did not, so I ordered a replacement from Amazon which arrived and successfully charged.
Next I downloaded the Go app and tried to connect everything. The controller had a green LED followed by white, and I was able to move the camera around. I was not able to connect though, the app just gave the option “learn how to connect” which I did multiple times without luck. This was the same using either a Samsung a7 or IPhone 12 mini. The tablets did charge when connected.
I did some brief searching and saw that it could be a firmware issue, or possibly a hardware issue with the USB port.
I downloaded the most recent firmware from DJI, unzipped it, placed it in the root of the micro SD, and started the drone. After about 20 minutes the LED on the gimbal was solid green and the drone was making a pattern of 3 beeps, so I thought it was complete. This is where I am at now, and am not sure how to proceed.
Currently, when I power on the drone, it does the self check, then the two front? loghts are solid red, the back two strobe between green/yellow/red, the LED on the gimbal is solid green, and it beeps non stop beep-beep.
When I power on the controller, the first light strobes red/green and the rest are white.
I tried to manually bind the controller, but nothing changed. I tried to update the controller firmware using a USB stick, and by using a cable to the gimbal, but nothing changed.
Please, any help guidance is very much appreciated…

I did see "[00013354][11 01] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support." but not sure what it means.


  • P3S_FW_RESULT_AB.txt
    945 bytes · Views: 76
  • P3S_FW_LOG_AB.txt
    9.3 KB · Views: 84
I downloaded the most recent firmware from DJI
Updating Ph3 FW is usually a bad idea. The older the better.

so I thought it was complete.
According to the log you provided, you did successfully updated to 01.11.0020. This is actually one of your problems.

See here:
 [00014597]Version checking[1]...
 [00014693][03 06][00] v2.4.20.50 -> v2.4.20.50
 [00014774][03 05][00] v34.2.0.9 -> v34.2.0.9
 [00014841][04 00][00] v1.48.0.0 -> v1.48.0.0
 [00014953][11 00][00] v1.8.0.0 -> v1.8.0.0
 [00015073][11 01][00] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support.
 [00015117][11 01][00] v1.8.0.0 -> v2.0.0.33
 [00015206][12 00][00] v1.12.0.0 -> v1.12.0.0
 [00015319][12 01][00] v1.12.0.0 -> v1.12.0.0
 [00015402][12 02][00] v1.12.0.0 -> v1.12.0.0
 [00015501][12 03][00] v1.12.0.0 -> v1.12.0.0
 [00015551][15 00][00] v1.1.2.0 -> v1.1.2.0
 [00015653][17 00][00] v1.1.1.7 -> v1.1.1.7
 [00015786][17 01][00] v1.0.2.7 -> v1.0.2.7
 [00015864][19 00][00] v1.0.8.96 -> v1.0.8.96
 [00015909][01 00][00] v1.25.5432 -> v1.25.5432
 [00015955][01 01][00] v1.25.5432 -> v1.25.5432
 [00016023][09 00][00] v4.1.0.0 -> v4.1.0.0
 [00016066]Packet upgrade cancelled at version checking.

In first bracket you've got timestamp which doesn't matter.
In 2nd bracket, there's module ID. Read here for what the modules are. Outside DJI, we usually put an "m" in front to indicate we're talking about a module, ie. "m0306" is the flight controller.
The 3rd bracket doesn't matter, is always 0 for most DJI products.
Then there's a current version and version within your FW file, for each module.

So looking at the versions, update was successful, and all modules are responding.

it beeps non stop beep-beep.
I assume "it" means that main motors of the drone are beeping, or at least one of them. This generally indicates an error detected within Electronic Speed Control driver of the motor. In your case, the problem is that m120x within the FW you updated to, claim there is an issue with a motor, even though the motor is fine. You need to replace m120x programming with a less buggy one, either older or newer.

Then you can get back to fixing your original issue, which was never related to the drone at all. You were fixing the wrong device.
@quaddamage Thank you for helping and explaining. I have two quick follow up questions to help me figure out how to proceed.

1. Does this mean anything from the log file "[0013354][11 01] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support"
2. Is there a guide to replace the m120x programming? Is this separate from doing the firmware update on the aircraft?

Thanks again for your time and help.
Does this mean anything from the log file "[0013354][11 01] v1.8.0.0 -> v2.0.0.33, firmware v1.8.0.0 not support"
Yes. This means you don't have m1101. See the O-Gs wiki for info on modules.

Is there a guide to replace the m120x programming?

Is this separate from doing the firmware update on the aircraft?
You can either update the single module (well, 4 modules in this case), or force update everything.
Single module is usually more safe, as long as you can extract it properly.
Everything (whole FW package from DJI) is easier, but there's a small chance of further issues.
Thanks for the help, I just want to give an update on where I’m at. I purchased a replacement GL300A controller, and was able to manually bind it to the drone, and was able to connect to the app on both my iPhone and A7 tablet, the drone hovered and landed, so I’m good to go and start learning the hobby.

I believe that the USB didn’t work on the original controller, updating the firmware on the drone (I know now I shouldn’t have) is what I think caused them to unbind and I couldn’t update the controller firmware with a bad USB port.

I think I’ve found enough information on this site to continue troubleshooting the usb board in the original controller although I don’t have a USB-TTL converter so I’ll have to order one.

Members online

No members online now.

Forum statistics

Latest member