P3 Pro Gimbal shows disconnected, yet responds to commands. No video

Joined
Jan 22, 2014
Messages
139
Reaction score
53
Location
P.E.I. Canada
Hey folks,

I have a phantom 3 professional that I have flown since 2017 or so. Has been a rock solid unit for me all these years. Did a shell replacement on it in 2019 due to stress cracks and has flown like a champ the whole time.

In 2022, around August or so, I bought a Phantom 4 from a friend, and "retired" my P3... I took the props off, batteries out and put it in storage in an old hard case I had.

Fast forward to yesterday. I thought it would be a good little drone for a buddy of mine who has a P3S who is constantly having connection and range issues with his unit.. I dragged it out of the closet, got everything charged up, and we went out for a flight.... Went and got everything connected up and ready to take off, and I am not getting any video from the drone.... The app shows connected, good to go, and the drone will fly with no problems, but the app shows "gimbal disconnected" in the status...

I can control the gimbal with the controller up and down, the gimbal rolls and pitchs like it should... I can do a gimbal calibration and it completes fine... The inserted memory card does not show up either.

I have not done a thing to this yet to troubleshoot.... Just wondering if anyone has any ideas before I crack it open..

Thanks in advance.
 
Try without the sd card. If that works, reformat the card or replace. Let us know so others can suggest ideas. It's usually something simple like sd card, relink, app, etc. I assume you're using GO not GO4 on P3P
 
Yeah, one of the first things I thought of... Pulled the card and nothing changes... Thanks tho! I am gonna pull it apart tonight and reseat the cables and such.
 
the app shows "gimbal disconnected" in the status...

What color is the light on the camera, I know that these units go bad if left unpowered for to long, usually resulting in loss of video feed.

I would suggest reflashing the main board if the light is flashing green if its any other color then the board is bad.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
What firmware is the drone? if latest Before I do anything I would downgrade firmware and see if it works, that worked for me when I didn't have video and ESC error fix as well. I know a lot of pilots don't like the idea because might fry the board but is recommended to use a fan while doing the procedure, I did it with a fan and my drone works just fine.
 
Thanks for the suggestions... I broke the camera and gimbal down right to the basics and put it all back together again and still no change.. I will have to check the firmware and try flashing again, once I am in the mood to tinker with it again..

Thanks again folks!
 

Members online

No members online now.

Forum statistics

Threads
143,194
Messages
1,468,392
Members
105,104
Latest member
easyhaildamage