Old firmware required (or do i?)

Joined
Apr 12, 2015
Messages
5
Reaction score
0
Age
64
Hi,

Just fitted a RP Gimble to PV2.

At the start i entered the assistant to make the adjustments to the pitch, this was the very first time i have attached the Phantom to the computer. i also did an update! (3.14) I think this is where i went wrong! its all bollocks now. Gps/battery indicators notworking and compass calibration hit and miss.

It also defaulted to Naza mode!

So my question is, can i revert back to a older version firmware?
 

Members online

Forum statistics

Threads
143,192
Messages
1,468,375
Members
105,103
Latest member
ZeroByter