GL300e Mapbox problem

Joined
Jan 1, 2020
Messages
37
Reaction score
11
Hello
I think a lot of GL300e controller owners might be having a problem downloading maps . I know I was. When I received my Phantom Pro + controller the map box feature would not download any maps at all. I followed all the internet advice and was considering tossing the controller for the standard one because I couldn’t get the mapbox to produce. Despite advice to the contrary, I contacted DJI customer service and was walked thru the correct procedure for updating the DJIGo4 App contained in the controller . It was a web site and password, different from the DJI Phantom site. Anyway, I downloaded the file there and put it on my Micro sd card then loaded it into the controller. It worked!!!! Don’t hesitate to contact support if you are having this problem.
Cheers!!
 
I can’t do it. You have to go to repair.DJI.com
. Submit repair request for the gl300e controller. They will suggest you go online to talk with a tech. Do it.
 
Hello
I think a lot of GL300e controller owners might be having a problem downloading maps . I know I was. When I received my Phantom Pro + controller the map box feature would not download any maps at all. I followed all the internet advice and was considering tossing the controller for the standard one because I couldn’t get the mapbox to produce. Despite advice to the contrary, I contacted DJI customer service and was walked thru the correct procedure for updating the DJIGo4 App contained in the controller . It was a web site and password, different from the DJI Phantom site. Anyway, I downloaded the file there and put it on my Micro sd card then loaded it into the controller. It worked!!!! Don’t hesitate to contact support if you are having this problem.
Cheers!!
I got a link from DJI support as well, downloaded the file put it on a micoSD and it got stuck at installing Go4 at the 10% level. The fix in the YouTube video did not work either.
 
my name is Donnie, I just sent my GL300E to DJI for repair of the charging board, and the sent me a replacement instead of fixing mine. the replacement works fine all but the Mapbox is blank. I have chatted with them online a few times, and on email +over the phone. they keep telling me to update my firmware which i have done many times. I have even tried to re install the Go4 app......still no maps in the mapbox. they even tried to tell me my network connection could be junk.. umm NO!! Yes i have tried older versions of firmware and GO4 app! Anyone think they can help out?
 
my name is Donnie, I just sent my GL300E to DJI for repair of the charging board, and the sent me a replacement instead of fixing mine. the replacement works fine all but the Mapbox is blank. I have chatted with them online a few times, and on email +over the phone. they keep telling me to update my firmware which i have done many times. I have even tried to re install the Go4 app......still no maps in the mapbox. they even tried to tell me my network connection could be junk.. umm NO!! Yes i have tried older versions of firmware and GO4 app! Anyone think they can help out?

My same problem exactly. Sent my Tx in because of a charging problem. On this one the maps worked, DJI sent a replacement but the maps did not work. Lots of firmware hocus pokus nothing worked.
I was sent a link to a file called "update.zip" which I was to run directly from the micoSD card. Sadly this file hung while installing Go4. I am at the point where I will send the Tx back to DJI and demand they return one with working maps.
 
  • Like
Reactions: scorp765
My same problem exactly. Sent my Tx in because of a charging problem. On this one the maps worked, DJI sent a replacement but the maps did not work. Lots of firmware hocus pokus nothing worked.
I was sent a link to a file called "update.zip" which I was to run directly from the micoSD card. Sadly this file hung while installing Go4. I am at the point where I will send the Tx back to DJI and demand they return one with working maps.
Yep.. DJI just gives us the run-around, no solution. I honestly think they have no clue what they are doing in the support section. My Tx did the same thing with the hang up glitch the first time i tried the firmware zip file. This is a known common problem they should be able to fix it easy. We spent way to much $ on these things... they need to work perfectly.
 
I finally got a fix from DJI after 3+ weeks of emails and 2 replacement controllers. But the fix for the mapbox problem is an update that is on their cloud not on the website.
 
I finally got a fix from DJI after 3+ weeks of emails and 2 replacement controllers. But the fix for the mapbox problem is an update that is on their cloud not on the website.
Did they give you a link to a file named "update.zip"? I downloaded this file a while back but it failed during the installation of Go4.
 
Did they give you a link to a file named "update.zip"? I downloaded this file a while back but it failed during the installation of Go4.
yes they did! it took a little while to download and then install, but it worked great. now they want me to update to the latest go4 app but every time and way they said to do so DONT WORK! It says installing for a bit, then "app not installed"
 
yes they did! it took a little while to download and then install, but it worked great. now they want me to update to the latest go4 app but every time and way they said to do so DONT WORK! It says installing for a bit, then "app not installed"
For me the update.zip file had to be the only thing on the sd card for it to work properly. insert the disk to controller with it powered off then turn power on. it auto detected it, i clicked install and just under 5 minutes it was done and successful.
 
For me the update.zip file had to be the only thing on the sd card for it to work properly. insert the disk to controller with it powered off then turn power on. it auto detected it, i clicked install and just under 5 minutes it was done and successful.
My thought is that the "update.zip" file would have installed the latest version of Go4.
 
For me the update.zip file had to be the only thing on the sd card for it to work properly. insert the disk to controller with it powered off then turn power on. it auto detected it, i clicked install and just under 5 minutes it was done and successful.
I recieved the Zip file from a Tech, put it on a SD Card and did everything as provider in the Guide, but it will not detect it. I also copied it to the internal storage Folder, but nothing happens. What should i do?
 
For me the update.zip file had to be the only thing on the sd card for it to work properly. insert the disk to controller with it powered off then turn power on. it auto detected it, i clicked install and just under 5 minutes it was done and successful.
Thanks for your help!! Do you know where to find the download? Maybe the link? Thanks I've been at this for weeks.
 
Hello, I have also searched for 2 days to solve the problem. Finally I found a link, downloaded and extract it on the USB -Stick and when I put the stick instead the controller it starts automatic to install. In my case, the mapbox is working perfect.
If you want the files, please ask and I shall send it by wetransfer. The file is too big to share inside this forum.
 
Hello, I have also searched for 2 days to solve the problem. Finally I found a link, downloaded and extract it on the USB -Stick and when I put the stick instead the controller it starts automatic to install. In my case, the mapbox is working perfect.
If you want the files, please ask and I shall send it by wetransfer. The file is too big to share inside this forum.
It is very kind of you to share the file, what would be the process?
 

Members online

Forum statistics

Threads
143,018
Messages
1,466,996
Members
104,896
Latest member
Sarika539