Standard Gimbal shake

Joined
Apr 22, 2017
Messages
22
Reaction score
0
Age
42
some help out here, i recently crashed p3s. I broke the camera arm, tore the camera ribbon. I replaced all the parts and after putting it back together and flying it it now has this shake in the camera. Could anyone help me out on this please
 
Joined
May 1, 2016
Messages
78
Reaction score
26
I
Did you crqsh yours as well?
I did unfortunately, bird just fell out of the sky when I was flying it in the park. Didn't see if it hit a bird so I don't have a clue how it happened. I fixed it up and now the gimbal starts vibrating.
 
Joined
Apr 22, 2017
Messages
22
Reaction score
0
Age
42
What all things have you check thus far so i can help you rule out some things.
 
Joined
Apr 22, 2017
Messages
22
Reaction score
0
Age
42
Private messege me if you can or will, that way we can exchange some info to make it easier and faster to communicate.
 
Joined
Apr 19, 2017
Messages
32
Reaction score
8
Age
49
Any progress on this one, I am in the same boat, seems to be a common issue after a crash. Everything looks good but video shakes.
 
Joined
May 1, 2016
Messages
78
Reaction score
26
Any progress on this one, I am in the same boat, seems to be a common issue after a crash. Everything looks good but video shakes.
Make sure all the arms aren't bent. You might also want to open up the covers so you can see the back of the motor arms and check to see if they're still correctly aligned with the camera.
 
Joined
Jun 4, 2017
Messages
1
Reaction score
0
Age
37
Anyone been able to fix this yet? I've come across the exact same issue. No crash, but gimbal vibrates when in the air. I've got no loose screws and everything looks in great condition. Any help would be greatly appreciated.
 
Joined
Dec 31, 2016
Messages
105
Reaction score
22
Age
58
Location
Allentown, PA. USA
How many grommets are you using on the gimbal Assy. It's recommended to only use 2. The vibration seems to have a definite pulse pattern to it,almost like it coincides an internal function of the phantom's.
 
Joined
Apr 19, 2017
Messages
32
Reaction score
8
Age
49
At this point I disassembled and reassembled gimball/camera several times and checked for everything. Everything looks like new with not a scratch on it. Cable is perfect, all gimbal motors appear fine, nothing is bent. I checked the camera alignment and it is perfect as well. Yaw screw is nice and tight and aligned correctly. I also opened up the body and verified that there are no cracks or anything wrong with it visually either. All prop motors work nice and smooth. Tried new set of props and balanced them as well. Tried using loose zip ties instead of pins on the gimbal. Nothing helps, same periodic jello/vibration in the video. At this point I am leaning towards some electrical issue... not mechanical... since I can't think of anything else. About to give up on this thing which is too bad since other then that video shake it is flawless with awesome range (upgraded controller and bird view antennas).
 

Recent Posts

Members online

Forum statistics

Threads
142,357
Messages
1,461,844
Members
104,162
Latest member
Boufou