Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
Hey Guys!

I'm new to the phantom family, after seeing the announcement of the P4P+ I was finally sold. I did get to use a P3 last year, the owners were beginners (I have quite some past RC-FPV experience from almost 10 years ago) so they let me take control, since I am a professional Photographer and the P3 came in handy coincidentally for an assignment. I was mega impressed by the rock-solid video-link and ease of use of the whole system.

Well unfortunately, my P4P+ is not that rock solid at all. I have frequent video-glitches (artifacts and lag) independent of distance (2m, 200m or 500m does not make a difference, did not take it any further) or environment. My home has about 5 wifis within 500m which I do not consider very heavy, the spectrum analyzer is not reporting any problems and is looking rather calm, absolutely no spikes on any channel. Today I flew in an environment where there was no wifi for at least 1km. I also tried setting my phone to flight-mode but no change. Antennas are aligned properly (I have lots of xp with antennas from my early fpv time, I would be surprised if this was a factor).
It is not so bad that I cannot fly at all, but if I fly near something I just stop whenever the glitches come and then try again, which is not very practical.

Basically, I have the feeling that this is not how it's supposed to be and it is certainly not as advertised and everything else but rock-solid. Is anybody else having similar problems or have an idea what I can try to improve it?

Thank you!
 
Joined
May 26, 2014
Messages
50
Reaction score
23
Hi,
I was having the exact same issues as you describe. One solution I found worked for me was if the p4p video was glitching I would land and reboot. This would more often than not allow for a trouble free flight. I've no idea why this would be but it worked for me. 5.8 was rubbish so I was always on 2.4. I'm in UK so CE power. On my last flight video and control was lost completely and DJI are sending me a new controller and I'm hoping this will fix all issues.
 
Joined
Nov 26, 2016
Messages
181
Reaction score
57
Age
48
Hey Guys!

I'm new to the phantom family, after seeing the announcement of the P4P+ I was finally sold. I did get to use a P3 last year, the owners were beginners (I have quite some past RC-FPV experience from almost 10 years ago) so they let me take control, since I am a professional Photographer and the P3 came in handy coincidentally for an assignment. I was mega impressed by the rock-solid video-link and ease of use of the whole system.

Well unfortunately, my P4P+ is not that rock solid at all. I have frequent video-glitches (artifacts and lag) independent of distance (2m, 200m or 500m does not make a difference, did not take it any further) or environment. My home has about 5 wifis within 500m which I do not consider very heavy, the spectrum analyzer is not reporting any problems and is looking rather calm, absolutely no spikes on any channel. Today I flew in an environment where there was no wifi for at least 1km. I also tried setting my phone to flight-mode but no change. Antennas are aligned properly (I have lots of xp with antennas from my early fpv time, I would be surprised if this was a factor).
It is not so bad that I cannot fly at all, but if I fly near something I just stop whenever the glitches come and then try again, which is not very practical.

Basically, I have the feeling that this is not how it's supposed to be and it is certainly not as advertised and everything else but rock-solid. Is anybody else having similar problems or have an idea what I can try to improve it?

Thank you!
I had this problem with the Samsung tab 3 my ASUS and Samsung tab a. Was advised the iPad 4 mini is a dream... I bit the bullet and never glitches once. On the contrary I hate Apple but I use it just for flights.

Sent from my P00A using PhantomPilots mobile app
 
Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
As stated in the first line of my post, I use a P4P+ with the buildt in display ... no extra device that I could exchange.
 
Joined
Dec 27, 2016
Messages
120
Reaction score
30
Age
33
Location
Texas
As stated in the first line of my post, I use a P4P+ with the buildt in display ... no extra device that I could exchange.
Sorry about that. Was trying to get one of the little ones asleep while trying to read and respond. My fault.

Only thing I can think of is there is some sort of interference around you. Doesn't have to be wifi signals. Before your flight, go into the frequency settings and select 5.8, and 2.4, and look at each one to see which is the cleanest.
 
Joined
Dec 2, 2016
Messages
102
Reaction score
46
Age
37
In my P4P, when I put the last firmware, I have glitches, freezing of live view when start to record, and app closes suddenly, but glitches are a real problem to me using a Nexus 6P with Android 7.1.1.

Solution? Borrow the iPhone 6S to my wife. I hate Apple, but with iOS I don't have glitches, hang ups, errors, NOTHING! Works PERFECT.

Sell P4P+ and buy a P4P with an iPad Air. Sad but true. DJI have too many problems with the software GO for Android, and your P4P+ it's the same...

Enviado desde mi Nexus 6P mediante Tapatalk
 
Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
Yes did that, forgot to add in initial post. Same issue independent of 2.4 or 5.8, channel set to auto.
 
Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
I would say there's no difference between the two. I can try to take a photo of the frequency selection screen, if thats what you're asking? I could post a video if I only found a way to download the video cache from the remote :confused:
 
Joined
Jun 17, 2015
Messages
56
Reaction score
23
Age
38
I would say there's no difference between the two. I can try to take a photo of the frequency selection screen, if thats what you're asking? I could post a video if I only found a way to download the video cache from the remote :confused:
I had the same live-feed issues... sent the P4P+ back for a regular P4P, no more glitches. I did a bunch of searching for solutions or noting of the problem, there's been quite a few people that had the same thing w/ the + version. Maybe the next firmware will fix it, maybe it's a symptom of the built-in screen setup, but it was definitely un-flyable.
 
Joined
Dec 27, 2016
Messages
120
Reaction score
30
Age
33
Location
Texas
I would say there's no difference between the two. I can try to take a photo of the frequency selection screen, if thats what you're asking? I could post a video if I only found a way to download the video cache from the remote :confused:
Are you able to connect it to your pc and transfer the files via usb?
 
Joined
Jan 8, 2017
Messages
425
Reaction score
141
Age
36
In my P4P, when I put the last firmware, I have glitches, freezing of live view when start to record, and app closes suddenly, but glitches are a real problem to me using a Nexus 6P with Android 7.1.1.

Solution? Borrow the iPhone 6S to my wife. I hate Apple, but with iOS I don't have glitches, hang ups, errors, NOTHING! Works PERFECT.

Sell P4P+ and buy a P4P with an iPad Air. Sad but true. DJI have too many problems with the software GO for Android, and your P4P+ it's the same...

Enviado desde mi Nexus 6P mediante Tapatalk
I think its so weird because i have a note 5 and it performs excellent. I had a nexus 6 p before the note 5 when i flew my phantom 4 i noticed that when i went to 7.1 nougat i had major problems. Flashed back to marshmallow 6.0.1 and it worked great. So i think the go app conflicts with 7.1.1 or nougat in general. Remember its a new os and apps still need updating from playstore to work correctly. Also helped a friend with same problem on his nexus and now he is good. Sucks u have to even go backwards as far as os but it worked! Also note that my note 5 is on 6.0.1 and so is the + version on the new remote.....
 
Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
Are you able to connect it to your pc and transfer the files via usb?

The remote does not mount on my mac, cannot access anything. Should it work on a pc?


So basically you guys say, the glitches are because the plus-remote is running android and the software is broken?
 
Joined
Dec 27, 2016
Messages
120
Reaction score
30
Age
33
Location
Texas
The remote does not mount on my mac, cannot access anything. Should it work on a pc?


So basically you guys say, the glitches are because the plus-remote is running android and the software is broken?
I don't have the plus version so I'm not sure how that's works. Maybe as sd card transfer?

I wouldn't say the android software is broken, as I use an android tablet with no problems. I did have this problem when I used to have my mavic, and used my older note 4 to fly and record in HD. When I upgraded to a faster nvidia k1, the problems went away. We might have to have other users with the plus version chime in. Have you contacted dji at all about this? Last thing you could do is calibrate everything. Imu, sensors, compass, etc.
 
Joined
Jan 22, 2017
Messages
13
Reaction score
0
Age
36
I have just tried two flights with 1080p and there was no single glitch and great range. Seems to be a problem only related to 4K recording on the P4P+ ...
 
Joined
Jan 2, 2017
Messages
25
Reaction score
9
Age
35
I don't have the plus version so I'm not sure how that's works. Maybe as sd card transfer?

I wouldn't say the android software is broken, as I use an android tablet with no problems. I did have this problem when I used to have my mavic, and used my older note 4 to fly and record in HD. When I upgraded to a faster nvidia k1, the problems went away. We might have to have other users with the plus version chime in. Have you contacted dji at all about this? Last thing you could do is calibrate everything. Imu, sensors, compass, etc.

almost all + users have this problem, including me. I had 2 + birds that had this problem, my friend has this problem and there's a whole topic on the DJI forums about it with other people that are having the same issue. VERY annoying.

edit: here's the topic:
P4pro+ with laggy freezing live view
 
Joined
Dec 27, 2016
Messages
120
Reaction score
30
Age
33
Location
Texas
almost all + users have this problem, including me. I had 2 + birds that had this problem, my friend has this problem and there's a whole topic on the DJI forums about it with other people that are having the same issue. VERY annoying.
Thanks for the update... Glad I got the P4P.
 
Joined
Jan 12, 2015
Messages
79
Reaction score
38
Location
UK
I purchased my P4P+ from Heliguy and noticed the video feed problem on my first flight when the signal was breaking up at about 10 metres away. I tried it again a couple of days later at another location and the same problem occured. I sent it back to Heliguy and they have sent it to DJI Netherlands for repair. I also have a problem with the gimbal, which, after power on, stops with the camera facing backwards.
Not very happy with my purchase, so far.
 
Joined
Jan 16, 2016
Messages
25
Reaction score
3
Age
44
same problems with p4p and ipad mini 2.
I get video glitches with artifacts especially while using intelligent flight modes (spotlight, tracking etc...) also recording in 1080p
Things seems to get better reducing the streaming bandwith from 10 to 6 mbps (see HD options/custom)
I suppose it's a software problem inside the DJIGO 4 App. I've tried litchi and the streaming is smoother
 

New Threads

Forum statistics

Threads
139,736
Messages
1,441,406
Members
101,478
Latest member
ELEVATEDPHOTOS