Downgrading firmware on P3P from 1.10.9 to 1.7.6

Joined
Jan 6, 2016
Messages
403
Reaction score
91
Age
51
Hello to everyone. I'm a french new owner of a second hand Phantom 3 Pro, which is my first "real drone".
Having a ESC problem, which have been temporarilly solved by the 1.11.30 DJI FW, but reappeared a few flights later, I'm assuming that this error is a software problem, so I hope downgrading my drone could solve it !

Thanks to this post, I was able to succesfully downgrade to 1.07.0060. Thank you Airbender !!!
View attachment 98953
But as you could notice, I have a Aircraft Firmware Inconsistent message. Does anybody know what it means ?
View attachment 98954
Maybe it's because I'm still using too much recent version of DJI Go ? I have downloaded a patched 2.4.2 version but still hadn't time to test it.

Other thing: it's impossible for me to downgrade my RC. I tried many times the graduation cap method, but it never worked... Always had a fail message...

I'm a bit confused with the very first post in this forum:

Manual Method
(Found on RC Firmware config · Issue #10 · mefistotelis/phantom-firmware-tools · GitHub by aka1ceman)
  1. Turn on RC, Plug in Tablet, start DJI Go (I used 2.4.2)
  2. Touch and hold top right corner of screen for 5-10 seconds. (tutorial button thanks to Inspire guys)
  3. New screen opens offering to downgrade RC. (I was offered 1.6 and 1.5.8)
  4. Download but do not install.
  5. Using file explorer replace and rename file
  6. I used RC file for 1.3.2 and renamed, and replaced the existing 1.5 file.
  7. Go back to DJI Go app and finish install. It will finish installing. It did install for me although renaming may not be the safest way. Hope this helps.
I don't understand the 6th step. Would someone please explain to me a different way.

Thank you to everyone who could help me !

EDIT: with the patched dji go 2.4.2, the rc upgrade seems to work !

EDIT N°2: unfortunately my ESC Status problem was not solved by downgrading :-(
We downloaded the 1.3.2 firmware for the RC and renamed it 1.5 to make the app think it was installing 1.5
 
Joined
Jun 22, 2018
Messages
3
Reaction score
0
Age
50
Hello friends.
I went to lower and lower firmware (P3P) but after uploading 1.7 of 1.8 there are problems. Gimbal does not react, the message about the problem with the firmware makes it impossible to do anything. I had to go back to 1.8. Some solution ? Regards
 
Joined
Feb 3, 2016
Messages
393
Reaction score
199
Location
Slovakia/Kosice
Hello friends.
I went to lower and lower firmware (P3P) but after uploading 1.7 of 1.8 there are problems. Gimbal does not react, the message about the problem with the firmware makes it impossible to do anything. I had to go back to 1.8. Some solution ? Regards
and do you have gimbal problems with FW 1.8?
if not, why do you want to downgrade?
 
Joined
Feb 3, 2016
Messages
393
Reaction score
199
Location
Slovakia/Kosice
And why everyone here wants to lower the version to 1.7 ? ;) (There is no problem in version 1.8) Regards
this thread is quite old and some of the information is not true anymore
if you want to mod the flight parameters of your AC, there is no need to downgrade
for a few months now with dji-firmware-tools you can modify any Phantom's FW
 
Joined
Jun 30, 2016
Messages
1,317
Reaction score
564
Location
PL
Joined
Jun 30, 2016
Messages
1,317
Reaction score
564
Location
PL
Will I find help to turn off the altitude limit in the easiest way in DJi Phantom 3 Professional ?

This thread is about downgrading.

Also, figuring out the software by yourself is more educational.
You need to extract firmware, edit flyc_param_infos and update them within flight controller module. Then flash that to your drone.
Try searching for retroroms dji wiki for details. Also there's nolimitdronez which lets you pay for having such things done automatically.

I won't mind if the thread will be cleaned of these unrelated posts.
 
Joined
Jun 22, 2018
Messages
3
Reaction score
0
Age
50
This thread is about downgrading.

Also, figuring out the software by yourself is more educational.
You need to extract firmware, edit flyc_param_infos and update them within flight controller module. Then flash that to your drone.
Try searching for retroroms dji wiki for details. Also there's nolimitdronez which lets you pay for having such things done automatically.

I won't mind if the thread will be cleaned of these unrelated posts.
Thank you for the information. Regards
 
Joined
Aug 2, 2018
Messages
2
Reaction score
1
Age
40
I can't stand the fact of dji crippling 'my property' even more with every supposed 'better/newer firmware', and while nothing wrong with my AC nor RC, I had a new droid device and couldn't immediately find my saved copy of the older app so installed the new. OF COURSE then, and only after then, the newer app gave me the new firmware required message. I refused to do it, BUT, afterwards trying to fly without updating, I was getting ESC error and couldn't power up the motors app or not. After reading this Entire Thread First, I got my drone back to Great and Even Better!

Even after all of this time, and even though there's also now the newer(cool way to do to, but not for any lamers that can't/don't want to study/read whole threads and directions) of downgrading the firmware's, I'd like to shout out a Super Kudos to the original poster of this thread for his method does indeed still work just fine as I downgraded to 1.7 easily, as well, like he, I hit the bump in from 1.8 to 1.7, though flashed 1.8 back and again 1.7 and Whalla! Success! Later this week, I will edit a flyc_param_infos, re-pack/compile it to the .bin, flash and test my pro out again this weekend with my 8 batteries. Thanks again to the original poster and others of whom led me to find the answers! :)
 
  • Like
Reactions: spectra9
Joined
Jan 16, 2017
Messages
64
Reaction score
14
Curious about " the newer(cool way to do to, but not for any lamers that can't/don't want to study/read whole threads and directions) " . Got link?
 
  • Like
Reactions: CyberMaster
Joined
Aug 2, 2018
Messages
2
Reaction score
1
Age
40
Curious about " the newer(cool way to do to, but not for any lamers that can't/don't want to study/read whole threads and directions) " . Got link?

What I mention is very similar, Newer because a lot of it is recently Updated(files) And, COOL because also allows learning of personally modifying parameters directly to the firmware and then popping in the bin on the SD card and flashing.

It's first mentioned about on Page 1 of this thread by the original author, phantom-firmware-tools github project page. There is also another page by maybe the same author of the project link?, that lists his actual downgrade of FW steps, and then explains the phantom-firmware git page files and steps to modify some things(a LOT of things), at http://dji.retroroms.info/howto/modp3params. ''I didn't use the later to do my downgrades'', I used page 1 on this forum, RC v1.5, AC 1.7.
 
Joined
Jan 11, 2018
Messages
36
Reaction score
0
Age
56
I believe what ultimately fixed it for you wasn't the modules but the fact you let it update through all that loud beeping and didn't care about the possible overheating issue...I had the same issue once when i interrupted an update and the next time i tried to update i got the crazy loud ESC beeping continuously for maybe a 30min while in the background i could hear the very faint d-d-d which made me let it keep going...It was one of the most painful things i had to listen to and I wanted to stab my eardrums with an ice pick..So hats off to you for enduring this and being patient and happy to see your flying again bud!
hi have the same problem constant beep at the end let it go for a half hour longer still constant beep gave up
 
Joined
Aug 25, 2017
Messages
15
Reaction score
0
Age
41
Hey, I've been chatting to Steve via email but still cant solve my issue. He has provided me with the modded PMCAPPFw3.bin file but the hight restrictions didnt work on 1.11 fw. So, we're trying to downgrade to 1.10 fw. Sounds simple... right. Nah... two days later, still can't get it to work. I put a debug file on the sd with 1.10 and it went through the process for 25 min then the card says 'upgrading...' however the app says 1.10.90.

Hight still locked. Any ideas!? Thanks! Its a P3P btw.
 
Joined
Aug 25, 2017
Messages
15
Reaction score
0
Age
41
Last week I rolled back successfully on my P3A from P3S_FW_V01.11.0020 to P3S_FW_V01.10.0090 with DEBUG file method. After downgrade all lights were red. So I turned it off/on and bird did the same SW update once again. After that it was O.K.
Hey, did the log pass/fail text file say 'upgrading...' after you did this or did it say 'sucessfull'?
 

New Threads

Members online

Forum statistics

Threads
140,061
Messages
1,444,515
Members
101,828
Latest member
Chawkins91