Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard DJI Go app Will not open on Samsung Galaxy Tab 3

Discussion in 'Phantom 3 Help' started by Austyn94, Oct 4, 2016.

  1. Austyn94

    Oct 4, 2016
    Likes Received:
    I recently purchased the P3 standard, and I own a Samsung Galaxy Tab 3 Wifi 7" (sm-t210r) that is running the latest available operating system for this device (4.4.2). I downloaded the DJI go app and it wouldn't open. It pulls up a black screen, then crashes and says "Unfortunately, DJI GO has stopped". From there, I deleted the app and tried to reinstall it but kept having the same issue. After that, I uninstalled the app and tried to side load it but still had the exact same problem. From there, i tried the last thing i could think of, and factory restored the device and tried all previous avenues again with the same exact result. Is there anyone who has experienced this or know away around this problem? Its getting really frustrating.
    #1 Austyn94, Oct 4, 2016
    Last edited: Oct 4, 2016
  2. RodPad

    May 20, 2015
    Likes Received:
    Pacific,NorthWet, 97031

    Welcome to the Forum!
    How about the first one?
    Standard - Phantom standard

Similar Threads - DJI app open Forum Date
A participative open source app for DJI SDK, what do you think ? General Discussion Apr 3, 2016
Professional DJI GO APP iOS Version v2.4.2 Crashes on opening Phantom 3 Help Dec 3, 2015
Android DJI GO4 App froze Control (Go, Litchi, etc..) Friday at 1:56 PM
Do DJI Goggles lag like the GO App? DJI Goggles Friday at 8:40 AM
Professional DJI Go App will not go to Camera Mode Phantom 3 Help Thursday at 1:51 PM