Display flashes green and blackout

Joined
May 8, 2017
Messages
11
Reaction score
2
My brand new Phantom 4 Pro from out-of-the-box is having a problem as recorded in the videos below.

The display of iPad/iPhone flash green and blackout 1/2-3/4 of the screen. It could happen 10 seconds to 5 minutes continuously varying from each flights. I also notice the extra heat of iPad/iPhone.

It happens on several different locations. It happens to four devices (iPad Air, 2 x iPhones 6, and iPad Mini 4 – all with latest iOS). It happens both during recording video (4K or 1080p) and not recording, even when the aircraft landed.

I did recalibrated IMU, relinked the radio, changed several cables. The problem still persists.

What is the cause? How to solve?

Many thanks.


 
Joined
Nov 27, 2016
Messages
63
Reaction score
18
Age
46
Location
Añasco
The same thing with 10.3.1 iOS on my iPad Mini 4.
I upgrade to 10.3.2 Beta and so far it has not happened to me again.
I flyed twice and it has not happened to me again. I will continue to do flight tests
Sorry for my english but my primary is spanish.
 
Joined
Mar 29, 2016
Messages
1,724
Reaction score
502
Age
57
Did you try 5.8Ghz band? Do you have your antenna's out and perpendicular to your bird? So if bird was directly overhead or close to then you would point your antennas straight out parallel with ground. But normal flying is to have antenna pointed up some and turn your direction toward your bird. So again the antenna's are perpendicular to your bird. It is normal for the Ipad's to get pretty warm after 15-25 min flights. Especially in the summer time. This may not be it at all. Just throwing some stuff at ya.
 
Joined
May 8, 2017
Messages
11
Reaction score
2
The same thing with 10.3.1 iOS on my iPad Mini 4.
I upgrade to 10.3.2 Beta and so far it has not happened to me again.
I flyed twice and it has not happened to me again. I will continue to do flight tests
Sorry for my english but my primary is spanish.
This is interesting. I will update to the latest beta OS and try again, in a few days. Thank you.
 
Joined
May 8, 2017
Messages
11
Reaction score
2
Did you try 5.8Ghz band? Do you have your antenna's out and perpendicular to your bird? So if bird was directly overhead or close to then you would point your antennas straight out parallel with ground. But normal flying is to have antenna pointed up some and turn your direction toward your bird. So again the antenna's are perpendicular to your bird. It is normal for the Ipad's to get pretty warm after 15-25 min flights. Especially in the summer time. This may not be it at all. Just throwing some stuff at ya.
I have tried both 2.4 and 5.8 GHz. I also face the antennas to the direct way.

Yesterday I tried again in the evening after sunset, the problem doesn't occur. I guess it's because of the less heat. But my normal shooting time is actually around noon when the sea water looks clearest.
 
  • Like
Reactions: sshephard
Joined
Nov 27, 2016
Messages
63
Reaction score
18
Age
46
Location
Añasco
My iPad Mini4 with 10.3.2 Beta is working perfect...i already use my Phatom 4 Pro two time and work nice.
 
Joined
Aug 15, 2016
Messages
1,424
Reaction score
296
This happened to me to. I asked DJI about it on their forum, and someone recommended turning off the video cache. This happens out of the blue every now and then for some reason. I already switched out my hdmi module, and I still get this here and there.... I guess the best thing is to land it, restart it, and then re plug everything.
 
Joined
May 8, 2017
Messages
11
Reaction score
2
This happened to me to. I asked DJI about it on their forum, and someone recommended turning off the video cache. This happens out of the blue every now and then for some reason. I already switched out my hdmi module, and I still get this here and there.... I guess the best thing is to land it, restart it, and then re plug everything.
Thank you. I've also tried turning off the cache, but it doesn't help.
 
Joined
May 8, 2017
Messages
11
Reaction score
2
I finally solved the green/black screen problem with the following settings…

DJI GO App
• Image Transmission : Custom, 5.8 GHz, low mbps (4-6 mbps)
• Video Cache : off

I also updated my iPad to iOS 10.3.2 Beta.

All of the above settings are to reduce processor load on my old iPad Air, but I'm still not sure which part of those settings actually solve the problem.

My iPad is still hot while flying, I also tried using it under direct sunlight, but there is no green/black screen problem again.

Knock on wood.
 
  • Like
Reactions: photoskyview
Joined
May 8, 2017
Messages
11
Reaction score
2
I also signed out from the DJI account in DJI GO app, as someone has suggested.
 
Joined
Nov 27, 2016
Messages
63
Reaction score
18
Age
46
Location
Añasco
I finally solved the green/black screen problem with the following settings…

DJI GO App
• Image Transmission : Custom, 5.8 GHz, low mbps (4-6 mbps)
• Video Cache : off

I also updated my iPad to iOS 10.3.2 Beta.

All of the above settings are to reduce processor load on my old iPad Air, but I'm still not sure which part of those settings actually solve the problem.

My iPad is still hot while flying, I also tried using it under direct sunlight, but there is no green/black screen problem again.

Knock on wood.
One test fly with your settings and everything perfect... Thank...
 
Joined
Nov 27, 2016
Messages
63
Reaction score
18
Age
46
Location
Añasco
I finally solved the green/black screen problem with the following settings…

DJI GO App
• Image Transmission : Custom, 5.8 GHz, low mbps (4-6 mbps)
• Video Cache : off

I also updated my iPad to iOS 10.3.2 Beta.

All of the above settings are to reduce processor load on my old iPad Air, but I'm still not sure which part of those settings actually solve the problem.

My iPad is still hot while flying, I also tried using it under direct sunlight, but there is no green/black screen problem again.

Knock on wood.

Second flight with this settings and no problems with my iPad Mini4
 

New Threads

Members online

Forum statistics

Threads
136,117
Messages
1,407,761
Members
99,048
Latest member
atariguy2