Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Assistant Software not recognizing P2

Discussion in 'Phantom 2 Discussion' started by foursymbols, Jan 19, 2014.

  1. foursymbols

    Jan 19, 2014
    Likes Received:
    I just downloaded the Assistant Software for Mac (v1.08) and when I plug in the Phantom 2 I get the error message:

    "Please connect the controller"

    When I then tried to plug in the controller I get the same message.

    I've used the cord provided by DJI as well as two additional cords for phones/chargers and that didn't work either.

    Any idea why the quadcopter is not being recognized by the software?

    Also worth noting, I tried installing an FPV system to the quadcopter and in doing so I wired it incorrectly, and I heard a small pop in coming from inside the quadcopter. I realized a fried a component of the board. The quadcopter would still fly no problem, but the FPV didn't work.

    I ordered a new central board and replaced it. Now the FPV is working, but when I power up the P2 it seems to be going into some sort of failsafe mode. The P2 knows the controller is there, because when I switch the button 10 times the P2 goes into calibrating modes (from yellow blinking lights to yellow static lights). However, when I turn the two sticks inward to props do not turn on, the lights flash red very quickly and then go back into yellow blinking mode.

    Any help would be greatly appreciated.
  2. ironbinder

    Dec 15, 2013
    Likes Received:
    I have been having the same problem. One thing is with the Mac assistant software, you must be online (connected with the internet) when you are updating.
    You also must be using the proper cord that came with the PH2. The one with the USB mini.
    Mine would not take the update unless I hooked everything up, the Zenmuse Gimbal and with the Hero attached.
    If you did not originally have that , then , no problem.

    I did, so that is the way it has to be rebooted.
  3. freyjoel

    Dec 24, 2013
    Likes Received:
    Did you do the driver download also? I went through the same thing until I realized you have to do the driver download also.
  4. PetePerrim

    Jan 18, 2014
    Likes Received:
    Christchurch, New Zealand
    A small 'pop' coming from the innards of any electronic gear is usually serious and with something as technical as a Phantom, it could have affected it in more ways than one. My QRX350 made a small 'pop, sizzle sizzle' after reconnecting the battery when I had rebuilt it which was the death knell of the thing. There was no way I was going to continue to pour more money into something than tried to get to China every time it lifted off the ground and my faith in it was totally gone.

    Good luck with getting your problem sorted out. Wouldn't it be great if DJI had an online diagnostic service that could run a series of tests on the various systems in the Phantoms and either recalibrate them live or send the user a report of faults that were found and solutions for them?
Similar Threads - Assistant Software recognizing Forum Date
Software Assistant Not Recognizing Phantom Vision Phantom 2 Vision Help Dec 4, 2014
Mac Assistant Software Not Recognizing Phantom Phantom 2 Vision + Discussion Aug 15, 2014
Phantom assistant software Standard Nov 25, 2017
DJI Assistant software - does it work with the Phantom 3 Pro Pro/Adv Discussion Oct 2, 2017
Problem connecting to 3.8 vision assistant software on computer Phantom 2 Vision + Help Sep 3, 2017