Anyone got a copy of DJI Go 2.7.1?

Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
My P3P is bricked running iOS 9.3.1 and DJI Go 2.7.2.

All worked prior to an auto app update to 2.7.2. Have tried a full restore, but the iCloud backup seems to be an iOS 9.3.1 install. Additionally, when you restore, it fails to install a previous version of the DJI Go app and goes off to install the latest version (due to Apple's App thining process).

If anyone has an iTunes backup with DJI Go 2.7.1 in their Apps folder, could you let me know so I can try that.

Cheers.
 

alokbhargava

Premium Pilot
Joined
Sep 28, 2015
Messages
6,943
Reaction score
2,322
Location
San Francisco, CA
I'm sure App 2.7.2 can't brick your bird. Check if you are able to start / stop motors, move gimbal up down even without starting Go App.

Your problem lies somewhere else. Let us know what FW versions you have installed on RC and AC. Thanks.
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
I'm sure App 2.7.2 can't brick your bird. Check if you are able to start / stop motors, move gimbal up down even without starting Go App.

Your problem lies somewhere else. Let us know what FW versions you have installed on RC and AC. Thanks.
Well it has in terms of not being able to use the app. Yes, remote functions work, start / stop motors, tilt gimbal, etc. But useless without the app.

The problem is documented elsewhere, i.e, others are having issues. Started with 2.7.2.

Firmware: 1.4.0010. Worked flawlessly prior.
 

LuvMyTJ

Admin
Staff Member
Premium Pilot
Joined
Feb 9, 2014
Messages
9,274
Reaction score
5,557
Location
Live! From New York!
You cannot instal an iOS app on any other device other than the original one it was installed on. Basically you can't share apps.
Have you checked iTunes for the saved app? I alway make a copy of each one and save it for just such an occasion.
 

alokbhargava

Premium Pilot
Joined
Sep 28, 2015
Messages
6,943
Reaction score
2,322
Location
San Francisco, CA
Well it has in terms of being able to use the app. Yes, remote functions work, start / stop motors, tilt gimbal, etc. But useless without the app.

The problem is documented elsewhere, i.e, others are having issues. Started with 2.7.2.

Firmware: 1.4.0010. Worked flawlessly prior.
Many have reported good feedback about 2.7.2. So I believe it's not a bad release.

Probably some one on the forum can help you if you list your problems.

If you are trying to downgrade your App from 2.7.2 to 2.7.1, I doubt any one can help you in that as you are now in the clutches of Apple. You can only revert back if you locate a backup of that App for your mobile.
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
You cannot instal an iOS app on any other device other than the original one it was installed on. Basically you can't share apps.
Have you checked your computer for the saved app? I alway make a copy of each one and save it for just such an occasion.
Good point, completely forgot about app / device signing. Checked my Mac, can't find any DJI Go .ipa files for either my iPhone or iPad.
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
Many have reported good feedback about 2.7.2. So I believe it's not a bad release.

Probably some one on the forum can help you if you list your problems.

If you are trying to downgrade your App from 2.7.2 to 2.7.1, I doubt any one can help you in that as you are now in the clutches of Apple. You can only revert back if you locate a backup of that App for your mobile.
Sure. For what it's worth I've emailed DJI support. Doubt I'll hear back anytime soon. Some guy on the DJI forums reckons they told him they were working on a fix. Shame, I've have zero issues with this P3P for 9 months. Thanks for your time.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,351
Reaction score
3,056
Location
Western US
Good point, completely forgot about app / device signing. Checked my Mac, can't find any DJI Go .ipa files for either my iPhone or iPad.
I believe that with iOS 9 and later, Apple has removed the ability to save .ipa backups for apps. I think it's in part due to the app thinning that you mentioned earlier.
 
  • Like
Reactions: Jaybee

LuvMyTJ

Admin
Staff Member
Premium Pilot
Joined
Feb 9, 2014
Messages
9,274
Reaction score
5,557
Location
Live! From New York!
I believe that with iOS 9 and later, Apple has removed the ability to save .ipa backups for apps. I think it's in part due to the app thinning that you mentioned earlier.
I am on iOS9 and save my apps, so it can be done. You just make a duplicate of the app from your hard drive.

Open up a finder window and in the column on the left click on - Music> iTunes> iTunes Media> Mobile Applications> find the app you want and drag it to the desktop or a folder.
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
Sure. For what it's worth I've emailed DJI support. Doubt I'll hear back anytime soon. Some guy on the DJI forums reckons they told him they were working on a fix. Shame, I've have zero issues with this P3P for 9 months.
I am on iOS9 and save my apps, so it can be done. You just make a duplicate of the app from your hard drive.

Open up a finder window and in the column on the left click on - Music> iTunes> iTunes Media> Mobile Applications> find the app you want and drag it to the desktop or a folder.
Yeah I used to do that for some apps, but the backup process doesn't seem to put anything in the Mobile Applications folder anymore. There maybe a setting somewhere in iTunes, I'll dig about for future ref.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,351
Reaction score
3,056
Location
Western US
I am on iOS9 and save my apps, so it can be done. You just make a duplicate of the app from your hard drive.

Open up a finder window and in the column on the left click on - Music> iTunes> iTunes Media> Mobile Applications> find the app you want and drag it to the desktop or a folder.
I've also saved apps for many years. Goodness, I have so many that I know I will never use yet I can't bring myself to delete them. Yes, it's a sickness I know.

It was much easier before iOS9. Since iOS9, if your app auto updates on your device or if you manually choose to update on your device separate from iTunes, there is no .ipa to save. Instead of updating directly on your device, you can still download the app in iTunes and save a copy elsewhere before syncing it with your device. Just google "ios9 backup apps" for lots of chatter about it.
 
Last edited:
Joined
Jan 3, 2016
Messages
742
Reaction score
302
Age
67
The updated app works fine on my iPhone 5s and iPad Mini 2.

I think you've got something else going on.

SB
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
The updated app works fine on my iPhone 5s and iPad Mini 2.

I think you've got something else going on.

SB
You running iOS 9.3.1 ?
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
Yes, on both devices.


SB
Out of interest, I'm guessing your devices auto (or you manually) updated, i.e, you didn't clean install the DJI Go app? When I was in the field, initially the camera view worked, but said 'disconnected'. After a few tries I ended up deleting the app and re-installing it. That's when it totally locked me out of the camera view and has since multiple re-installs and an iOS restore.
 
Joined
Jul 2, 2014
Messages
431
Reaction score
88
Age
54
Location
UK-Lancashire
You will need to install the latest FW 1.8 on your P3P before you will get the Go ap 2.7.2 to work - no problem using it here ... after a similar issue on my P3A.
 
Joined
Apr 13, 2015
Messages
117
Reaction score
18
Age
64
Location
Henderson, NV
I am on iOS9 and save my apps, so it can be done. You just make a duplicate of the app from your hard drive.

Open up a finder window and in the column on the left click on - Music> iTunes> iTunes Media> Mobile Applications> find the app you want and drag it to the desktop or a folder.
Is the finder window in the itunes app?
 
Joined
Dec 24, 2013
Messages
373
Reaction score
18
Location
Bristol UK
You will need to install the latest FW 1.8 on your P3P before you will get the Go ap 2.7.2 to work - no problem using it here ... after a similar issue on my P3A.
Thanks will give that a bash.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,351
Reaction score
3,056
Location
Western US
  • Like
Reactions: JoBe

New Threads

Forum statistics

Threads
135,778
Messages
1,404,675
Members
98,855
Latest member
johnvanlit