What's going on with my P3s?

Joined
May 16, 2016
Messages
31
Reaction score
17
Age
28
Alright. Today I charged up my battery on my drone and remote, started remote, connected phone, and started up drone. Drone turns on fine, and the gimbal spins as usual. I get the "no image transmission signal" on my phone and have no picture on the screen, so I pick up the drone to examine the gimbal. Camera falls and points towards the ground as if the drone were off. I try to turn it off and the red light on the battery flashes repeatedly for about 7 seconds. Drone powers off. I try my other battery. Same thing. Repeat a few times. Anybody know what the problem is?


Sent from my iPhone using PhantomPilots
 

Mark The Droner

Premium Pilot
Joined
Aug 26, 2015
Messages
5,316
Reaction score
1,741
I don't have a P3S, but it sounds like you have a bad connection between the gimbal and the AC. A plug might have come loose.
 
Joined
May 16, 2016
Messages
31
Reaction score
17
Age
28
I don't have a P3S, but it sounds like you have a bad connection between the gimbal and the AC. A plug might have come loose.

Alright. Not sure what happened but I took the SD card out and tried to start it up and it worked for some reason. Flew it around for a while with no issues. I think it was a software issue but thanks for your help!


Sent from my iPhone using PhantomPilots
 
Joined
Jun 2, 2014
Messages
223
Reaction score
58
Age
74
P3P cameras will NOT function with a class 4 SD card in them. They will if you are upgrading firmware, but not for filming/flying.
 

New Threads

Members online

Forum statistics

Threads
139,577
Messages
1,439,937
Members
101,357
Latest member
raedra